Thread Tools
Aug 11, 2011, 07:09 PM
Crazy Cessna Owner
Robbie d's Avatar
@Zootster Indeed there is, PZ UM planes and Eflite.
Was thinking about a raptor 50 E conversion, <$200 on 8S. Cheap if I can get a s/h airframe without smelly motor.
Sign up now
to remove ads between posts
Aug 11, 2011, 09:58 PM
Registered User
AdMan's Avatar
Quote:
Originally Posted by Zootster
Is there any OMP products there? It could be .................................................. ......... CHUCKIES shop


Well... No dramas out there whatsoever, just had to wait a little while for the bloke to return and I got what I needed.

There was another bloke there who wanted to start learning to fly... Then he told me what he was going to learn with. He opted for a Spitfire, I told him how hard they are to fly, especially for a beginner. But that didnt change his mind.

Ive just soldered the ESC up... some reason I couldnt get the damn programming card working. Now, the heli wont even spool up, it starts to but just quits. It looks like the positive wire from the windings on the motor has broken, and smells burnt. Something is not happy right now, I wont be when dad finds out.
Last edited by AdMan; Aug 11, 2011 at 10:04 PM.
Aug 12, 2011, 04:12 AM
Registered User
Quote:
Originally Posted by AdMan
Unfortuantely, my dad wont buy anything thats got a Turnigy sticker on it....
As far as Im aware Dualsky is the same exact thing as Hobbywing and Turnigy, I have Turnigy 100a HV in my 600 and it is the same as the Dualsky in every way.....apart from the drug money price the LHS wants for it. You would be surprised how much of this hobby gear is flogged off to us at huge price hikes thanks to a sticker
Aug 12, 2011, 04:15 AM
addicted rc'er
acky's Avatar
had no luck with the f-86 today - grass runway full throttle for about 50m then the motor cut out, now intermittently works to about half throttle and dies, or at 1/4 throttle cuts out see the vid below, any ideas???? motor or esc??
(all connections tight!)
fan f 86 (0 min 40 sec)
Aug 12, 2011, 05:01 AM
The return of the spity
spityman's Avatar
Quote:
Originally Posted by acky
had no luck with the f-86 today - grass runway full throttle for about 50m then the motor cut out, now intermittently works to about half throttle and dies, or at 1/4 throttle cuts out see the vid below, any ideas???? motor or esc??
(all connections tight!)
Hi Acky,

I've had this hapen to me before, on one occasion changing the ESC timing mode and PWM setting together worked, timing mode alone was not enough.
On the second time with a different model, could no nothing but change ESC's. ESC was fine and I am still using it, just in a different combo with a different motor.

Hope this helps.
Bruno
Aug 12, 2011, 05:11 AM
Life begins at transition
Looks ESC related to me... Each time I've killed a motor, they either just don't run, or get reeeeaaaallllyyyy hot.

Can you check with another speedy without completely removing the fan?
Aug 12, 2011, 05:13 AM
Ozzie Express wiggy pilot
SON OF PALEFACE's Avatar
Quote:
Originally Posted by aeromaniac
Why it could of been worse, Yankalilla
Doesnt matter where it is...too rich for me...
Aug 12, 2011, 05:33 AM
addicted rc'er
acky's Avatar
Too late I've pulled the fan, tried checking with a Hyperion 50 amp that was in a 3s prop plane, I get the arming tone but no power to the motor - is that cos the esc is setup for 3s?
Aug 12, 2011, 06:03 AM
Life begins at transition
How many cells are you trying to run it on?
Aug 12, 2011, 06:06 AM
Glow 😡 no no no
I tried to put 6s into a 5s hyperion esc and had the same thing, maybe your esc isnt rated to that number of cells ?.
Aug 12, 2011, 06:39 AM
addicted rc'er
acky's Avatar
Whoops, i need to run 4s and on the back of the Hyperion esc 1-3 cells ..... Anyone got a 50+ amp esc for sale or swap???
Aug 12, 2011, 06:57 AM
Registered User
DOH
Aug 12, 2011, 10:51 PM
jbc
jbc
WHO's your DADDY!!!
jbc's Avatar
Try the fan/motor on your 1-3S hyperion ESC on 3S and see if she spools up to full throttle. Also reset your throttle point from 0-100%. Check your timing on low, med, and high.

Looked to me, especially at the 7 second mark, that she was horribly out of balance. Might be something as simple as the rotor rubbing and getting stuck on the shroud when it hits a specific RPM.
I used to have a horrible vibration at one specific rpm setting on one of my motors, shaft was straight, prop was balanced and I couldn't get rid of it. My only solution was to make sure I didn't keep the throttle at that setting, above and below it was fine and very smooth.

If you still can't sort it I got a test stand you can try it out on here at home. I also got a 4S 50A speedy here which I pulled out of my FMS P47, it's brand new and I never used cos it pulled 49A from the get go and just went and stuck a 60A in it for the maiden.
Aug 12, 2011, 11:51 PM
Registered User
Quote:
Originally Posted by jbc
I used to have a horrible vibration at one specific rpm setting on one of my motors, shaft was straight, prop was balanced and I couldn't get rid of it.
Maybe the shaft was displaying mechanical resonance, matched to the frequency of the motor at that specific troublesom RPM?
Aug 13, 2011, 12:35 AM
addicted rc'er
acky's Avatar
Cool will try it with the 3s, if it's ok I will order a turnigy plush 60, will let ya know Jbc