New Products Flash Sale
Thread Tools
Old Dec 08, 2010, 10:28 AM
HappyKillmore is offline
Find More Posts by HappyKillmore
Suspended Account
No problem, thanks for catching it. I wish Microsoft had a better way to handle it. But I suppose MS doesn't know if 123.456 is One hundred, twenty three point four fifty six or one hundred twenty three thousand, four hundred fifty six.... if "." can be a thousands separator or a decimal separator.
Sign up now
to remove ads between posts
Old Dec 09, 2010, 12:48 PM
HappyKillmore is offline
Find More Posts by HappyKillmore
Suspended Account
Icebear, now update posted with LOTS of testing on other region's settings.

http://code.google.com/p/happykillmo...downloads/list
Old Dec 09, 2010, 02:38 PM
icebear is offline
Find More Posts by icebear
Registered User
icebear's Avatar
Ah, that is wonderful! Thanks a lot - I will try it out immediately!

Cheers,

Björn
Old Dec 09, 2010, 03:31 PM
icebear is offline
Find More Posts by icebear
Registered User
icebear's Avatar
It works - great to see you sorted out the troubling .'s and ,'s!

I just hooked up the GPS from a Picopilot setup and it seems to work just fine. Will try an XBee link soon too...

Great work!

/Björn
Old Dec 09, 2010, 04:33 PM
HappyKillmore is offline
Find More Posts by HappyKillmore
Suspended Account
Nice! I'm hoping to support the PicoPilot's output stream soon too...
Old Dec 10, 2010, 05:10 PM
elossam is offline
Find More Posts by elossam
Registered User
Hi guys, downloaded the latest version available but I got an error message while running it (just one opening the program) It´s not possible to load the file or ensambled "Microsoft. directX.Direct3DX. Version=1.0.902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' nor any of his depencencies. The system can not find the specified file
I´ve read it´s a known problem in some aplications since 2005 at least. Do anyone of you suffered the same trouble and how do you solved?

HK have you plans to make the system compatible with FY20 and FY21AP autopilots?
Thanks and best regards
Old Dec 10, 2010, 05:16 PM
jalves is offline
Find More Posts by jalves
Registered User
jalves's Avatar
Hi HKM,

Your latest GCS executable is not running in my PT system, it crashes before I can see any page except the MS error report window.

maybe the .vs, error?
Old Dec 10, 2010, 05:17 PM
HappyKillmore is offline
Find More Posts by HappyKillmore
Suspended Account
I added a message box to the last post to try and figure out what people are having problems with as far as DirectX. Yours sounds like it will be fixed with this download: http://code.google.com/p/happykillmo...t.exe&can=2&q=

I was unable to see the 3D model on my laptop today and did lots of testing to get it to work. It seems that the initialization routines in DirectX are hardware dependant. So now I'm asking the system about what kind of hardware they have and it fixed the issue on my laptop... can't say for sure about everyone else. If you can post a screenshot of your error message, it may help me figure things out.

Do you have any output files from the FY20 and FY21AP auto-pilots? Is there a protocol specification?

jmralves, can you post the error report?
Old Dec 10, 2010, 05:27 PM
HappyKillmore is offline
Find More Posts by HappyKillmore
Suspended Account
elossam, I found this: http://shop.fyetech.com/product_info...products_id=42

The LOGCON download appears to be a sample flight. But it doesn't look like it was an actual flight. Maybe simulated?

Sample:
#DATA3,-22,3,1523,1324,1000,1500,0*
#DATA2,00,0,0,36,,,,,0,0,000255,010680,35,0,0,0,0*
#DATA3,-22,3,1523,1324,1000,1500,0*
#DATA3,-22,3,1523,1324,1000,1500,0*
#DATA1,0,0,1,2,7,,0,0,0,,,359.47,0,0,0,-0.9,0,0*
#DATA3,-22,3,1523,1324,1000,1500,0*
#DATA2,00,0,0,36,,,,,0,0,000255,010680,35,0,0,0,0*
#DATA3,-22,3,1522,1324,1000,1500,0*

I'm assuming Data 2 has lat, long and alt... maybe speed.
Data 3 looks to be the pitch and roll data
Data 1 Has heading and HDOP

I assume it's all there, just figuring out what variable is what may be a challenge since I haven't found any documentation and this file isn't a very good one... you'll notice that Data 3 doesn't change at all...not possible when reading actual pitch and roll values.
Old Dec 10, 2010, 05:33 PM
airmcn_3 is offline
Find More Posts by airmcn_3
Registered User
This is very cool. Nice to see one GCS work for every AP!

Keep up the great work!
Old Dec 10, 2010, 05:40 PM
elossam is offline
Find More Posts by elossam
Registered User
HK the .exe should be uncompressed in a particular folder?
No idea about the protocol specification, A friend passed me a couple of programs to see how is the output secuences, one is SIOW (Serial input output monitor v 4.03) and the other is TERMINAL V1.9b. Do you think any report of those programs will be usefull for you or maybe a hyperterminal report is enough?
Old Dec 10, 2010, 05:51 PM
elossam is offline
Find More Posts by elossam
Registered User
Topic 71 https://www.rcgroups.com/forums/show...1267515&page=5 I think you will find there what you are asking for.
Old Dec 10, 2010, 06:56 PM
HappyKillmore is offline
Find More Posts by HappyKillmore
Suspended Account
elossam, a hypertem report would be best. The exe doesn't need to go anyplace in particular. Just make sure you unzip everything into one folder (the zip file has the correct directory structure).

I found this page: http://feiyutech.ning.com/profiles/b...oway-data-link which has a 2-way specification. I really like having an actual data file to work with so I can stream the data and parse it correctly. I also tried downloading their GCS.exe from their store and the link is dead. Are they still supporting their GCS?
Old Dec 10, 2010, 07:47 PM
elossam is offline
Find More Posts by elossam
Registered User
HK, look at your PM box Error code solved with the .exe, Will try to get a hyperterm report this weekend.
Thanks.
Old Dec 10, 2010, 11:14 PM
HappyKillmore is offline
Find More Posts by HappyKillmore
Suspended Account
elossam, thanks for the link. What was the cause of the error?

New installer ready for you guys to try: http://code.google.com/p/happykillmo...downloads/list


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Show Us Your Ground Station !!!! FPV Ground Station Design and Idea's found here :) JettPilot FPV Equipment 4630 Today 10:08 AM
Discussion Ground station wiring harness ziomatrixacs FPV Talk 3 Oct 07, 2010 06:48 PM
Discussion DIY Continuous Rotating FPV Ground Station Moosthegoose FPV Talk 37 Sep 29, 2010 05:27 AM
Discussion Aerial Photography request an Autopilot system & Ground Control Station Atflying Aerial Photography 7 Jun 27, 2010 03:13 AM