Shop our Airplanes Products Drone Products Sales
Thread Tools
Oct 31, 2010, 04:54 AM
Registered User
Discussion

Umx beast batt fail....


I just bought my new Eflight UMX Beast, brought it home and set up all the radio adjustments as per the book. made sure everything works, inc the motor for about 30 secs then proceeded to charge the small lipo 2s 120mAh batt that came with it using the inc charger. its been on charge now for about 4 hours and is still blinking red (still charging). anyone else had this problem? Faulty batt out of the box maybe?
Sign up now
to remove ads between posts
Oct 31, 2010, 07:01 AM
Southern Pride
everydayflyer's Avatar
Or perhaps you over-discharged / damaged it by using it before charging it. Lipolys come approx. 40 to 60% charged and must be fully charged before being used.
Oct 31, 2010, 11:01 AM
KC
KC
Registered Loiterer.
KC's Avatar
The UMX Beast looks to be a nice plane. Congrats on your purchase.

Have you checked the Lipo's voltage? It might be a good starting point to see what's happening with your battery.
Oct 31, 2010, 01:58 PM
Team Hitec, Customer Support
Xpress..'s Avatar
You should also not static test for that long. You probably sucked the lipo down too far, and it's not charging.
Oct 31, 2010, 09:32 PM
KC
KC
Registered Loiterer.
KC's Avatar
Looks like he found his answer.

https://www.rcgroups.com/forums/show...postcount=1705


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Official Eflite UMX Beast Owners thread! darksiede Micro Ready-to-Fly 19567 Jan 21, 2017 01:40 PM
Sold Dyn E Max Beast (New) JamF4U Aircraft - Electric - Jets (FS/W) 1 Oct 16, 2010 08:05 AM
Discussion UMX Beast thread. Estoner Scratchbuilt Indoor and Micro Models 3 Sep 30, 2010 02:01 AM
Discussion UMX Beast thread. Estoner Scratchbuilt Indoor and Micro Models 0 Sep 29, 2010 02:49 AM
Discussion Ideal profile UMX Beast Nooflyer Scratchbuilt Indoor and Micro Models 6 Sep 26, 2010 02:26 AM