New Products Flash Sale
Thread Tools
Old Oct 05, 2010, 10:48 AM
nathan089 is offline
Find More Posts by nathan089
Registered User
Discussion

Help with CE OSD


I am having a problem with my CE OSD. Every feature of the OSD is working perfectly except the current meter does not seem to be working. When i have my plane at full throttle it still reads 0.0A. It is reading the correct voltage which i have confirmed with a voltmeter but it is not reading amp current at all. Is there something that i might have to adjust or check, or is this a manufacturing fault.


Cheers
Sign up now
to remove ads between posts
Old Oct 05, 2010, 11:34 AM
marco899 is offline
Find More Posts by marco899
Registered User
Is the input and output correct (maybe you switched sides)?
Old Oct 05, 2010, 11:41 AM
pc_pilot is offline
Find More Posts by pc_pilot
Registered User
I have a similar problem with mine also. The Voltage is correct but the current will not go above 4 amps on mine even though my watt meter shows 14amps.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Ce osd Neo360 FPV Talk 1 Sep 21, 2010 01:54 PM
Help! Help with broken Eagle Tree OSD Pro StealthWorkx FPV Talk 1 Dec 13, 2009 10:52 AM
Discussion Newb Alert! Help with Fatshark Teleporter cam and ET OSD Pro djinni69 FPV Talk 1 Dec 07, 2009 12:28 PM
Discussion Need help with Eagle Tree OSD RTH! Ellis108 FPV Talk 2 Nov 30, 2009 11:28 PM
Discussion Help with my ET OSD Pro & RangeVideo Tx harness Cralis FPV Talk 122 Sep 11, 2009 11:35 AM