Thread Tools
Jul 25, 2010, 03:36 PM
Registered User
Thread OP
Discussion

Blade CX3 flys but turns counterclockwise


I am new to electric helicopters. I do not know what I did. I did install the remote control lights in it. Tested it in my basement after that, flew great and the lights worked. Later that night went out to fly it in the dark(wanted to see the lights in the dark). Connected the battery and something started to smoke. The battery got real hot, I immediately unplugged the battery and turned off the transmitter. Let everything cool down 24 hours. Now when I try to fly it, the rotors spin like they should, I get just over half on the throttle, and the helicopter starts to spin counterclockwise. If I get it enough throttle, it will fly, but again, spins counter clockwise. I have tried all the trim adjustments and even played with the pots on the gyro(I think that is what it is called). Still does the same thing. None of the adjustments I make seem to help at all. Any ideas?
Sign up now
to remove ads between posts
Jul 25, 2010, 09:44 PM
"whirlydude"
flyeraroo's Avatar
Sounds like something shorted out. Can you tell what was smoking? You should be able to smell where it burnt. Where did you have the lights plugged into?
Jul 26, 2010, 10:00 AM
Registered User
Thread OP

Blade CX3 flys but turns counterclockwise


I really cannot say. I was still outside in the dark, not much light. I smelled something and just happened to touch the battery. It was hot so I unplugged it. Brought the CX3 inside and noticed some smoke. Really did not pay much attention to it. I guess I should have. I do notice an electrical smell in the front of the CX3. I think maybe the 3n1 was fried. Sometimes it just blinks red. I have to unplug the battery and plug it back in 2-3 times before it turns green.
I do not think it has anything to do with the lights. When I installed them, I did plug them into the wrong place (GEAR I think), then went online and noticed I need to plug the lights into the AUX. Once I did that, the lights worked liked the were supposed to. I could use the 5th channel to control them. I flew it around for 5-10 minutes. Everything was fine. I did call Hobby Zone and they said to check the gears, which I did and they seem fine. I did see someone else having the same problem, but their CX3 did not fly, just spin couterclockwise. The screw on the shaft was loose so he tightend it up and his works fine now.
Jul 26, 2010, 10:05 AM
Registered User
kodak_jack's Avatar
EFlite (Horizon) screwed up a good thing with the CX3. It's very likely that you burned up an FET for one of the motors. If it is turning counter-clockwise, the motor for the top rotor set is more powerful than the bottom. I'm surprised you're getting lift as the B-blades/ rotor gives you the majority of your lift while the A-blades/ top counteracts it. The 3-in-1's on these heli's have had issues for quite a while now. Contact your LHS or Horizon and see what they say.
Aug 07, 2010, 02:15 PM
Registered User
Thread OP

Blade CX3 6100 receiver problem


I have replaced the 3n1 and that fixed the problem. I noticed the 6100 receiver turns solid red when the 3n1 turns green. When I fly it, the 6100 receiver starts to flash red. Is that normal? The 3n1 is still solid green.


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Sold BNF or RTF Blade MSR like new in box flys perfect charger battery manual blueindian Aircraft - Electric - Helis (FS/W) 6 Jun 04, 2010 12:21 PM
Sold 3 Eflite cx3s everything but rx 3in1 HH gyro rate body bind plug Cx3 Cx2 parts blueindian Aircraft - Electric - Helis (FS/W) 0 May 02, 2010 11:59 PM
Discussion Blade MSr banking counterclockwise 015734 Beginner Training Area (Heli-Electric) 2 Feb 21, 2010 12:19 AM
Discussion Ok,bought used/damaged blade cx2-replaced multi parts, now spins counterclockwise tvtech3 Coaxial Helicopters 5 Jul 11, 2008 01:41 PM
Discussion Blade CP no hover, but turns circles green127045 Mini Helis 3 Mar 13, 2006 05:37 PM