Thread Tools
Jul 18, 2010, 01:34 AM
Angering mobs since 1980.
Twmaster's Avatar
Discussion

Art-Tech EC135/MD500 controller board issue (I think)


I've got one of the A-T EC-135 Speed 370 coax helis. It will not trim out for yaw. It wants to keep doing piros no matter how much trim I try. Holding the stick full opposite will almost tame it into not spinning.

I suspect I have a damaged 3-in-1 controller board. Ideas? Confirmation?

Thanks!

--
Mike N
Orbiting in OK.
Sign up now
to remove ads between posts
Nov 07, 2010, 12:41 AM
Angering mobs since 1980.
Twmaster's Avatar
Chirp...

Chirp..

Nobody?

--
Mike N
Nov 07, 2010, 07:10 AM
Take my money already
jombo's Avatar
its probably the motors, when it usually does that i replace both motors and it works fine again.
http://www.xheli.com/at-44171.html
Nov 07, 2010, 10:31 PM
Angering mobs since 1980.
Twmaster's Avatar
That would be grand if it's just the motors. I'll have to try that next weekend when I have some spare time.

Thank you.

--
Mike N
Nov 07, 2010, 10:45 PM
Si Vis Pacem Para Bellum!
Doubletap's Avatar
I had a coaxial that did this. It could be because the lash between one of the pinion gears and main gears is wrong, namely, too tight or too loose. optimally, your gear lash should beset by just making contact, if it's too little on one of your motors, that would create too much turning resistance.
Nov 09, 2010, 11:57 PM
Angering mobs since 1980.
Twmaster's Avatar
Yea, I've been through the drive system looking for binding. That was the first line of trouble shooting. I bought this used and it has never flown correctly. I have the MD500 and it flies just fine. I just hate to go through the heartburn of swapping parts until I find the culprit.

I'll tinker with it over the weekend as I'm pretty busy with work during the week.

--
Mike N
Mar 02, 2011, 09:06 AM
Registered User
Virginia Jim's Avatar
Yours is an old post, but I just joined this forum, and thought I would chime in.
I hope this suggestion is not exposing my own naivete. Have you tried adjusting the tiny potentiometer that is accessible through a hole in the left side of the cabin to the printed circuit board?
Mine was spinning at first too, but I was able to correct it by careful adjustment of this pot.
Please indicate in your post which version you have. I believe it has sold in both 72mHz and a 2.4ghz versions. Mine is the 2.4ghz version (ArtTech-11044-MD500-24Ghz-GreenHeli), purchased in Jan 2011 from Xheli.
http://www.xheli.com/arttech-2-4ghz-md500-hughes.html
Last edited by Virginia Jim; Mar 02, 2011 at 09:14 AM.
Mar 02, 2011, 05:50 PM
Angering mobs since 1980.
Twmaster's Avatar
72 MHz.

I should have made it clear when I said 'trimmed' I meant the pot on the circuit board. Thanks for the suggestion. Never hurts to point out all options.
Mar 02, 2011, 06:20 PM
Registered User
Virginia Jim's Avatar
Twnmaster:
Thanks for your quick reply. Did you ever resolve your problem? Do you still have your MD500?
Has the consensus opinion on this heli improved at all?


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product Art-Tech MD500 & Eagle Eye deadduck Coaxial Helicopters 27 Aug 20, 2011 02:08 PM
Discussion Art-Tech MD500 Spycopter - flying badly - tx problems - ESC? r00x Coaxial Helicopters 1 Jan 27, 2010 10:39 PM
Sold Art-Tech MD500 visatrade Aircraft - Electric - Helis (FS/W) 4 Mar 21, 2009 07:25 PM
Question MD500 & EC135 JHawk19 Vendor Talk 2 Nov 20, 2008 06:39 AM
Discussion Art-Tech MD500 Racer57 Coaxial Helicopters 5 Aug 12, 2008 05:47 AM