Thread Tools
Old Jul 09, 2010, 01:57 PM
drumbum is offline
Find More Posts by drumbum
Registered User
Discussion

Question about hobbyking Quattro charger


Hey all,

I have a hobbyking quattro charger.

It seems to be a good peace of gear. Can charge 4 batts at once.

But i cant find info in the manual about auto shutting off when charge is complete. My other charger turns off at a pre determined level but the quattro doesnt seem to.

If not, when do i stop charging a lipo.

They get down to about 1 amp charge and sit there for ages.
Sign up now
to remove ads between posts
Old Jul 09, 2010, 02:23 PM
TomBates is offline
Find More Posts by TomBates
Registered User
TomBates's Avatar
I have one of these chargers and it shuts off just advertised, along with the cute little tone

Tom
Old Jul 09, 2010, 03:12 PM
thomaskj is offline
Find More Posts by thomaskj
Registered User
thomaskj's Avatar
I have occationally experienced the Quattro charging a full pack at a very low rate (0,1A) until the timer kicks in at 120min. I usually charge in Balance mode and I've put this behavior down to some of my packs being worn out and failing to balance completely. I have two packs (out of about 10 in frequent use) that has caused this to happen so I'm keeping an extra eye on them. If the problem persists and is isolated to these two packs I'll retire them.

If your charger keeps putting 1A into a full pack I'd be worried though, perhaps you should try to charge the pack in Charge (as opposed to balance) mode and see if this makes any difference?
Does the charger exhibit the same behavior on all ports and with all your packs?
Old Jul 09, 2010, 05:25 PM
hoppy is offline
Find More Posts by hoppy
Space Coast USA
hoppy's Avatar
Balance mode - charge mode - all the same in my experience.
My guess is that the cells were out of balance and the charger was trying to correct things.

Is this a pack that hasn't been balanced recently?
Old Jul 09, 2010, 07:40 PM
JoeSantora is offline
Find More Posts by JoeSantora
Registered User
Quote:
Originally Posted by hoppy View Post
Balance mode - charge mode - all the same in my experience.
Not in mine. Charge mode charges without ballancing.
Old Jul 09, 2010, 11:13 PM
hoppy is offline
Find More Posts by hoppy
Space Coast USA
hoppy's Avatar
Quote:
Originally Posted by JoeSantora View Post
Not in mine. Charge mode charges without balancing.
If you mean it doesn't balance if the balance plug isn't connected during the Charge mode operation, you are correct. I should have said, if the balancing connector is connected, it balances in both Charge and Balance modes.

However, if the balance plug is connected during Charge mode, I believe it balances the pack.
This is based on:
(1) When I am in Charge mode and press the INC key, the individual voltages show up and every time they all end up at 4.19-4.2V. and
(2) If the balance lead is disconnected when using the Charge mode the charger faults and stops.

Did you mean yours doesn't balance in the charge mode even if the balance connector is connected. What leads you to believe that?
Old Jul 10, 2010, 08:12 PM
JoeSantora is offline
Find More Posts by JoeSantora
Registered User
Quote:
Originally Posted by hoppy View Post
Did you mean yours doesn't balance in the charge mode even if the balance connector is connected. What leads you to believe that?
No Hoppy, I just ment that there was a difference between a chargers "charge' and "balance" modes.

Joe
Old Jul 10, 2010, 09:03 PM
hoppy is offline
Find More Posts by hoppy
Space Coast USA
hoppy's Avatar
Quote:
Originally Posted by JoeSantora View Post
No Hoppy, I just ment that there was a difference between a chargers "charge' and "balance" modes.

Joe
What differences are you seeing that makes you think there is a difference (assuming balance connector connected in both cases)?
Old Jul 11, 2010, 05:20 PM
earlwb is offline
Find More Posts by earlwb
Registered User
earlwb's Avatar
I used to think that the charge versus balance mode were different on the Quattro. But in the Quattro charger's case, if you plug in the balance connector on the battery pack, either mode appears to balance just fine. A few people have tested it and stated it works the same for both modes if you plug in the balance jack too.
I do have some other chargers where the charge and balance modes are different though.
RCG Plus Member
Old Jul 11, 2010, 09:04 PM
drumbum is offline
Find More Posts by drumbum
Registered User
ey all,

thanks for the info.

I have tried several lipos 3s and 4s and have had the same issue. It just hangs up at 1a charge and goes up to 2 hours - I have not let it go to the cutoff at 2 hours yet. All batts are reasonably used and always balanced on my good charger/balancer thingy. One lipo was almost new.
Old Jul 11, 2010, 09:43 PM
hoppy is offline
Find More Posts by hoppy
Space Coast USA
hoppy's Avatar
Quote:
Originally Posted by drumbum View Post
ey all,

thanks for the info.

I have tried several lipos 3s and 4s and have had the same issue. It just hangs up at 1a charge and goes up to 2 hours - I have not let it go to the cutoff at 2 hours yet. All batts are reasonably used and always balanced on my good charger/balancer thingy. One lipo was almost new.
What size lipos?
What charge rate did you set?
Old Jul 13, 2010, 07:31 PM
drumbum is offline
Find More Posts by drumbum
Registered User
finally figuring out how it works. It came with no manual so i downloaded it from the web but its blurry and hard to read.

I am charging as we speak a 4s 2200 mah lipo but i have upped it from 1a charge to 2a. Will this make things faster?

Also, on another thread about the squall - i cant fond the page now - someone mentioned not to run lipos down to below 20% of milliamps. How do you k now how many mah are used - the charger does not display it?

regards, thanks for the input
Old Jul 13, 2010, 10:53 PM
hoppy is offline
Find More Posts by hoppy
Space Coast USA
hoppy's Avatar
The Quattro does display the mah put back in. Ideally, you should fly only long enough so the "put back in" mah is less than 80% of the mah capacity of the pack.
For instance, with a 2000mah pack, 80% would be 1600mah. So when charging, the amount put back in should be less than 1600mah. That number is displayed on the Quattro charger.

Charging at 2A, will cut the charge time in 1/2.
Old Jul 18, 2010, 05:26 PM
drumbum is offline
Find More Posts by drumbum
Registered User
thanks all. I have stumbled across the answers.

Turns out its a really good purchase.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Mini-Review A First Look at the HobbyKing Quattro 4 channel charger kit Batteries and Chargers 270 Nov 19, 2016 11:28 AM
Discussion ? about hobby king quattro 4 port charger reptileman Batteries and Chargers 9 Jun 18, 2010 11:01 PM
Discussion HobbyKing Quattro 4x6 Charger bkseyer Batteries and Chargers 17 Apr 30, 2010 10:24 PM
Sold HobbyKing Quattro 4x6S Lithium Polymer Multi Charger $99.99 Shipped Mikey 68 Aircraft - Electric - Batteries & Chargers (FS/W) 5 Apr 13, 2010 12:28 PM
Discussion Question about thunder ac6 charger. sbeirs Batteries and Chargers 3 Jan 19, 2010 09:31 AM