E-flite Blade SR 120 Thread. - Page 975 - RC Groups
Shop our Airplanes Products Drone Products Sales
Thread Tools
Aug 07, 2012, 02:52 PM
Look ma, no hands!
1Pilgrim's Avatar
Quote:
Originally Posted by KYChopper
On a different note, the wind gods finally cooperated yesterday and I was able to take my 120 outside for a flight. It seems that it had very little power for FFF; otherwise it acted normally. Could this be a case of a tired old main motor or is this common?
So did you notice a loss of power on takeoff, i.e. how fast could you climb straight up?
Sign up now
to remove ads between posts
Aug 07, 2012, 03:04 PM
Newbie but coming on fast
KYChopper's Avatar
Quote:
Originally Posted by 1Pilgrim
So did you notice a loss of power on takeoff, i.e. how fast could you climb straight up?
It seemed to climb just fine but really struggled moving forward. But then again, I bought it used so I do not know how it acted when new.
Aug 07, 2012, 05:46 PM
Look ma, no hands!
1Pilgrim's Avatar
Quote:
Originally Posted by KYChopper
It seemed to climb just fine but really struggled moving forward. But then again, I bought it used so I do not know how it acted when new.
If it climbs okay then it may not be the motor. If you haven't already done so, here are some more things to check off:
Are the links ("dog bones" lol) coming down from the fly bar connected to the short balls on the swash? They should be.
Is your tx on high rates? It should be.
How much forward trim do you have dialed in on your tx?
Aug 07, 2012, 09:54 PM
Jake From Planet Mascoutah, IL
Jake8131's Avatar
Since you say you bought it used, did it come with its own transmitter? If so, make sure the trims are at neutral . Does it backwards very fast? If so, the servo rod needs to be adjusted.
Aug 07, 2012, 10:06 PM
Scout CX | mCX2 | mSR | 120SR
North_of_49's Avatar
1Pilgrim...

... don't you mean the longer balls?
Last edited by North_of_49; Aug 07, 2012 at 10:14 PM.
Aug 08, 2012, 02:22 AM
Jake From Planet Mascoutah, IL
Jake8131's Avatar
Quote:
Originally Posted by North_of_49
1Pilgrim...

... don't you mean the longer balls?
No the servo rods connected to the swash. One of them needs to be turned down two full turns.
Aug 08, 2012, 07:15 AM
Scout CX | mCX2 | mSR | 120SR
North_of_49's Avatar
No, I thought he was saying you need the flybar connected to the short balls for more swash movement... he specifically mentioned flybar to swash.
Aug 08, 2012, 08:19 AM
Epilepsy Awareness
Chap1012's Avatar
Quote:
Originally Posted by 1Pilgrim
If it climbs okay then it may not be the motor. If you haven't already done so, here are some more things to check off:
Are the links ("dog bones" lol) coming down from the fly bar connected to the short balls on the swash? They should be.
Is your tx on high rates? It should be.
How much forward trim do you have dialed in on your tx?
I think what Pilgrim meant "are the links connected to the long balls on the swashplate". Look close. There are a set of short balls and long balls on the swashplate. The links should be on the long balls.

You Guys really need to quote each other. Other wise everything turns into a circle jerk and gets confusing

Mike.
Aug 08, 2012, 10:14 AM
Rock-n-Aileron Roll!
Saxguy1000's Avatar
"Circle jerk" must be a Navy technical term?
Aug 08, 2012, 10:38 AM
Epilepsy Awareness
Chap1012's Avatar
Quote:
Originally Posted by Saxguy1000
"Circle jerk" must be a Navy technical term?
Actually it's a boyhood term in becoming an early teen. Hint: In the Navy, one would do it in private as an adult

Mike.
Aug 08, 2012, 12:37 PM
Registered User
WhalleyB0Y's Avatar
Quote:
Originally Posted by Chap1012
The stock battery tray should not "flip" or move. It's held in place by a single screw (also for the front motor screw). Take a good look at it, as it could be broke. Many of us use the velcro mod including myself.
http://astroid-designs.myshopify.com...-battery-mount

Mike.
I was looking at this and I think it is a really good product. In the description it mentions a zip tie mod around the motor but doesn't elaborate. What is that for?
Aug 08, 2012, 12:48 PM
High Plains Drifter...
BattleDude's Avatar
Quote:
Originally Posted by WhalleyB0Y
I was looking at this and I think it is a really good product. In the description it mentions a zip tie mod around the motor but doesn't elaborate. What is that for?
The zip tie is for the purpose of keeping the main motor from flexing, thus preventing the clearance between the motor pinion gear, and main gear from changing under torque.

It is a good idea, but I prefer a spot of adhesive(I use silcone)between the motor and the brace that is there to prevent flexing.

I prefer silicone as I believe there is a significant chance that the zip tie could be over tightened, or come loose in time.

Also the battery mount is a good one, especially for larger non-stock batteries, but the stock battery mount always breaks in the same place. I re-inforce the brand new stock battery mount, in the weak spot, with Shoo-Goo. Never had a problem since I started doing this.

BD
Last edited by BattleDude; Aug 08, 2012 at 01:06 PM. Reason: Spelling
Aug 08, 2012, 05:35 PM
Registered User
Mickmeister's Avatar
I finally found the fix for the fishtailing tail wag bug I was talking about a while back. I had already checked the usual suspects - good tail motor and rotor, no cracks in the tailboom, no cracks in main shaft or rotor head (which can be suspect if there's excess tail vibration). I I had also checked the wiring coming from the 5-in-1, as well as the connector on either end, by replacing it with an old wire/connector set from a broken boom (which allows you to easily bypass the existing internal wire without messing with it, to see if it's causing the problem).

After ruling out all these things, it turned out that the problem was with the wire pair coming from the 5-in-1 going to the connector that leads to the tail motor wire. These are incredibly flimsy. If there are any kinks or defects in these wires (which may or may not be visible), re-do the solder connection to the board. It's easier and more secure to solder them to the opposite side of the board from where they were originally. I took it one step further by removing the flimsy stock wires/connector and instead using the wires/connector from a Walkera Genius tailboom. This connector/wire is a little more solid than the 120SR stock, and mates well with the Blade connector, despite the 2 different brands.

Since the solder job I haven't had any tail hold problems.
Aug 08, 2012, 05:48 PM
Look ma, no hands!
1Pilgrim's Avatar
Quote:
Originally Posted by Chap1012
I think what Pilgrim meant "are the links connected to the long balls on the swashplate". Look close. There are a set of short balls and long balls on the swashplate. The links should be on the long balls.
Mike.
Busted! You'd think after flying my 120 for more than a year I'd know which balls to use. The last time I changed out the main shaft I put it back together wrong and then shared some bad intel here.

It worked out okay for me since I've only been able to fly indoors for the last week or so. Luckily I didn't try to fly outside - the lack of response could have been fatal! Hope I didn't mess up anybody else.
Aug 08, 2012, 06:31 PM
Registered User
venicebill's Avatar
Still under the wx but back in FL from VT and flew my stock 120SR this morning early before the breeze picked up..Been catching up on the thread..always interesting and informative,,Good to be back home after a nice vacation in VT..Hapyy flying


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product Blade SR RTF Electric Micro Heli by E-flite ghost2212 Micro Helis 6658 Oct 28, 2015 09:24 AM
Discussion Update Blade CP or buy E-Flite Blade SR or 400? markhwing Electric Heli Talk 10 Aug 06, 2012 04:16 PM
Link E-flite mSR batteries E flite 110-120 Hyp.CX 120 and others everydayflyer Batteries and Chargers 45 Apr 08, 2010 05:55 AM
For Sale Did you just buy a new E-Flite Blade SR? Z06 Tony Aircraft - Electric - Helis (FS/W) 3 Feb 28, 2010 01:01 AM
New Product Blade SR RTF Electric Micro Heli by E-flite ghost2212 Micro Ready-to-Fly 2 Jan 07, 2010 10:36 AM