New Products Flash Sale
Thread Tools
Old Jul 08, 2010, 12:09 PM
cdi3d is offline
Find More Posts by cdi3d
Brushless
cdi3d's Avatar
Alex - Is there any way to test a WMP+ to see if it is still functioning - All I did was change batteries and I went from flying to no flying - No green light - I double checked all connections and still nothing - Any ideas? WMP+ is an original - Seems like my WMP+ is dead

Mike

Okay I just tried a bad WMP+ and something must have happened to my original - not sure what because I am getting a green light now -
Last edited by cdi3d; Jul 08, 2010 at 12:40 PM.
Sign up now
to remove ads between posts
Old Jul 08, 2010, 01:02 PM
ddrake is offline
Find More Posts by ddrake
Registered User
ddrake's Avatar
Quote:
Originally Posted by cdi3d View Post
Alex - Is there any way to test a WMP+ to see if it is still functioning - All I did was change batteries and I went from flying to no flying - No green light - I double checked all connections and still nothing - Any ideas? WMP+ is an original - Seems like my WMP+ is dead

Mike

Okay I just tried a bad WMP+ and something must have happened to my original - not sure what because I am getting a green light now -
Glad you solved. It may have been stated before but a quick search didn't bring it up.
Anyway some may find this helpful: Knuckles904 & GlacialWanderer from the Arduino forum have made the code both to test and have a graphic response of the wmp.
http://www.arduino.cc/cgi-bin/yabb2/...=1245723011/15
See posts 17 & 18

Regards
Old Jul 08, 2010, 02:06 PM
cdi3d is offline
Find More Posts by cdi3d
Brushless
cdi3d's Avatar
Okay - I just wired in my old WMP+ (the bad version) and the tri seems to be flying - Oscillation is pretty bad so I am going to test it for a while - Has anyone found a good fake replacement for the original on ebay? Thanks

Mike

Nevermind - IC2 dropout I think - Just flipped over after a few minutes of flying - motors were really hot along with ESC's - I think I will be upgrading soon - Once I get a new WMP+
Last edited by cdi3d; Jul 09, 2010 at 10:30 AM.
Old Jul 14, 2010, 11:38 AM
wland is offline
Find More Posts by wland
Registered User
I just finished my tricopter. Thanks alex.
On sat I'll test my tricopter in official.
I did test flight in a few second in my livingroom.
she's good.
I used prop normal-2ea, reverse-1ea.
Old Jul 14, 2010, 01:22 PM
Sid3ways is offline
Find More Posts by Sid3ways
DJI Supporter
Sid3ways's Avatar
It is amazing something so simple flies so well. Still haven't gotten to the wiring of the boards yet But I will very soon.
Old Jul 14, 2010, 07:58 PM
Alexinparis is offline
Find More Posts by Alexinparis
Registered User
Alexinparis's Avatar
Quote:
Originally Posted by wland View Post
I just finished my tricopter. Thanks alex.
On sat I'll test my tricopter in official.
I did test flight in a few second in my livingroom.
she's good.
I used prop normal-2ea, reverse-1ea.
Hi Yun,
Thank you for your feedback.
I hope everything will go right this week.
Old Jul 15, 2010, 11:22 AM
tazdevil is offline
Find More Posts by tazdevil
FPV Junkie
tazdevil's Avatar
oh year it's flying well !!

need to rebuilt my yaw mecanic ,cause mecanical game create a lot of oscillation in yaw axes..

need to find a good solution and easy to reproduce for this...
Last edited by tazdevil; Jul 15, 2010 at 04:09 PM.
Old Jul 16, 2010, 01:52 PM
Alexinparis is offline
Find More Posts by Alexinparis
Registered User
Alexinparis's Avatar
Hi,

These days I played a lot with processing (processing.org) and have just finished the first version of a GUI for TriiWiiCopter. Processing is a very good approach to build rapidly a GUI with java rudiments, and it is free!
The principle of the GUI is quite simple:
  • 1)switch on your TX
  • 2)plug usb to power the arduino. choose the good serial com port in the gui
  • 3)wait for the green LED (your RX must be also powered)
  • 4)then (only after this step) you can graph values and read/write parameters


http://radio-commande.com/wp-content...iWiiConfV1.zip
http://radio-commande.com/wp-content...riwii_V2_0.zip


I also updated TriiWii soft to V2.0 in order to manage the serial communication and added some new functionalities.
Change summary:
  • GUI: graphical visualisation of computed RC stick values, RC motor values, gyro values evolution. Now it should be easy to configure RC channels form the radio to match exactly the range [1000;2000], and to know what to reverse.
  • GUI: possibility for READ and WRITE PID parameters for NICK/ROLL/YAW
  • GUI: ACC ready (nunchuk), for future development in the TriiWii code (not ready)
  • TriWii: full throttle allows now the gyro to still apply good corrections
  • TriWii: PID values for ROLL and NICK are now independent when configured from the GUI. It should be useful for strange WMP copies where ROLL and NICK sensibility is different. However, a configuration from the LCD will be still global for ROLL and NICK.
  • LCD: P_YAW is now configurable from LCD

Note: Still be careful. Do not plug USB when your motor are powered on, do it before or do it with motor not powered.

Enjoy
Old Jul 16, 2010, 04:09 PM
RCvertt is offline
Find More Posts by RCvertt
Registered User
RCvertt's Avatar
Quote:
Originally Posted by Alexinparis View Post
...These days I played a lot with processing (processing.org) and have just finished the first version of a GUI for TriiWiiCopter...
That looks great! Can't wait to play with it.

Just change the word "Nick" to "Pitch" and it'll be perfect
Old Jul 16, 2010, 05:08 PM
tazdevil is offline
Find More Posts by tazdevil
FPV Junkie
tazdevil's Avatar
yeahhhhhhhhhhh!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

good new ...

I've got somethingto do this monday ...

thxs alex
Old Jul 16, 2010, 11:18 PM
JimnAz is offline
Find More Posts by JimnAz
Registered User
Quote:
Originally Posted by Alexinparis View Post
Hi,

These days I played a lot with processing (processing.org) and have just finished the first version of a GUI for TriiWiiCopter. Processing is a very good
Enjoy
Hey Alex.

Great job.........but there is a problem.

I downloaded the v2.0 file, compiled it, loaded it in my Pro-mini, then tried to run the WiiConfiguration application you wrote.

It will not run on my machine. It says the javaw.exe file cannot be found.

I am running Windows7 professional 64bit. Do I need to have Processing installed? Would it be possible to get the Processing file to run it in Processing instead of a stand alone application?

Thanks.

Jim
Old Jul 17, 2010, 04:37 AM
Alexinparis is offline
Find More Posts by Alexinparis
Registered User
Alexinparis's Avatar
Quote:
Originally Posted by JimnAz View Post
Hey Alex.

Great job.........but there is a problem.

I downloaded the v2.0 file, compiled it, loaded it in my Pro-mini, then tried to run the WiiConfiguration application you wrote.

It will not run on my machine. It says the javaw.exe file cannot be found.

I am running Windows7 professional 64bit. Do I need to have Processing installed? Would it be possible to get the Processing file to run it in Processing instead of a stand alone application?

Thanks.

Jim
Hi,
If your windows version does not already include java,
you can download and install it directly from sun site.
Select the JRE (Java runtime) here:
http://java.sun.com/javase/downloads/index.jsp

The full installation of processing should not be required to run TriWiiconf
Old Jul 17, 2010, 10:49 AM
wland is offline
Find More Posts by wland
Registered User
I tried triwiicfg.
thanks Alex.
http://www.youtube.com/watch?v=OKiTC-u-YAQ
Old Jul 17, 2010, 06:01 PM
kitemaker is offline
Find More Posts by kitemaker
Registered User
Alex,

re Good or bad WM+ copy??

I'm collecting the parts to make my TriWiiCopter. Thanks for this clever design work!

Yesterday I received WM+ from ebay seller "wanghonmei-ey" $10/pc. (the same seller you recommended in post#109). Here are photos of the board:

So, I'm confused - this board looks exactly like the 'bad WM+ copy' you show in post #103. You say the problem is due to unreliable I2c communications. Is there a simple sketch I/ we can use to test these WM+, to make sure the board is good and to avoid problems with crazy motors and propellers?

thanks,
Ken
Old Jul 18, 2010, 12:03 AM
Alexinparis is offline
Find More Posts by Alexinparis
Registered User
Alexinparis's Avatar
Quote:
Originally Posted by kitemaker View Post
So, I'm confused - this board looks exactly like the 'bad WM+ copy' you show in post #103. You say the problem is due to unreliable I2c communications. Is there a simple sketch I/ we can use to test these WM+, to make sure the board is good and to avoid problems with crazy motors and propellers?
Hi,

I'm also confused because I reorder also from the same seller a WM+ and got this time 2 days ago this copy. It seems he changed his source.
I'm going to write a specific sketch with WM+ only to see what happen exactly with I2C. There is maybe a tuning optimization that can be done to still use this copy, but not sure.


Thread Tools