Shop our Airplanes Products Drone Products Sales
Thread Tools
Old Apr 24, 2010, 07:20 AM
karosi is offline
Find More Posts by karosi
Registered User
Question

Cessna 182 (980 mm, EPO) Art-Tech


Hi all,

I have bought an 'Art-Tech Cessna 182 Skaylane 2.4GHZ RTF V3 EPO mit Simulator BLAU' several days ago from hobbyfly.de. It was nice and it has worked properly. However, I tried to disconnect the battery from the speed controller by a small screwdriver. The connection was very-very tight. During this manipulation sparks have occured. Now the plane does not operate, only a continuous bipping from the brushless motor can be hear. The servos are pulsating. It does not referr to the radio signs. Is the problem great? What should I do?

Thanks, Tamás Karosi
Sign up now
to remove ads between posts
Old Apr 24, 2010, 03:21 PM
Xpress.. is offline
Find More Posts by Xpress..
Team Hitec, Customer Support
Xpress..'s Avatar
Sounds like you fried something.

NEVER use a screwdriver to unplug a battery!!!!!!
Old Apr 25, 2010, 09:38 AM
fmw is offline
fmw
Find More Posts by fmw
fmw
Registered User
fmw's Avatar
If you shorted the battery terminals then you can discard and replace the battery. You may have to replace more than that but start with the battery.
Old Apr 27, 2010, 03:38 PM
avt is offline
avt
Find More Posts by avt
avt
Hell Flyer
If you have another battery, try it.
If the problem is not solved - look for a new ESC.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion How to install Spektrum DX6i in Art-Tech Cessna 182 V2 kahays77 Electric Plane Talk 9 Jul 01, 2015 02:01 PM
Discussion Art-Tech Cessna 182 Version 2 tagmann50 Parkflyers 0 Apr 09, 2010 03:38 AM
Discussion Art Tech Cessna 182 nitro conversion !!! ryank Fuel Plane Talk 8 Sep 08, 2009 03:10 PM