Eflite blade mCX2 - Page 44 - RC Groups
Thread Tools
Dec 22, 2010, 09:33 AM
NEVER GIVE UP!
Brooklynstar23's Avatar
I tried to bind this to my Dx5e and the heli went completely insane wanting to just spin left...i tried to adjust my trims but it didnt do anything...am i missing something?
Sign up now
to remove ads between posts
Dec 22, 2010, 03:32 PM
Registered User
JimL's Avatar
Quote:
Originally Posted by Brooklynstar23
I tried to bind this to my Dx5e and the heli went completely insane wanting to just spin left...i tried to adjust my trims but it didnt do anything...am i missing something?
Maybe you already know this but one possible problem could be that the gyro did not stabilize.
Assuming the mcx2 is bound to the dx5e, the procedure to fly should be:

Turn on the dx5e
Connect the battery to the mcx2
Immediately set the heli down the heli must be at rest for a short period to allow the gyro to initialize.
After a few second delay the blue light in the heli will turn on solid.
The heli should be ready to fly. (If the heli was not still after connecting the battery then the gyro did not stabilize and you will not be able to control the heli).

The manual talks about this on page 13.
Dec 22, 2010, 03:55 PM
Registered User
DoomsDay's Avatar
Quote:
Originally Posted by JimL
Maybe you already know this but one possible problem could be that the gyro did not stabilize.
Assuming the mcx2 is bound to the dx5e, the procedure to fly should be:

Turn on the dx5e
Connect the battery to the mcx2
Immediately set the heli down the heli must be at rest for a short period to allow the gyro to initialize.
After a few second delay the blue light in the heli will turn on solid.
The heli should be ready to fly. (If the heli was not still after connecting the battery then the gyro did not stabilize and you will not be able to control the heli).

The manual talks about this on page 13.
I disagree about the gyro part. It is simply not that sensitive. Worst case scenario from violently shaking the heli while it initializes produces a heli that will be a little out of trim. At least that is the results I have had on mine and I did do a lot of testing on that.
Dec 22, 2010, 04:02 PM
Must not buy more planes!
mclarkson's Avatar
Are both blades spinning properly? Sometimes, one of my blades doesn't want to spin up.
Dec 22, 2010, 06:43 PM
Registered User
Anyone have one of these 4 Battery Charger Adapter? Are they ok or shall i just but a eflite 4 port charger?

http://tinyurl.com/28mjbpg
Dec 22, 2010, 06:46 PM
NEVER GIVE UP!
Brooklynstar23's Avatar
Quote:
Originally Posted by JimL
Maybe you already know this but one possible problem could be that the gyro did not stabilize.
Assuming the mcx2 is bound to the dx5e, the procedure to fly should be:

Turn on the dx5e
Connect the battery to the mcx2
Immediately set the heli down the heli must be at rest for a short period to allow the gyro to initialize.
After a few second delay the blue light in the heli will turn on solid.
The heli should be ready to fly. (If the heli was not still after connecting the battery then the gyro did not stabilize and you will not be able to control the heli).

The manual talks about this on page 13.

Yeah it's not that I always adhere to the rules but the second I give throttle it freaks out I dunno why the gyro does stabilize though...I'm at a loss
Dec 22, 2010, 07:31 PM
Registered User
DoomsDay's Avatar
Quote:
Originally Posted by Brooklynstar23
Yeah it's not that I always adhere to the rules but the second I give throttle it freaks out I dunno why the gyro does stabilize though...I'm at a loss
Try resetting the dx5e back to neutral settings and then rebind the helicopter to it.
Dec 23, 2010, 08:43 AM
NEVER GIVE UP!
Brooklynstar23's Avatar
Quote:
Originally Posted by DoomsDay
Try resetting the dx5e back to neutral settings and then rebind the helicopter to it.
Did that...tried it 4 times....still with the same result...trimming it doesnt fix the problem...could it be that this heli simply just doesnt play nice with my dx5e? any one else encounter this problem with their dx5e? I know, I know...i should invest in the dx6i but money is too tight for that ...
Dec 23, 2010, 08:57 AM
Master Of My Universe
scotsoft's Avatar
Quote:
Originally Posted by padge993
Anyone have one of these 4 Battery Charger Adapter? Are they ok or shall i just but a eflite 4 port charger?

http://tinyurl.com/28mjbpg
Having read what you need to do with this charging lead, I don't think I would want to trust my batteries with it .

I have the E-flite four battery charger and each battery has it's own LED, batteries are too expensive to be charged trial and error - but that is just my opinion and others may disagree
Dec 23, 2010, 09:56 AM
Registered User
I have hooked my FHX (based on the mcx2) to the dx5e and it works fine. I did notice I had to reverse switch the ailerons so that all the servo switch are down.

I got my dx5e as part of a Phoenix flight sim package.
Dec 23, 2010, 11:31 AM
NEVER GIVE UP!
Brooklynstar23's Avatar
Quote:
Originally Posted by ronhawker
I have hooked my FHX (based on the mcx2) to the dx5e and it works fine. I did notice I had to reverse switch the ailerons so that all the servo switch are down.

I got my dx5e as part of a Phoenix flight sim package.
so every servo switch on ur dx5e is in the down position? guess ill try that..
Dec 23, 2010, 03:08 PM
Registered User
Quote:
Originally Posted by scotsoft
Having read what you need to do with this charging lead, I don't think I would want to trust my batteries with it .

I have the E-flite four battery charger and each battery has it's own LED, batteries are too expensive to be charged trial and error - but that is just my opinion and others may disagree
Thanks for that 4 port it is then.
Dec 23, 2010, 04:13 PM
Registered User
Is $95 shipped from Amazon a good price?
Dec 23, 2010, 04:24 PM
NEVER GIVE UP!
Brooklynstar23's Avatar
Quote:
Originally Posted by felix21685
Is $95 shipped from Amazon a good price?

For the mcx2? Yes, atleast thats what I paid for it...dont forget to get the ac adapter if you dont already have one...unless you wanna keep burning through AA batteries...
Dec 23, 2010, 08:04 PM
Registered User

Servo problem


Today after a small crash i went to take of again and the chopper keep taking a hard left so i pulled of the body and had a look. It looks like one of my servos is dead or jammed. Any ideas what i can try?


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Sold Eflite Blade MSR Plus 2.4ghz Eflite Transmitter soaringcam Aircraft - Electric - Helis (FS/W) 4 Apr 07, 2010 11:27 AM
Sold EFLITE BLADE MSR+BLADE 400+DX6i dhmojo Aircraft - Electric - Helis (FS/W) 7 Mar 29, 2010 11:38 PM
Sold Blade MCX2 LNIB mgroves Aircraft - Electric - Helis (FS/W) 1 Mar 23, 2010 12:17 PM
For Sale Trade, eflite blades for eflite blades....Sell Blade CP Pro NIB with extras. kdill2160 Aircraft - Electric - Helis (FS/W) 1 Sep 02, 2006 10:28 AM
Alert Eflite Blade CX - 2nd Eflite heli jschenck Coaxial Helicopters 26 Oct 24, 2005 02:48 AM