8.38 install problem? (XP) - RC Groups
Thread Tools
Mar 28, 2010, 08:31 PM
Registered User

8.38 install problem? (XP)

I can't seem to get past the 8.38 unpack part of the install. Diaslog box disappears and no installing box appears... 8.31 install's without a problem as did 8.37..

Anyone else seeing this?
Sign up now
to remove ads between posts
Mar 29, 2010, 04:04 AM
Registered User
cvandenb's Avatar
I've reported this with two earlier software releases and to date, no resolution or attempt to assist in resolving these problems. Very disappointed.
Mar 29, 2010, 01:52 PM
billpa's Avatar
This is so odd. We are not changing the setup program - definitely no changes from 8.37 to 8.38.

Charl, I think we must have had a comms breakdown. We did quite a bit of work based on your problem report - I added back (and subsequently removed) a built-in installer to see if that addressed it, and we tried reproducing it on XP and other PC's here. You let us know that you'd tried these things (and mentioned you noticed the size changes), so I thought we were in communication. I think what must have happened is that I thought Don was communicating status to you, and he may have thought I was. Sorry about that. But, I thought you said you found a solution to the problem by using different setup steps?

Sigh - what to do now?
Mar 29, 2010, 03:51 PM
Registered User
I wonder if this might be to do with anti virus / "leave the PC alone" programs? After the unpack part, I usually get a do you want to allow this program to continue from Kaspersky...
Mar 29, 2010, 06:44 PM
Registered User
Bill can probably shed some more light on this, but I believe the installer may need some sort of Administrator privilege. If you're using an anti-virus program that blocks the calls that need Administrator privilege, the installer will probably fail.

I'm going to go out on a limb here and say that the downloads direct from EagleTree.com should be safe.


Mar 29, 2010, 07:05 PM
Registered User
I think there might have been a couple of releases that could fail that test! lol...

This problem was with XP on the same PC that all versions before and the one after (8.40) went in fine.

I did do a cold boot between the attempts incase something was hung up with no difference. If they do fail, at least in my experience, they've done so elegantly and don't just die like this one did...

8.37 has gone now and 8.40 is the beta on offer... Hopefully one problem we wont see again!
Apr 07, 2010, 03:16 PM
Registered User
cvandenb's Avatar
Hi Bill,

Thanks for the feedback. No, i did not receive any emails and that may have been the problem. I'm always very willing to assist you with the testing.

I have re-opened the fault ticket for this problem and really need your help to resolve this.
Nothing has changed on my laptop as its sole purpose is to run ET software for my planes. I resorted to this a while back when the ET stopped working on my work Laptop using the OSD Pro.

Thanks in advance and looking forward to hearing from you...
Apr 08, 2010, 06:49 PM
billpa's Avatar
Hi Charl,

We're a bit flummoxed by this error. I think we've had two reports, but the other has been intermittent. We have not been able to reproduce it here.

Until we sort it out, I think you are unable to install (albeit painfully)?

Can you have a look at this, and see if it might fix your problem?

Apr 08, 2010, 06:55 PM
billpa's Avatar
Charl, I found one other suggestion, from Microsoft, but this may say the same thing:


I am wondering if there was a recent XP update that is causing this. I'm not sure our XP SP3 machine has all the latest updates. Will check on that.
Apr 08, 2010, 08:48 PM
Registered User
cvandenb's Avatar
Hi Bill,

Thank you for the suggestions...

I tried all the steps in both the Microsoft support threads, but still no luck.

I dont have this specific problem though. What happens is that it unpacks your EXE, and then says its not a valid install (.msi), and i have to contact the supplier.

Now, what i do is run your EXE, and it does the above and fails. But on the PC it has unpacked itself and i can get hold of the .MSI file...
So, then all i do is manually running the commands your installer should be doing...

So i run msiexec /a rc.msi (renamed "RC Data Recorder (Beta Version).msi")
Then i choose a temp directory and the .msi unpacks
i then go into the temp directory
Then i simply go into the temp directory and run rc.msi
Your software then installs successfully.

I dont believe this problem is related to the Windows SP... as i can install earlier versions of your software with no problems. the problem started from release 8.30 when your installer package changed from an 8mb package to a 5mb package.

Any other suggestions ?

Apr 12, 2010, 10:42 PM
billpa's Avatar
Hi Charl,

Thanks for trying these steps. We also loaded the latest updates on our XP system here, but still could not reproduce the problem.

I have added back the installer, which we removed prior. I'm hoping this resolves the issue for you, but I'm pretty sure you tried the setup version that had the installer re-added for you previously, to no avail.

Please let me know if 8.44 solves the issue!
Apr 13, 2010, 07:09 PM
Registered User
cvandenb's Avatar
Hi Bill,

Thank you for all the efforts here... its very much appreciated.

I have updated the status of the ticket with a full description. But basically, the latest release works on my one new laptop and not on the dedicated ET laptop. So the problem is still not fixed.

However, please do not action this report any further. It does look like there is something wrong with the laptops software / configuration. I did about 30 different tests/sequences and the problem still persists. The only constant throughout this is the same static Windows OS im using. I will now rebuild this laptop in the hope that this clears the problem.
I find it very strange why it suddenly started from 8.30..as i dont use the laptop for anything other than ET configuration and pulling logs.

Please can you remove the installer again from the install package as its clearly not the cuase of the problem. I have successfully installed earlier releases that did not include the installer, and they are fine, and clearly is for the greater user community, otherwise you would have been swamped with all the reports At least this way, it saves 2Mb for every download of the firmware and peoples individual storage

Many Thanks Again, and I will let you know when i get to the bottom of this one.

Apr 16, 2010, 02:17 AM
billpa's Avatar
Charl, sorry the change didn't fix it. I was a little afraid of that. I'll back that out in the next release. Others will indeed be happy with the switchback.
Apr 16, 2010, 05:31 AM
Registered User
On your Website in the version history, it shows the latest version for Elogger V3 to be 8.35
But your download option just gives us 8.31
How do I get onto the 8.35 version????
Apr 16, 2010, 05:34 AM
Registered User
cvandenb's Avatar
The latest release is indeed 8.44 (including the eLogger) if you are looking for a BETA version, and if you want a "stable" release, then 8.31 is the latest released version.

Unfortunately you cannot download individual releases.

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Sold 38/4/8 Turbo spinner & 14x10 Aeronuat New cycle1racing Aircraft - Sailplanes (FS/W) 1 Mar 14, 2010 12:08 AM
New Product Pactiv XP-14 & XP-38 Sheet foam mrblucor Foamies (Scratchbuilt) 16 May 13, 2007 11:10 AM
not sure if its cause of a fresh xp install... wired one Site Suggestions / Complaints 5 Jan 03, 2006 04:56 AM
Windows XP Clean Install - Need some answers.. Tram Life, The Universe, and Politics 20 Feb 23, 2005 09:50 PM
G2 wont install on xp pro sp2 cdub Simulators 0 Oct 02, 2004 12:24 AM