Thread Tools
Mar 12, 2010, 08:32 AM
Registered User
Well i had same problem but accidentally got the upgrade to work. I had problem with OSD firmware upgrade. eLogger Application version 8.35 shows "OSD PRO firmware UNKNOWN". If i push the upgrade putton it starts to upgrade and gives message as upgrade is successful but it was not. I managed to get even error code 128.

But i got upgrade by accident. OSD PRO must be activated by eLogger application and then firmware can be upgraded.

Choose "Hardware" > "Parameters to Display on Video OSD". Application then asks to upgrade firmware and this time it upgrades it. Just for info. I could not see this solution in RC groups forum. Maybe this helps someone.
Sign up now
to remove ads between posts
Apr 29, 2010, 05:28 AM
Registered User
Hello! when i connect GPS expander to V3 elogger all the parameters vanish but the video picture is still there. with out connecting GPS expander i can see all the parameters. can someone please help.
Jun 27, 2010, 11:55 AM
Registered User
Hello,

Thanks Kleemann, I had the exactly same problem ("OSD PRO firmware UNKNOWN") and it works for me ;-)

Regards,

André
Jun 27, 2010, 09:10 PM
Oleg
Syberian's Avatar
Quote:
Originally Posted by ravinewdelhi
Hello! when i connect GPS expander to V3 elogger all the parameters vanish but the video picture is still there. with out connecting GPS expander i can see all the parameters. can someone please help.
har-ness
har-ness
har-ness
/*hurrah!!!*/

(use battery backup harness because elogger`s supply is not enough for GPS)
Jun 29, 2010, 06:18 AM
Registered User
connect one of the ods servo inputs to 5 volt like it would be powered when connected to a reciever.
I had a power issue and this resolved it.
Jul 03, 2010, 11:20 AM
What goes up...
Krylon's Avatar
Thanks Kleemann,
Been trying to get the OSD working for about an hour, thought it was a dead unit. Seems to be working fine now. good fix!
Dec 13, 2010, 01:28 PM
Registered User
supermat's Avatar
Thanks a lot,
got the same problem, solved with the same Kleemann solution.
May 26, 2012, 07:29 AM
FPV flyer
Virgis21's Avatar
I have issue with updating the OSD Pro.
As you see, The OSD version isn't recognized at all.
Whole system is over 1 year old. Had same difficulties with V3 logger, but after few times it just updated and firmware version is OK now.
Just OSD can't do anything. Get error in few seconds. Any help will be useful!

Virgis
P.S. sorry for messy picture
Jun 02, 2012, 02:59 PM
billpa's Avatar
Hi Virgis,

This is a USB connectivity problem I believe. I would recommend trying a different PC, or trying a USB hub, to see if that resolves it. Additionally, please see the suggestions above about backup power.

If this still doesn't resolve it, it's possible that the eLogger V3's USB interface is failing.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion eLogger V3 + GPS v3 + OSD Pro problem ragamofyn Eagle Tree Systems 8 May 06, 2010 01:43 AM
Sold Eagle tree osd pro elogger v3 gps expander v3 Squatter Aircraft - General - Miscellaneous (FS/W) 2 Nov 27, 2009 09:12 PM
Sold Eagle tree osd pro elogger v3 gps expander v3 Squatter Aircraft - General - Miscellaneous (FS/W) 14 Nov 27, 2009 08:58 PM
Discussion problem--New elogger v3, osd, gps edragon Eagle Tree Systems 3 Aug 19, 2009 08:59 PM
Discussion Problems with 5Hz GPS Expander V3 and eLogger V3! Geni Eagle Tree Systems 7 Aug 14, 2008 12:08 AM