jeti 140 high voltage cut-off - RC Groups
Thread Tools
Apr 23, 2001, 11:42 AM
Registered User

jeti 140 high voltage cut-off


I have a fairly weird problem with my Jeti 140 compact speed control since yesterday(the one that screws on the back of speed 400s)...the low voltage cutoff is not so low at all...
With a fresh pack of 1000mah AA cells (tried 3 different ones) the motor will turn on and run alright but after about 2 min. the motor shuts down and "stutters"..but at a much lower speed then you would expect(about 20 rpm or so -- the prop is barely turning)...shutting the motor off and turning it back on immediately doesn't recktify the situation...but waiting for 20 seconds before turning it back on does. At one time the motor started to run again for a full 2 min. before shutting down again. A few times I also noted noticable servo jitters (like you would expect when you run down a battery completely) holding my plane (Trick Razor) in my hand...
I checked my packs...only about 400 mah are taken out of the pack ...too bad I can't find my receipt otherwise I would give Trick a call...

Anybody experienced something like this?
Has anybody
Sign up now
to remove ads between posts
Apr 23, 2001, 12:21 PM
Registered User
Andy W's Avatar
How much current are you drawing?
Apr 23, 2001, 12:33 PM
Registered User
About 12amps -- but the ESC is directly in the airstream and it has worked before with the same setup (for about 30 flights)...even when drawing less than that (using a smaller prop) it still happens...even when crusing around at half throttle...just a little later...it seems the voltage is the determining factor. (BTW -- the ESC doesn't get warm either....)

In any case --- I wasn't aware that the 140 has a current limiter?! Or temp shutoff?
Apr 23, 2001, 12:45 PM
Registered User
Andy W's Avatar
I was actually wondering whether it was the cells, not the ESC. Even though you've tried three 1000mA packs, do you have any larger cells you can try, to eliminate the ESC?
Another question I have, however - are you running this on the bench? That will certainly cause problems like this.. (high current, lack of airflow for cooling, etc.).
..a
Apr 24, 2001, 01:16 AM
Registered User
I could use larger cells...if they'd fit in the plane
I don't think it's the cells though...they wouldn't recuperate enough in 10 - 20 sec. to continue running quite strongly for another 2 min -- and then the shutoff is the same as before...usually you'd still have partial power (the "stuttering" of the esc)to at least extend your glide...but in my case the prop barely turns at all....and after that there's still about 600 mah in the pack (8 cells discharged at 5 amps to 0.8 V per cell)
Apr 25, 2001, 11:17 AM
Registered User
Well? Junk it?
Apr 25, 2001, 11:50 AM
jrb
jrb
Member
jrb's Avatar
Junk what?

As has been discussed in many other posting on this subject, the cells aren't keeping up!

If you don't have a what meter (why not?) to show that the volts are falling as you advance the throttle; then do the smaller prop test as was proposed elsewhere.

Does it work (not auto cut-off) w/o a prop? And, with a smaller prop? Its the cells!
Apr 25, 2001, 12:34 PM
Registered User
Well...did you read my above posts?
I'm going to summarize:

-- Batteries fully charged -- launch -- motor stops after 1 - 2.5 min

-- between 15-20 seconds later you can advance the throttle again and the motor starts running again (quite strongly)

-- testing the same thing on the ground: after the motor shuts off, the prop BARELY turns (I would hold put my finger in!)and the servos jitter..like there is absolutely no juice left. 20 seconds later I turned the motor back on...continues to run strong for another 2 min with the servos functioning normally....and then the same thing happens.

Are you telling my that my battery packs are dropping down to about 4 Volts (to cause the servo jitter / prop turning at 20rpm) but magically regain their strength within 20 seconds (motor and servos running for another 2 minutes?!?!)

That makes no sense...