Thread Tools
Old Nov 19, 2011, 09:54 AM
NightRunner417 is offline
Find More Posts by NightRunner417
Fly Like A Thing Posessed!
NightRunner417's Avatar
Ok, let's see if this sounds sane to everyone... I'm planning to go with all tractor props on my quad by going back to round dowel rod for the arms and drilling each motor mount angle at 5 or 6 degrees. This is based on some reading I did where others said they mounted TWO of their four motors at 10 to 12 degrees to cancel torque spin. The math would seem to indicate that if I did all four (for simplicity's sake) then I only need half the angle per motor. Basically the configuration would be a helix.

All I need to know right now is if my figures are excessive or weak... I would like to make this happen without having to say, "Whoops, too much" or "Whoops too little" after drilling out a bunch of dowels to the wrong spec. I might do a clamping system at first to avoid such problems but it would still be nice to have some ballpark idea of the angles in advance.

Thoughts? Thanks for any help! :-)

Rick NR417
Last edited by NightRunner417; Nov 19, 2011 at 10:13 AM.
Sign up now
to remove ads between posts
Old Nov 19, 2011, 01:34 PM
elmesito is offline
Find More Posts by elmesito
Chopping board captain
elmesito's Avatar
Four weeks in, and my quad has not taken off yet

Since I flashed firmware V4.7 the motors have only two speeds, stopped or full speed. I have set the throttle range over and over, but nothing makes it change.

The method I used to set the throttle range, was set the yaw pot to zero (fully clockwise) turn on with the throttle stick of the transmitter on max, and once the ESC beep twice, take the stick down to minimum. Wait for the esc to beep again, silence and power off.
Set the Yaw pot back to 50% and nothing, still full speed or nothing.

Any suggestions? Please help, I am really getting frustrated with this board now.
Old Nov 19, 2011, 02:03 PM
hish is offline
Find More Posts by hish
Registered User
hi all,
my 2 last videos. kk board v6 and firmware V4.7, hope you enjoy it.

sorry, i can't upload to youtube because of filtering !!!

http://www.4shared.com/video/-KcyZ1qp/zribar_lake.html

http://www.4shared.com/video/E6bYkat...ar_lake02.html
Old Nov 19, 2011, 04:08 PM
NightRunner417 is offline
Find More Posts by NightRunner417
Fly Like A Thing Posessed!
NightRunner417's Avatar
Elmesito I really wish I could help you! It does sound like you're doing it the right way. You're turning the yaw pot to zero with the power off, and THEN powering up the quad, I assume... everything else sounds textbook. What about rates and endpoints for your throttle stick? Is everything kosher there?

I do have one suggestion... I had weird problems with one of the firmwares (I think it was XCopter 4.7)... I can't remember exactly what it was doing but I think it may have involved wicked and unprovoked WOT issues like yours. Not knowing what else to do, I flashed to XCopter 2.3, and presto, she now flies beautifully. Maybe give that a try?

Rick NR417
Old Nov 19, 2011, 04:17 PM
NightRunner417 is offline
Find More Posts by NightRunner417
Fly Like A Thing Posessed!
NightRunner417's Avatar
Just got back from racing my scratchy quad Valkyrie II FPV X-Copter around the big parking lots at a business complex near my home ground, and WOWWWWWWW omg was that a lot of fun. I ended up bobbling it on a corner and put it in a tree, which it then tumbled out of onto the pavement, snapping the two rear arms AGAIN, lol... but before that I got a lot of flight time in and she flew like a mad bastard ballerina, AWESOME. I so wish I'd built one of these before, they are SO much fun. I thought flying low with my EZ was a riot, but this thing you can slalom through trees and then do slingshot orbits around and between stuff and she's so quick and even the 20 mph wind was like nothing to it... SO much fun. I can't wait to get serious with this thing after I've had a little more time to train on her. CRAZY. I should have had toys like this when I was a kid. :-) :-)

Rick NR417
Old Nov 19, 2011, 04:22 PM
Stunt Double is offline
Find More Posts by Stunt Double
Registered User
elmesito - go thru the setup from the start once more, maybe you missed a step - radio end points, calibrate escs, esc throttle range, kk stick centering, kk throttle range, kk gyros etc...
Old Nov 19, 2011, 05:40 PM
elmesito is offline
Find More Posts by elmesito
Chopping board captain
elmesito's Avatar
Thanks for the replies, and yes, I've gone through the setup over ans over. I give a go to flashing the xcopter 2.3, it might be the one that cracks it!

... but now is too late, I think it will be a tomorrow job that.
Old Nov 19, 2011, 06:34 PM
Dr.Gonzo is offline
Find More Posts by Dr.Gonzo
Registered User
Today, a silver cap from one of the gyro's fell off suddenly. I put it back gently and applied some hot glue on the sides to prevent it to fall off again.

Will the gyro work as before? The inside of it was all ok. It happend in my workplace when I turned the board upside down, without applying any pressure.
Old Nov 19, 2011, 11:00 PM
mxspode is offline
Find More Posts by mxspode
If it flies, I will crash it
mxspode's Avatar
Probably not but you can test it by throttling it up while holding it in your had over your head to say 1/4 throttle and then moving it in the direction of that particular gyro and see if it tries to fight the motion. If not probably bad. Time to hot glue is before not after. Not being sarcastic, hate to see it happen to folks.

Rob...
Old Nov 19, 2011, 11:04 PM
Sympster is offline
Find More Posts by Sympster
Registered User

Problem flashing HK V1 board


My trying to flash using Lazy Zero's tool but I keep getting a "Can't find USB device" error. I have this USB programmer:

http://www.ebay.com/itm/51-AVR-ISP-P...item27b9e6169e

It installs automatically under Win 7 64 bit and is listed as a "USB input device" I downloaded the "Libusb0" driver and when trying to update the driver to it, windows states I already have the best driver installed and won't update it. In the flash tool I'm selecting the HK V1 board and "USBASP" programmer. When I hit "start" it states the error message along with "error setting fuses".

Any ideas anyone?
Old Nov 20, 2011, 12:59 AM
elmesito is offline
Find More Posts by elmesito
Chopping board captain
elmesito's Avatar
Quote:
Originally Posted by Sympster View Post
My trying to flash using Lazy Zero's tool but I keep getting a "Can't find USB device" error. I have this USB programmer:

http://www.ebay.com/itm/51-AVR-ISP-P...item27b9e6169e

It installs automatically under Win 7 64 bit and is listed as a "USB input device" I downloaded the "Libusb0" driver and when trying to update the driver to it, windows states I already have the best driver installed and won't update it. In the flash tool I'm selecting the HK V1 board and "USBASP" programmer. When I hit "start" it states the error message along with "error setting fuses".

Any ideas anyone?
Sympster, although it is a usb device, the cheap devices only interface as usb, but emulate a com port. try selecting the highest com port in the list instead, that worked for me.
Old Nov 20, 2011, 01:40 AM
panos2408 is offline
Find More Posts by panos2408
DXL Team Pilot FuriusP
panos2408's Avatar
Quote:
Originally Posted by elmesito View Post
Four weeks in, and my quad has not taken off yet

Since I flashed firmware V4.7 the motors have only two speeds, stopped or full speed. I have set the throttle range over and over, but nothing makes it change.

The method I used to set the throttle range, was set the yaw pot to zero (fully clockwise) turn on with the throttle stick of the transmitter on max, and once the ESC beep twice, take the stick down to minimum. Wait for the esc to beep again, silence and power off.
Set the Yaw pot back to 50% and nothing, still full speed or nothing.

Any suggestions? Please help, I am really getting frustrated with this board now.
I think gyro pots and motor order are altered with the 4.7 FW. I hope you get lucky with other Fw's.

I am still looking for something to suit me since every FW i tried wasn't spinning motors properly. I know it sounds that i am doing something wrong but i did go again and again from calibrating to stick centering more than 10 times. These boards can really be a pain in the .... sometimes and the cause is a mystery.
Old Nov 20, 2011, 03:04 AM
NightRunner417 is offline
Find More Posts by NightRunner417
Fly Like A Thing Posessed!
NightRunner417's Avatar
I had a real freak out just a few minutes ago during testing. I'd had a bad wipeout at the "field" today (big parking lot) that broke two of the arms on my quad and I also needed to redo the setup for the rubber feet... I just didn't feel like tearing into the repairwork so I shelfed it for the afternoon. I was up late tonight anyway so I decided to get it done, and then just a few minutes ago I gave her a quick test in my living room.

Everything seemed to be fine, maybe slightly all over the place but I'm up wayyyyy past my bedtime so that's probably just pilot fatigue. Anyway, she drifted out toward some things I had on my floor and I really didn't wanna break a prop so I let her float down toward the floor and was attempting to drift her back toward me when suddenly the motor sound got way loud and fast and she flipped HARD and dug into the floor, and I heard something hit the wall on the other side of the room. She sat there upside down for a second just plain shrieking with what sounded like WOT on the one prop not stopped by the carpet, and then spun down and was silent.

I turned her over to find that one of the props had all but exploded (the pieces are what hit the wall across the room), so I grumbled my way through the process of replacing it with my LAST 10x4.7 tractor prop... and very cautiously tested her again. I hadn't cut the power during all this, and when I applied throttle, the motors spun up really hard despite that I was barely above zero. I had to pull the battery and then she flew normally again. I was understandably jumpy by this point, and during that last test flight she did make a sudden, brief sound of much faster throttle, and then no further incident. Kind of a little spooky! I'm not sure how I'd have handled that sudden WOT thing if I'd been flying FPV... because it was like the throttle curve was WAY hot - I'd have had to be very very precise on the throttle to get her to come back down without just falling like a four bladed rock.

Anyone ever have something like this happen to them before? I'm tenatively figuring that it's a once in a great while computer glitch on the controller... but it would be nice to know how great a while that actually is.

I still love my bird... nothing will change that... unless she *stays* at WOT maybe, lol.

Rick NR417
Old Nov 20, 2011, 03:51 AM
dompower is offline
Find More Posts by dompower
Flying like a bird!
dompower's Avatar
Hi friends,
It is really fascinatting to see KK multicopter development.
As many fans dream... I too like to have compass, accel, baro and GPS options.
Any body has 'C' source file for the KK multicopter.... Pls provide me. I will experiment, if I succeed I can share with our KK multicopter community.
Thanks
Dominic
Old Nov 20, 2011, 05:34 AM
SSM is offline
SSM
Find More Posts by SSM
SSM
Voluntary Assumption of Risk
SSM's Avatar
Quote:
Originally Posted by NightRunner417 View Post
I had a real freak out just a few minutes ago during testing.

Rick NR417
Rick NR417,

If you're using all 4 tractor props (rather than 2CW and 2 CCW props), then you need one opposite pair tilted about 12 degrees and the other opposite pair not tilted. Or for more yaw authority, one opposite pair tilted about 14 degrees, and the other opposite pair tilted negative two degrees.

Angles for all CCW props on a KK + copter.mp4 (0 min 20 sec)


Simon


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Quadrotor brushless controller airbotix Multirotor Talk 63 Aug 06, 2010 12:15 PM
Discussion ALPO -Aerobatic Low Parts count Original design. Brian Courtice Foamies (Scratchbuilt) 8 Sep 21, 2009 04:57 AM
Discussion Any tips for my first flight with a low wing plane? Warthog_Fan Fuel Plane Talk 4 Sep 06, 2009 08:53 AM
Help! Need help with Low-cost QuadRotor Hero.sl Coaxial Helicopters 5 Jun 28, 2009 03:26 AM
Question Searching Simple Controller for Free Flight flymax Power Systems 8 Jan 07, 2006 11:07 AM