Thread Tools
Old Oct 13, 2012, 03:43 PM
ryan_m is offline
Find More Posts by ryan_m
doh!
ryan_m's Avatar
Quote:
Originally Posted by turnerm View Post
Power measured how exactly? Watts or Amps or what? Does this just mean that a larger motor can handle a larger prop assuming the same battery setup (cell count) and assuming the same or similar KV rating?? So a 5320-300 could swing a 20 inch prop on 8s while a 4325-300 could only swing a 19 inch prop? Just using made up figures to make sure I understand...
Not really anything to do with prop size really. Like Losi said it's about efficiency, plus overall watts. The 4325's will pull around 2200-2400 watts pretty easily if given the right prop, etc. The difference is that the 4325 will run 20-30 degrees hotter than the 5320 while doing so. It will require baffling to help keep the heat under control better. And some of the power (watts) are lost in the form of heat. The 5320 will run cooler (not generating as much heat due to better efficiency) at the same power setting. Then the 5320 can be bumped up in power to almost 3000 watts, though here again you need to have proper baffling and realize that there will be some efficiency losses and some of those excess watts are essentially going down the drain in the form of heat. I think any motor when running close to it's limit begins generating lots of heat and losing lots of it's efficiency. So in theory a larger motor is better given the efficiency thing, but then you wind up carrying extra weight too, which affect performance of the airframe. So it's all a balancing act...
Sign up now
to remove ads between posts
Old Oct 13, 2012, 10:24 PM
ROLLING CIRCLE is offline
Find More Posts by ROLLING CIRCLE
TEAM TWISTED
ROLLING CIRCLE's Avatar
Any thoughts are appreciated guys. Here is the problem with this 70.
PROBLEM WITH THE SLICK 101312 (1 min 48 sec)

Motrofly 4325
8S = 2x EZ Flite 4200 Mah 35C continuous packs
18x8 Xoar
Castle Ice 100

3100 Mah Life batt on receiver/servos

Run it up and shuts down but still able to run. Castle need reprogrammed, bigger Mah packs? These packs were used on the 51 Slick for a while as stand alone 4S but thought we could still use the same packs on the Y to run the 70. They balance charge up to 16.8 OK. Not sure but had some connectors just changed over to 150 amp connectors. Could leads on motor to the speed control be out of order and cause this. Doesn't make sense to me...
RCG Plus Member
Old Oct 13, 2012, 10:57 PM
gremlin is offline
Find More Posts by gremlin
What?!? I didn't do that!
gremlin's Avatar
The 2 beeps means you are hitting low voltage cut off. Check the setting for the cutoff or try different packs.
Old Oct 14, 2012, 01:16 AM
hertzrepkeith is offline
Find More Posts by hertzrepkeith
Registered User
hertzrepkeith's Avatar
Ok guys I could really use some help. I am running a DLE 30 CC Engine with a Fortitude Fuel Tank. My engine is running great!(Well not sooo fast!) At the Huck Fest today I had 3 Dead sticks. I brought the plane in. Ran it on the ground and found that when I flip the plane upside down it runs fine but right when I go to turn it back over it DIES on me (Everytime) The clunk looks like it is moving correctly and I have replace the hose. Any suggestions????
Old Oct 14, 2012, 08:50 AM
alfabeast is offline
Find More Posts by alfabeast
3D Addict
alfabeast's Avatar
Quote:
Originally Posted by hertzrepkeith View Post
Ok guys I could really use some help. I am running a DLE 30 CC Engine with a Fortitude Fuel Tank. My engine is running great!(Well not sooo fast!) At the Huck Fest today I had 3 Dead sticks. I brought the plane in. Ran it on the ground and found that when I flip the plane upside down it runs fine but right when I go to turn it back over it DIES on me (Everytime) The clunk looks like it is moving correctly and I have replace the hose. Any suggestions????
Go electric! Couldn't resist. Or, OS GT33? Or check if the pump is putting out enuff pressure.
Old Oct 14, 2012, 08:55 AM
alfabeast is offline
Find More Posts by alfabeast
3D Addict
alfabeast's Avatar
Quote:
Originally Posted by ROLLING CIRCLE View Post
Any thoughts are appreciated guys. Here is the problem with this 70.
http://youtu.be/O2AmKAVP1zk
Motrofly 4325
8S = 2x EZ Flite 4200 Mah 35C continuous packs
18x8 Xoar
Castle Ice 100

3100 Mah Life batt on receiver/servos

Run it up and shuts down but still able to run. Castle need reprogrammed, bigger Mah packs? These packs were used on the 51 Slick for a while as stand alone 4S but thought we could still use the same packs on the Y to run the 70. They balance charge up to 16.8 OK. Not sure but had some connectors just changed over to 150 amp connectors. Could leads on motor to the speed control be out of order and cause this. Doesn't make sense to me...
do you have powerpoles on the ESC and batts? sometimes the blades will push back and you don't get enough contact. Check the end, make sure the tang gets all the way out and snaps over the retainer feature. I chk these everytime I fly. The servos will work, but not enough juice for WOT.
Old Oct 14, 2012, 09:43 AM
lugnutz is offline
Find More Posts by lugnutz
The Twisted Elf
lugnutz's Avatar
Quote:
Originally Posted by hertzrepkeith View Post
Ok guys I could really use some help. I am running a DLE 30 CC Engine with a Fortitude Fuel Tank. My engine is running great!(Well not sooo fast!) At the Huck Fest today I had 3 Dead sticks. I brought the plane in. Ran it on the ground and found that when I flip the plane upside down it runs fine but right when I go to turn it back over it DIES on me (Everytime) The clunk looks like it is moving correctly and I have replace the hose. Any suggestions????
richen the high end just a little to start,because what is good on the ground under a load,holding plane back, it will unload in the air a may cause engine to go lean,high needle should be tuned with a tachometer,just when the rpm's start to drop back off the screw,richen it,about a 1/16th
Old Oct 14, 2012, 11:52 AM
ROLLING CIRCLE is offline
Find More Posts by ROLLING CIRCLE
TEAM TWISTED
ROLLING CIRCLE's Avatar
Quote:
Originally Posted by alfabeast View Post
do you have powerpoles on the ESC and batts? sometimes the blades will push back and you don't get enough contact. Check the end, make sure the tang gets all the way out and snaps over the retainer feature. I chk these everytime I fly. The servos will work, but not enough juice for WOT.
The batts are on deans. 150 amp connector in line making the Y right off the speed control with the two deans on the end there. I was wondering about the connectors causing the resistance but not sure since they are overweight for the job. I would think they would be OK. Maybe the Motrofly is pulling to hard for the ESC or the packs to keep up with???? let me know what you guys are thinking...
RCG Plus Member
Old Oct 14, 2012, 12:09 PM
racerman27410 is offline
Find More Posts by racerman27410
Registered User
racerman27410's Avatar
Quote:
Originally Posted by hertzrepkeith View Post
Ok guys I could really use some help. I am running a DLE 30 CC Engine with a Fortitude Fuel Tank. My engine is running great!(Well not sooo fast!) At the Huck Fest today I had 3 Dead sticks. I brought the plane in. Ran it on the ground and found that when I flip the plane upside down it runs fine but right when I go to turn it back over it DIES on me (Everytime) The clunk looks like it is moving correctly and I have replace the hose. Any suggestions????
My DLE was doing the exact opposite.... it ran fine upright but cut off every time i went inverted...... turned out to be a weak metering lever spring.
I replaced the spring with one from a used walbro carb and the problem disappeared.
Old Oct 14, 2012, 08:16 PM
hertzrepkeith is offline
Find More Posts by hertzrepkeith
Registered User
hertzrepkeith's Avatar
Thanks for all the help everyone! Found my problem! Gas tank(Fortitude 8 OZ and its brand new! I switched the tank out and my problem is gone. I don't know why but that is what was wrong. I guess I will have to order another one.
Old Oct 14, 2012, 08:20 PM
going4speed is offline
Find More Posts by going4speed
3DHS 'native'
going4speed's Avatar
Interesting! I am installing a fourtitude 8 ounce in the velox. Would like to know what the issue is. Are you sending it back for them to check out?
Old Oct 14, 2012, 11:13 PM
hertzrepkeith is offline
Find More Posts by hertzrepkeith
Registered User
hertzrepkeith's Avatar
I got the tank from Aero Graphix about 3 weeks ago. I have about 1 gallon of fuel through it. I was going to call them in the morning. I would love to know why this is causing this to happen, because I don't see anything on the tank that looks adnormal, but puting a new tank on it completly fixed my problem.
Old Oct 14, 2012, 11:18 PM
hone1er is offline
Find More Posts by hone1er
Team Twisted!
hone1er's Avatar
Quote:
Originally Posted by hertzrepkeith View Post
I got the tank from Aero Graphix about 3 weeks ago. I have about 1 gallon of fuel through it. I was going to call them in the morning. I would love to know why this is causing this to happen, because I don't see anything on the tank that looks adnormal, but puting a new tank on it completly fixed my problem.
Glad to hear you got it worked out. It was a bummer you were having all those engine problems at Huckfest. Hope to see you again next year man!


-Joe
Old Oct 14, 2012, 11:48 PM
hertzrepkeith is offline
Find More Posts by hertzrepkeith
Registered User
hertzrepkeith's Avatar
Thanks Joe! I will see you there for sure! Hey you bailed out before you could get your award!!! Oh and the 42% Plane that you won, but since you were not there to collect they gave it to me
Old Oct 14, 2012, 11:58 PM
hone1er is offline
Find More Posts by hone1er
Team Twisted!
hone1er's Avatar
Quote:
Originally Posted by hertzrepkeith View Post
Thanks Joe! I will see you there for sure! Hey you bailed out before you could get your award!!! Oh and the 42% Plane that you won, but since you were not there to collect they gave it to me
Oh nooooo ahaha


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Poll 3D hobby shop 51" slick or 55" SHP? appleflyer 3D Flying 24 Mar 24, 2009 07:29 PM
Video 3D Hobby Shop's AJ Slick Clark Warfel Electric Plane Talk 3 May 08, 2008 08:31 AM