Thread Tools
Old Sep 13, 2001, 07:38 PM
erashby is offline
Find More Posts by erashby
Flying Free
erashby's Avatar

Need help with FMS to Hitec Fash 5 interface cord? Signal but no channel input.


I built the parallel interface cord for my Hitec Flash 5XG to use with FMS. FMS says it gets a signal but there is no input on any of the channels.

I don't have an IRQ conflict; that all is setup right.
I even rebuilt the interface cord. I've built it two ways:
1) with the zenor diode nd 680 Ohm resistor and
2) with the transistor and 10K resistor(s).

I've tried the interface cable input from pin 2 and again from pin 3 with pin 6 as ground and again with pin 5 as ground. There is no difference when you move the control sticks.

Has anyone succesfully built and used an interface cord with FMS and a Flash 5xg?


Please help. Thanks.
Last edited by erashby; Sep 13, 2001 at 07:42 PM.
Sign up now
to remove ads between posts
Old Sep 13, 2001, 11:09 PM
rlt55 is offline
Find More Posts by rlt55
Senior Moment
rlt55's Avatar

cmos?


Go into CMOS setup and try changing around your Onboard Parallel Mode. Don't change the address, just the mode. mine has SPP, EPP/SPP,ECP or ECP/EPP..

I also saw a post where the guy had the same bug and found that the "Shared" IR with the soundboard was the cause.
Rich<>
Old Sep 14, 2001, 03:49 AM
steve lewin is offline
Find More Posts by steve lewin
Registered User
The port must be in EPP or ECP mode. The signal ground should be the DIN plug screen not any of the pins. It's never pin 5 though some Txs have an additional ground on pin 6. But the screen always works.

OTOH those sort of problems are exactly why I always recommend the more complex, but much more reliable, serial port interface.

Steve
Old Sep 14, 2001, 10:26 AM
erashby is offline
Find More Posts by erashby
Flying Free
erashby's Avatar

Need serial interface schematic


Where can I find the schematic for the serial interface?
Old Sep 14, 2001, 12:56 PM
steve lewin is offline
Find More Posts by steve lewin
Registered User
On the FMS website http://n.ethz.ch/student/mmoeller/fms/index_e.html

Look in"Manual" then "Connection of a remote control to a serial interface".

That one works fine with Futaba/Hitec. Some JRs need a modified version, see http://members.tripod.co.uk/SteveLewin

HTH - Steve
Old Sep 15, 2001, 01:57 AM
erashby is offline
Find More Posts by erashby
Flying Free
erashby's Avatar
Steve,
Thanks for the help. I got the parallel interface cord to work, but it is way too glitchy, so I built the serial interface just tonight. When I start the computer with the serial interface cord plugged in it locks up my computer. The one time that I got in to FMS and set the IRQ correctly, I got no signal. Now it just locks up my computer anytime I plug the seerial cord in.

Any ideas?
Thanks in advance for the help.
Eric
Old Sep 15, 2001, 04:29 AM
steve lewin is offline
Find More Posts by steve lewin
Registered User
Sorry Eric, can't help I'm afraid. I must have built a dozen of those serial interfaces now and every one has worked without any trouble (on various PCs with Win95, 98 and even ME).

There are all sorts of ways for it not to work, all boiling down to "building errors", but from what little I know it shouldn't even be possible to lock up a PC just by plugging a cable into a serial port.

Anyone ?

Steve
Old Sep 15, 2001, 12:31 PM
Gene Bond is offline
Find More Posts by Gene Bond
Crash Master
Gene Bond's Avatar
I just built and tested the parallel version last night for my Hitec Focus 4. It worked fine, once I got decent solder joints on the junk phone cord I was using.

The signal for mine was on pin 4, the pin at 10:00 looking at the socket, I used the shroud for ground. in the D25 header, I connected ground to pin 18, and ran signal through 2-330ohm resistors to in 10, then a 5.1v zener from 10-18... couldn't be simpler.

The 5 channel should have the same buddy cord connection, I assume, but I've been wrong before.

I haven't got all the trims and gains figured out yet, and I do have to swap the rudder and ailerons around for some models, but I really only had to reverse the elevator, douh! and click the calibrate button.
Old Sep 15, 2001, 02:16 PM
erashby is offline
Find More Posts by erashby
Flying Free
erashby's Avatar
Thanks all for the help. I think I'll rebuild the serial port interface cable and try again. The parallel cable works it is just glitchy.
Old Sep 16, 2001, 12:49 AM
Gene Bond is offline
Find More Posts by Gene Bond
Crash Master
Gene Bond's Avatar
My parallel looked glitchy until I calibrated it. Did you? Just a thought...


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
help with FMS and Hitec please Bruce Emdur Simulators 1 Aug 24, 2004 03:35 AM
Need help with fms interface. omega blood Electric Plane Talk 4 Dec 17, 2002 06:55 AM
Subject: Need help with CCPM and Hitec Eclipse 7 Radio. tom88 Electric Heli Talk 2 Aug 21, 2002 01:30 AM
Need help with FMS Duane Beginner Training Area (Aircraft-Electric) 2 Apr 19, 2002 04:26 PM
Need help with power choice 3.5 lb Cub, Endoplasma? slowflyer Electric Plane Talk 3 Aug 01, 2001 03:16 PM