cant get my esc to arm or do anything really - RC Groups
Thread Tools
Aug 06, 2009, 05:01 PM
Registered User
Help!

cant get my esc to arm or do anything really


so i have been trying to setup a system for a new build i soldered on the connectors plug it in bind the RX then turn everything off and then back on.

motor/esc never beeps. if i push the throttle to 100% it goes into program mode. when i got back to 0 it beeps like it saved it and beeps like it armed.

but not when i push the throttle up slowly it sort of clicks then beeps and thats it. but if i push it to full it will go back into program mode. i checked motor on different esc that is identical and it works fine and i also tried different rx. there is radio contact as i can control servo's even when the motor isn't working.

i don't have any type of manual as it is a cheap ebay item but every spec on the motor and esc are identical to the grayson hobby parkjet combo with a 2212-6 motor and 30 amp esc both welgard brand. only difference are the color of shrink wrap as far as i can see.

i emailed the maker and seller for a manual and have yet to get a response from either. i have tryed trimming everything down to 0 with regular trim and sub trim. i am sure it is the esc, possibly programming issue or does this all sound like a bad esc unit
Sign up now
to remove ads between posts
Aug 06, 2009, 05:04 PM
Former Futaba employee
If its futaba try reverseing the throttle on the transmitter.
Aug 06, 2009, 05:05 PM
Registered User
its a dx6i by spektrum so that doesn't apply.

as a side note i've been searching the web for 3 hours and read aton of varoius ideas.

i've re soldered the connections so i know they have good contact.
Aug 06, 2009, 05:56 PM
Former Futaba employee
Have you tried to arm it full throttle and see if it beeps then bring in back to low
Aug 06, 2009, 07:39 PM
Registered User
it beeps like my other one does when it arms. but when you give it some throttle it sort of clicks then beeps again. and if i ever put it up to full throttle it starts beeping out its programming stuff
Aug 06, 2009, 07:53 PM
Registered User
i think im going to file this as a bad esc. i just ordered a replacement only out i guess 12 dollars so w/e.

apreciate the help but 5 hours of tinkering and experimenting hasn't fixed it so no worries


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
I cant get my Tx to work with FS2004 littleport2003 Simulators 1 Jan 17, 2005 06:58 PM
Help! Help! I cant get my motor to stay in my plane saitrix GWS (Grand Wing Servo) 26 Jun 02, 2004 06:24 PM
I cant get my plane off the ground! ashdec87 Electric Ducted Fan Jet Talk 20 Apr 23, 2004 09:05 PM
Help I cant get my new Jasto inline gearbox to fit my motor Joe Elston Electric Plane Talk 1 May 21, 2001 11:49 PM
Help I cant get my inline gearbox to ,ount to my motor Joe Elston Electric Plane Talk 0 May 21, 2001 10:55 PM