Schulze isl8 won't work with power supply - RC Groups
Thread Tools
Mar 23, 2003, 03:35 AM
f5b-uk
Mike Seale's Avatar

Schulze isl8 won't work with power supply


My power supply (Watson, 22A continuous, bought from WLM last year) won't run my isl8 anymore

I think the charger has a big capacitor to charge up and the initial surge overlaods the PS and it shuts down. I have been overcoming this by connecting the PS to a 12V battery and the Schulze to the PS before switching on the supply. Removing the leads from the PS to the battery would then leave the Schulze working OK. However, now this won't work either.

Has anyone had a similar problem and is there a cure? Can anyone suggest why my original hookup has stopped working when it seems to be fine in the past?

Mike
Sign up now
to remove ads between posts
Mar 23, 2003, 12:03 PM
small electrics r BIG FUN
Does the charger still work ok with a good 12v battery ? That would isolate the charger or the ps.

Could be your power supply was going bad a long time ago.

I have also found that some chargers will function just fine on a certain power supply, while a different charger will refuse to.

Al
Mar 23, 2003, 02:43 PM
Menber
Mike,

Read this.

https://www.rcgroups.com/forums/show...5&pagenumber=1
Mar 23, 2003, 05:30 PM
f5b-uk
Mike Seale's Avatar
Quote:
Originally posted by Theox
Mike,

Read this.

https://www.rcgroups.com/forums/show...5&pagenumber=1
Thanks for this. However, I've solved the problem in a different way. Hooking a 1 Ohm resistor in series with the charger when the PS is switched on limits the current. This resistor is then removed whist keeping continuity in the circuit. Seems to be working fine now.

Mike