camopacman's blog - RC Groups
camopacman's blog View Details
Posted by camopacman | Mar 17, 2017 @ 10:51 PM | 2,406 Views
This entertaining video demonstrates why you should use pc props, especially in the winter with a lot of invisible branches looking in goggles.
Huge drone crash (8 min 45 sec)

Posted by camopacman | Mar 12, 2017 @ 06:36 PM | 2,811 Views
Hey everyone, I'm sure most of you have more common sense then me, but if you don't i recommend you don't flying around crazy people. Your craft WILL be stolen. Watch this video and have a good laugh towards the end of it.
Crazy Neighbor Steals My Drone (3 min 16 sec)

Posted by camopacman | Mar 05, 2017 @ 08:38 PM | 2,362 Views
Flew at this beautiful construction site. Problem was i kept loosing signal to my controls. Found out later the 2.4ghz from the public wifi was interfering with my radio causing my quad to eat dirt. Subscribe if you liked it. Thanks
WiFi's a b**** (3 min 23 sec)

Posted by camopacman | Mar 04, 2017 @ 11:42 PM | 2,586 Views
So after watching a lot of videos i found stingerswarms PID Tunning video was most helpful. Go check it out if you need help.
A lot smoother compared to my other videos now. Enjoy and Subscribe if you want.
Re-Tunning (3 min 24 sec)

Posted by camopacman | Mar 02, 2017 @ 09:31 PM | 2,770 Views
If anyone wants to understand the full potential of these PC props. WATCH THIS VIDEO. I crash a million times and yet no props broke in the whole session. Also like and subscribe. Enjoy
PC Props Proven (5 min 6 sec)

Posted by camopacman | Feb 28, 2017 @ 07:47 PM | 2,750 Views
Hey everyone, posting again to share a video i think you guys will really like. Please support by subscribing or just liking!
Enjoy and any feedback is appreciated.
Flying with the birds (4 min 22 sec)

Posted by camopacman | Feb 26, 2017 @ 03:46 PM | 2,751 Views
Hope you guys like my new videos. I have a moka frame I've been flying with lately and i love it. Ill be posting more that are really cool. Id much appreciate it if you guys supported me by subscribing! Any feedback is also appreciated.
Dumpster Diving (4 min 15 sec)

Posted by camopacman | Feb 23, 2016 @ 08:03 PM | 3,333 Views
Hey guys! Check out my video!
Under the swings (3 min 46 sec)

Posted by camopacman | Feb 20, 2016 @ 12:30 AM | 3,403 Views
Hope you enjoy, its a little shaky, might of been just the wind or its my PID settings. If you know what settings to adjust based on the flight of the video please tell me.

Under the swings (3 min 46 sec)

Posted by camopacman | Feb 19, 2016 @ 04:15 PM | 3,198 Views
Hey, i just got a new mobius. However the sd card only saves some of the videos i take using it on my 250 miniquad. Ive tried trouble shooting and the only correlation i could find to as why some videos were saving and some weren't were that the ones were it didn't save i was doing pretty aggressive flips and hang times ( upside down falling). Could this be the reason? and if it is how could i fix it? i have a sandisk 8gb card. maybe its defective? or is it the mobius. Thanks
Posted by camopacman | Aug 19, 2015 @ 04:27 PM | 3,418 Views
Hi, I'm stretch building a plane, but when I throttle up the motor just cuts off when I reach 50%. The whole receiver shuts off and you hear the motor beap a few times to tell you its ready. Any help would be appreciated.
Posted by camopacman | Jul 24, 2015 @ 05:42 PM | 3,346 Views
So I was trying to do a back flip on my quadcopter but I landed upside-down right on the tx antenna. The whole gold part where you screw on the antenna fell off. Can anyone help me on how to solder this thing back on? thanks!
Posted by camopacman | Jul 10, 2015 @ 12:24 AM | 3,670 Views
Check out the footage I got from the fatshark pilot hd v2 on my quadcopter, it did get wavy sometimes from the vibration but other than that pretty good. Also note that I did have a spotter with me to make sure I wasn't flying over anything that I could do any damage to.
Quadcopter flies over neighborhood (2 min 51 sec)

Posted by camopacman | Jul 09, 2015 @ 05:53 PM | 3,666 Views
Does anyone know why my ar400rx isn't working? The tx is binded to it and everything looks normal except when i try moving servos or throttling up there is no response. The battery is fully charged and I trouble shooted my power system and thats not the problem, so it has to be the rx. any ideas how to fix it?