Whabbit's blog - RC Groups
Whabbit's blog View Details
Posted by Whabbit | Sep 11, 2012 @ 12:52 PM | 2,414 Views
I am new to the field of RC. On recommendation of a friend I purchased the Turnigy 9X with RF 9X V2 Tx from Hobby King. Programming the controller went well including binding the Rx and the Tx.

Then the trouble started. Not able to control the ESC on channel three. After many unsuccessful attempts I draped the aerial of the Rx around that of the Tx. For the first time other than when I did the binding did the Rx led burn solid. I could control the speed of the out-runner motor, the elevator and the rudder. However channel 4 to be used for the ailerons drove the servo hard on in one direction and kept doing so with the power applied. I disconnected channel 4, turned off the Rx and then the Tx. 2 hours later turning on the Tx and thereafter the Rx (aerial still draper round the aerial of the x) yielded the following results.: The led of the Rx took some time to turn on. Tried the stick to control the motor no go, no command to the rudder etc. I tried a number of times by turning everything on and off, rebind etc no go. I did notice the LED of the Rx was not
burning solid it would stay on for about 10 secs go dead for 2 secs on again for 5 secs etc.
Question: Was I supplied a dud Rx or is something else amiss ?
Your comments will be appreciated.