iskess's blog - RC Groups
iskess's blog View Details
Posted by iskess | Aug 26, 2013 @ 03:26 PM | 19,017 Views
I have used this BT Module with the APM in lieu of the telemetry module and sucessfully linked it to Mission Planner on my Windows 7 laptop. I ran into a few complications along the way, maybe I can save you from them.

1) Go to the Bluetooth Devices and double click on the BT module > Hardware tab > Properties > Change Settings > Port Settings > Bits per Second to 57600.
Do NOT follow this path... Hardware tab > Propeties > Port Settings tab. You MUST go through that administrator Change Settings button. If you do directly to the Port Settings tab you will get stuck and your baud changes won't stick. You must also uncheck "Reset APM on USB Connect" under Configuration>Planner>APM Reset

2) If you get a "Connection Fail" error:
The secret is to disconnect the bluetooth module from its cable and reconnect it after getting the MP "Connection Fail" error. After this it worked, and so did the MinimOSD. I have not had to do this little trick ever since, just that one time and everything just works now.
I found this tip in this video at 11:47 of RCJose's Bluetooth Configuration Tutorial.