RHTizzy's blog - RC Groups
RHTizzy's blog View Details
Posted by RHTizzy | Jan 26, 2013 @ 07:23 AM | 3,758 Views
Originally Posted by tvbcom View Post
How to download the MPNG 2.9 R2? Is there a link?

I am not that familiar with google code and svn.

Is there a step by step tutorial how to download?

I am not a computer person
Using the link from "many different client programs and plug-ins. See your client's documentation"
I downloaded the win64 version of SVN and copied the "svn checkout http://megapirateng.googlecode.com/svn/trunk/ megapirateng-read-only" command into a dos command prompt window

This downloaded the contents of the trunk to the folder "megapirateng-read-only" (located in the folder where you execute the command from, adding a path to the command makes things easier to retrieve)

The more the merrier!
Posted by RHTizzy | Jan 08, 2013 @ 12:50 PM | 3,848 Views
I came across a mod on Youtube for replacing the original 9x antenna with an SMA connector, it took some searching to find the proper parts so here they are with a bit of explanation (but it should be pretty self explanatory).

First of all, open the casing and remove the original 9x antenna from the inside (it's quite easy), then desolder the coax connector inside the original module if you want to reuse it (I have a few FlySky CT6B rx's that it works perfectly with)

I then cut the cable from this RP-SMA female plug center to RP-SMA female nut bulkhead RG316 cable jumper 50CM in half and pulled it through the casing (drilled a small hole). I then soldered it to this connector RP-SMA male jack center right angle crimp RG174 RG316 LMR100 RF connector which gives you a bit of room to play with as not all modules have their antenna connector on the top.

After that I cut the pigtail off this: RP-SMA female plug center nut bulkhead to IPX U.fl 1.13 pigtail cable 20cm and soldered the coax connection inside the standard 9x module.

This then allows you to swap between Corona, FrSky, FlySky modules. You still need an antenna to put on the 9x of course but they're easily available on HK (I got both a 5db and 11db)
Posted by RHTizzy | Oct 24, 2012 @ 12:06 AM | 3,414 Views
Here are the relevant topics
MWII - http://www.multiwii.com/forum/viewto...tart=10#p17758
Mutiwii have it solved by either programming a T9x or by adding a bit of code the the .ino code to make Acro mode more manageable. Changing the Rates ( "RC Rate to 1.0 and my Pitch/Roll rate to 0.7") will allow you to freely flip and roll as you see fit but it's extremely hard to fly normally. In the above solution the quad switches to LEVEL mode if the sticks are near centre.

MPNG - http://code.google.com/p/arducopter/wiki/AC2_SimpleMode
Flipping is preprogrammed and can be accessed via ch7 and changing the settings in the mission planner.

The difference between the two is mainly that MWII allows you to flip in any direction for any duration or sequence. MPNG just activates a 1 flip on the roll axis using a switch on your Tx and direction or duration cannot be changed, ie a slow flip forward is not possible.
Posted by RHTizzy | Oct 17, 2012 @ 06:15 AM | 5,578 Views
I have placed plenty of orders and I've never had much hassles with GLB in the past (other than double the RCTimer.com shipping times).

Anyway, so I now placed a large (>$150) order on 28 sept. The website got updated almost immediately stating it had been shipped but there was no tracking nr. on the website so I didnt expect it was shipped. I did receive an email acknowledging the order.

Two weeks later, still no number so 11 october I sent an email on asking about the missing tracking nr.

Same day I receive an email saying they had just returned from the Chinese holiday (6day holiday which ended 6 october btw) but that an item was out of stock

12 october I received an email saying it had been shipped, two tracking nrs were included. (??)

17 october the tracking site states the order has arrived and is now being processed for shipping. Has not yet left the country....

It seems GoodLuckBuy time is of a different dimension to the rest of the planet?
Posted by RHTizzy | Oct 11, 2012 @ 02:50 PM | 3,811 Views
I tried to flash my ESC's after getting pre flashed ones from RCTimer but ran into a problem
Originally Posted by RHTizzy View Post
Hi guys,

Just recently I bought a few pre-flashed 30A ESC's from RCTimer and the difference was so noticable I thought I'd flash my other ESC's too. I've flashed a bunch of other stuff using a CRIUS USBASP and thought I had the pinouts clear so I made a new cable for doing the ESC's. But I can't get it working.

As soon as I touch the pins to the ESC the USBASP quits and cannot be found by avrdude anymore. The status light on the asp blinks when I touch the pins to the ESC but it doesnt talk to the USB port anymore. Unplugging the ASP and then pluggin it back in will reset it again, but that's as far as I can get.

Have I got something backward? All input is welcome, thanks people.


In the first pic I test the USBASP without touching the ESC to see if the driver is recognised. After that I touch the pins to the ESC and the ASP cannot be found anymore. I made the extra connector after the problem arose so I could easily swap the connections but everything seems to match up to spec and it still freezes the ASP.

...Continue Reading
Posted by RHTizzy | Sep 18, 2012 @ 03:07 PM | 4,568 Views
Got the following from RC Timer for use with the x650 and the Crius AIOP

At the moment I'm struggling a bit to get it going, all it does for now is resist movement instead of adjusting to movement... iow, the gimbal servo's are not controlled by the controller on roll or pitch but instead hold position and try to hold center position.

What have I done so far?
- connected servo's to CAIOP pins 44 & 45 Roll & Pitch (no free channels for using pin 46 Trigger, so might have to disconnect something else)
- connected Rx to ch7 & ch8
- defined SERVO_MIX_TILT in config.h
- I'd removed all red leads from the ESC's but it turns out that 1 needs to be connected to power the servo's

Time to google
Posted by RHTizzy | Sep 15, 2012 @ 06:14 AM | 3,928 Views
I found the seemingly best post on tuning PID's so far:

After all I've read, I liken PID tuning to driving a car with a somewhat loose steeringwheel and wanting to change lanes: how much force to apply (P) to the steering wheel for how long (I) and how quickly (D) you need to make adjustments is basically what's needed to change lanes as smoothly as possible...

Tuning in short (much thanks to Shikra):

For Aerobatic flying:
Increase value for P until oscillations start, then back of slightly
Change value for I until until hover drift is unacceptable, then increase slightly
Increase value for D (remember, that means a LOWER number as it is a negative value - i.e. closer to zero) until recovery from dramatic control changes results in unacceptable recovery oscillations
P may now have to be reduced slightly

For stable flying (RC):
Increase value for P until oscillations start, then back of slightly
Change value for I until recovery from deviations is unacceptable, then increase slightly
Decrease value for D (remember, that means a HIGHER number as it is a negative value - i.e. further from zero) until recovery from dramatic control changes becomes too slow. Then Increase D slightly (remember - lower number!)
P may now have to be reduced slightly

For stable flying ( AP / FPV):
Increase value for P until oscillations start, then back of slightly
Change value for I until recovery from deviations is unacceptable, then increase slightly
Decrease value for D (remember, that means a HIGHER number as it is a negative value - i.e. further from zero) until recovery from dramatic control changes becomes too slow. Then Increase D slightly (remember - lower number!)
P may now have to be reduced slightly

You will have to accept a compromise of optimal settings for stable hover and your typical mode of flying. Obviously factor it towards your most common style.
Posted by RHTizzy | Sep 10, 2012 @ 07:14 AM | 4,754 Views
As the RM450 was rather rudimentary I decided to use the experience to go one up and get a folding frame from RCTimer. Still using the parts I had from the previous build, so Crius All In One Pro with 1045 props, 30A ESC's and 2215 930Kv motors. It's almost double the weight though so have ordered a pair of 2450mAh 30C's from Hobbyking which should provide plenty of lift and connected in parallel provide plenty of flight time..

Here's the build log

...Continue Reading
Posted by RHTizzy | Sep 03, 2012 @ 09:14 AM | 3,863 Views
Got my 3rd flight in today and can happily share that the quad flies! It appears though that the 2200 15c batteries are indeed way underpowered for the job and within a minute or two the quad starts showing an ever increasing height oscillation and has trouble staying up on roll or pitch. Within 3 or 4 minutes it's reduced to a hopper that can hardly clear the ground.

I still had a few 1300mAh batteries from my ARdrone times which are 30C and they actually last longer and give more power (ie better throttle response) than the 2200's! Connecting 2 actually gives almost 5 minutes of actual control but obviously the quad needs tuning and control is perhaps too big a word. In fact, without level, mag and baro active it's almost impossible not to crash as the quad is extremely sensitive to the controls and has a tendency to rocket off in whatever direction I twitch the sticks. But with these power problems there's no point in trying to tune anything so I'll be waiting for my replacement 2450 30c's before I can get started with any serious flying.

About the batteries, I went for the smallest size and weight which I thought would have enough juice to sustain at least 60% of max amps for a few minutes, but I'm thinking maybe I should order some bigger ones. Tricky though as bigger also means heavier, any recommendations?

Anyways, I've locktite'd the motors and frame so that should be fine for a while. How do I get them loose though, is it enough to put some heat on it with a heat gun?
Posted by RHTizzy | Sep 01, 2012 @ 08:14 AM | 3,913 Views
Went out for the first actual flight this morning since the very short test day before yesterday and actually I'm a happy chappy even though both first and second flight ended in disaster.

I take off too close to the edge of the clearing and 30sec into the first flight it gets into some trees, crashes to the ground and brakes a leg right at the landing joint.
Good thing? It hit the tree about 10meters up, so that's a major improvement as far as the hopping goes

Second flight I learn from the first and take it to the middle of the field. There's quite a bit of wind and it takes a few tries before I get the hang of hovering at a certain height. As the minutes (which feel like seconds) go by it gets harder to control and the end of it is a hard landing whereby one of the motors comes right off. Closer inspection shows all the screws have gone. Probably due to vibrations and lack of locktite
Good thing? I got to see it working properly and even switched from acro to level to baro to mag. And could see the result of each!

Okay so it resonated up and down a bit but it did so keeping itself pointed in the right direction and pretty much level. I didn't get to try RTH out but was happy to see the GPS unit got a fix in seconds!

Done flying for now and won't have time for a few days either but in all honesty, all in all, I'm a happy happy chappy!

Oh yes, I used Q-bond to fix the broken leg and boy is that the best buy ever!
Posted by RHTizzy | Aug 31, 2012 @ 04:56 AM | 4,026 Views
Apart from the obvious safety aspects, incorrect prop choice probably causes more problems in electric flight than any other mismatched component, and it is SO easy to get right, as long as you have the correct equipment.
The equipment Iím referring to is some sort of measuring device such as a Wattsmeter or Power Meter, and these are available from most model shops now at very low cost.
There was a time when even I used to poke about in the dark, trying to establish whether or not I had chosen the correct prop by how hot the motor or NiCad pack got after a couple of minutes! Looking back it was crazy!
When you consider the cost of a melted motor, blown ESC or overloaded Li-Po, paying around £25 for a meter suddenly fades into insignificance and your enjoyment and success in electric flight will suddenly take an upturn, as you will finally be able to see at a glance exactly what is going on.
These meters simply plug in between the flight battery (whether it be a NiMh or a Li-Po) and as you open the throttle of your (well secured) model to full, the various readings instantly indicate the important information you need: current in Amps, power consumption in watts, battery state under load in volts, and in most cases the number of milliamp-hours of battery capacity given up (although this will only be of any use if you are measuring a complete ground run from fully charged to fully exhausted).
As you analyse this information, you can see whether the wattage exceeds the motorís capability, whether the current exceeds the ESC or batteryís constant handling capacity, and whether (in the case of a Li-Po) the battery voltage is being pulled down too low by the current being drawn. It is therefore also very useful in establishing the quality of some of these unknown brands of Li-Po from the Far East - if at 10C it is showing less than 10 volts, then your Li-Po is a lemon.

By Nigel Hawes
Posted by RHTizzy | Aug 31, 2012 @ 03:15 AM | 3,967 Views
For multicopters we typically all use lipos. The ESCs must be set for NiMh and no or soft cut-off because this makes the ESC low voltage cutoff lower so one or more of them does not decide to shut down in-flight which is always predictably bad ju-ju for multicopters. A throttle surge can be enough to momentarily put an ESC in shutdown mode if the ESC lipo setting is selected. Get a separate lipo alarm and gauge your total flying time minus two minutes reserve power for landing are the best practice methods for multicopter lipo management.

by jesolins (Jim)
Posted by RHTizzy | Aug 30, 2012 @ 01:00 PM | 3,986 Views
From what I gather I have more lift than I need as the current build comes to a total of 750gr

I found these specs:

Order No. - Model No. - KVRpm//v - Weight - Motor Dimensions - Shaft Size - Prop/ recom - Battery - Idlecurrent - Loadcurrent - Power(Watt) - ESC(A) - Ri (Ω) - Pull (Approx)

221215 - A2826-15 - 930 - 50g - Ф27.7*26.3mm - Ф3.17*37mm - 9x6/9x3.8 - 2-3Li-Po - 0.4A - 9.5A - 100 - 30A - 0.139 - 330g

So I was thinking I might try these should have enough lift if I stay under a kilo and would also give more airtime per battery
220414 - A2812-14 - 1400 - 22g - Ф28*11.5mm - Ф3.17mm - 6030/7040 - 2-3Li-Po - 0.4A - 3.2A - 60 - 10A - 0.270 - 200g

They probably wouldn't handle as well but I'm not sure what would happen and I've no idea whether I'd like it or not...
Posted by RHTizzy | Aug 29, 2012 @ 03:43 PM | 3,573 Views
Finished building and got the first opportunity today to try and get it in the air. But no such luck, it appears as if there's not enough power to get the quad airborne. Increasing throttle to max just gives enough power to hop a a few centimeters off the ground.

I got a 'pre-selected parts' beginner's kit from RCTimer so I had the least chance of mismatching stuff but it's using RCTimers 2200mAh 15C batteries which were the highest capacity they had available and I'm thinking they just don't have what it takes. I did use the online RC calc to check but is wasn't possible to fill in exact matches to my kit so I'm unsure about the results.

A few good idea's have come up, e.g. that it could be vibrations, but also that the ESC's might not be calibrated properly. People say it's doubtful that the battery is not powerful enough but opinions differ and some say 15C is barely enough and only on a new battery (which wont last long).

I haven't balanced my props properly so they might well be the cause of it. I hope to find some time soon to get it done and check whether that solves it.
Posted by RHTizzy | Aug 28, 2012 @ 03:38 PM | 4,698 Views
Bluetooth Module must have a Baud of 115200bps to connect
Bluetooth should connect to FTDI port (Tx/Rx3) (5v-5v, GND-GND, TX-RX, RX-TX)
When you want to send a new firmware you must unplug the BT to connect USB for uploading it.
MPNG - set appropriate port speed in APM_Config.h

Posted by RHTizzy | Aug 28, 2012 @ 03:19 PM | 4,027 Views
Posted by RHTizzy | Aug 28, 2012 @ 03:13 PM | 4,749 Views
if you power the board from external power source via the extended power in marked on the back of the board then you will be able to take power from the S1-S3 plug (so you dont have to have wires running from the I2c plug). The power supplied to the external power source is the power supplied to the S1~S3 plug so beware what voltage you connect.

Remember to remove the yellow jumper if you are powering the board this way

I connected a two pin header to the "EXTEND POWER IN" & removed the yellow jumper. With this set up you don't have to remove the BEC's (red wires) from the ESC's as removing the yellow jumper has cut them off from the rest of the board, also this means that there is power to "S1~S3" port (eight pin serial port as stated.

I used a 5A\5V UBEC directly off the batteryconnector on the frame which should provide ample power for the CAIOP and supporting modules such as Bluetooth, GPS or sonar.

I soldered 4mm bullet connectors to the frame for the ESC's so if anything needs to be replaced I can just disconnect it. I also soldered the UBEC directly to the frame and it gets it's power from the same connector as the ESC's. To connect the battery('s) I soldered both an XT60 and a Deans plug for convenience. As the Deans are not easy to work with, since then I've replaced them on all of my batteries with XT60's.

As it made more sense (and provided easier access) I soldered all my connectors to the bottom. As this might result in issues out in the wild, I added some hotglue for protection

Posted by RHTizzy | Aug 28, 2012 @ 02:48 PM | 3,796 Views
The following code will write the contents of the Crius AIOP compile to a binary. It is based on the arduino-0022 ide and your location will probably differ. As it's a binary it difficult to decompile but I've also added the code to write the compilation back to the board.

Read sketch
G:\>avrdude -C "G:\Devices\ARDrone\arduino-0022\hardware\tools\avr\etc\avrdude.conf" -v -v -v -v -p atmega2560 -c stk500v2 -U flash:r:"g:/arduino.bin":r -P\\.\COM8 -b115200

Write sketch
avrdude -C "G:\Devices\ARDrone\arduino-0022\hardware\tools\avr\etc\avrdude.conf" -v -v -v -v -p atmega2560 -c stk500v2 -U flash:w:"g:/arduino.bin":r -P\\.\COM8 -b115200
Posted by RHTizzy | Aug 28, 2012 @ 02:32 PM | 5,158 Views
Originally Posted by RHTizzy View Post
Okay did some digging and can report the following: it's definitely not just the ublox that suffers from the reset issue. In fact as far as Ive gathered most gps modules don't hold on to their settings indefinitely unless flashed and most are sold without any user flash cycles left. More on point, the LS20031 is an mtk3339 and eosbandi's gps sketch includes a comment that it's only good for the mtk3329. There are people who have claimed to have the 3339 working in binary mode but they are not specific about what it is they've got working. What I (and I'm sure others like me) are looking for is the ability to initialise the mtk339 on fc boot so it isn't reliant on user settings or the battery to hold on to the appropriate baudrate and nmea sentence settings. As it is, it works in nmea mode and will report it's position to the fc but it's far from optimal as far as cpu load goes and has an appaling accuracy regardless of the number of sats fixed...
After some extensive research, the following works for the Locosys LS200031 with MT3339 chip and will initalise the GPS module on boot regardless of default settings or default speed. It will reconfigure the GPS unit to 115200bps, 10Hz, with GGA+RMC NMEA sentences (minimum needed but I also added GSA so miniGPS can utilise the data).

No need to replace the GPS.ino, just add the following code in the GPS sketch in the section that...Continue Reading
Posted by RHTizzy | Aug 10, 2012 @ 09:03 AM | 5,888 Views

RM450 Kit
  • Package:
  • Wheelbase: 17.7in/450mm
  • Weight: 0.65lb/282g(Appr)
  • Made by advanced engineering material, super strong & smooth.
  • Black color
Crius All in one Pro

...Continue Reading