piotrkundu's blog View Details
Posted by piotrkundu | Mar 04, 2015 @ 03:12 PM | 11,453 Views
If you have Flysky GT3B or Turnigy GTX3 there are a bunch of modifications you can do. The first one would be a LiPo 11,4V 3S Zipyy 2200mah with a XT60 connector, we all have favorits and XT60 is covered unlike the "deans". I opened the GTX3 and desoldered the battery box and soldered on XT60 - not much to talk about.

Once I got that going I run into "Overkillrc.com" and "losikid" and got the voltage regulator. It's a 5 Volt regulator R-785.0.0.5:


Since I ordered the 5V regulator i picked up a STM8S Discovery kit, which is a flashing tool and STM8 dev kit. I't should take 30 mins (but I know it might end up being a full day!.

First thing was making a 4-pin cable and connectors. I used an old 14-pin DIP socket and some wires. It took almost an hours and I got an ERROR!

Error : Cannot communicate with the device !
Check the SWIM cable connection and check all the needed pin connections on the SWIM connector.

If the application code uses Swim Disable and Reset pin as Output or has disabled SWIM Clock Divider:
Try Now to SWITCH OFF and ON the application Power Supply while NRST Reset pin is forced low.

Error : < PROGRAM MEMORY reading failed.
Dadgum! So I spent an hours searching the web and came out short. "Check the soldering"... "bad connection...Continue Reading
Posted by piotrkundu | Jun 09, 2014 @ 07:57 PM | 4,688 Views
Act II of my V922/mcpx clone Brushless conversion!
I just remembered I spent $70 on two BL motors from HK and a Dual ESC with Norwegian software. That's more than the BNF of the V922, and I guess a spent twice that on autorotation gears, CNC upgrades, CF frame (which actually is really really good).

And since I started my BL upgrade I couldn't get any tail and I don't mean the kind of tail you don't get driving a Miata My tail motor just browned out, was stuttering and whatever and I couldn't get it to hold. I thought it was the settings in my TX (since I'm kind of new to this hobby) or my Dual ESC settings. I suspected an burned FET or a short in the ESC and finally I thought maybe that HK 12000kv outrunner might be the issues so I tried an inrunner (Turnigy 1220).

That motor runs smooth!

Again, don't do a Dual Brushless upgrade unless you have no use of your time at all For 3-400 USD you'll get a Trex 150 or 250 and the tinkering-to-flight ratio is in the 1:10, while vice versa for the V922. With the inrunners I'll get a great vibration free indoor heli and some 3D practice, so it might be worth it, but the time I spent I could get a Trex 800E with any scale fuselage, might even squeeze in jet turbine! Stupid
Posted by piotrkundu | Jun 04, 2014 @ 04:10 PM | 4,697 Views
A lot has been discussed earlier, but as always with HK stuff you think it might be a HW issue, not SW or config. Read this later:

The first thing is which motors to mount were.
The Red/Blue ones are the clockwise and the Black/White ones are counter clockwise, or R/B=CW and B/W =CCW for short. The head of the quad is where the two SMD LEDs are. The R/B goes front left and back right and the B/W goes front right and back left - opposite to the product picture on HK and my Hubsan X4:

The second thing is to get your FTDI tool running Arduino app for Mac OSX (v 1.0.5), the MultiWii 2.3, the MultiWiiConf for Mac OSX (1.0) and the key for success the FTDI VCP drivers:

Before I installed the FTDI drivers I got "stk500_recv() programmer is not responding" and I was think "Darn (=) I bought another thing that will waste my non-existing spare time". Installed the FTDI drivers, restarted the Arduino app and still nothing, so I unplugged the USB, plugged it back in waited a few seconds and pressed Upload. This time I got it working and cleared the EEPROM, then I flashed the MultiWii 2.3 as instructed.

SETTINGS for Arduino (in Tools):
BOARD: Arduino Duemilanove with ATmega 328
SERIAL PORT: /dev/tty.usbserialA7039SLM
Next step is to get the MultiWiiConf tool running. First thing was to close the Arduino.app, then run the:
chmod +x MultiWiiConf.app/Contents/MacOS/JavaApplicationStub
chmod +x MultiWiiConf.app/Contents/MacOS/JavaApplicationStub64

Start the MultiWiiConf.app, Choose "Close Comm", Choose "/DEV/TTY.USBSERIAL-A7039SLM" and press START. If you have done it successfully once you will remember it, but doing it the first time I had difficulties figuring it out. I'm not sure if the "Close Comm" is nessesary, just telling you how I did to get it working.

Watch the red arrows!

Posted by piotrkundu | May 13, 2014 @ 03:15 AM | 8,802 Views
While searching the net for a S-FHSS module I ordered an OrangeRX Transmitter module and a Spectrum DSMX sattelite (SPM9645). Most people seem to have range issues with the receivers not with the TX and given how much RF noise I get in my 5W speaker on my Taranis, I dought the OrangeRX TX module will be an issue. I might do the DX5e mod, so I wanted to get a decent sat RX.

There are three things to make this happen:

1. You need to choose mode on your OrangeRX Transmitter module. I use DSMX 11ms (three rapid flashes) and you change that when your TX module is power (LED lights up when you press a button). Press 3 times rapidly to change mode.

2. For DSMX mode you need to HOLD the "SET" button on the 150MRS while powering up (inserting the battery) in binding mode. You have to have your binding plug from Align inserted in the MRS, it's next to your servos. You power up the MRS before you do the Taranis.

3. You have to turn OFF your radio HOLD the "BIND" button, power up the Taranis and make sure Throttel is all the way down and no switches are positioned so a Switch warning is set off. Any of these warnings will prevent the OrangeRX transmitter module to get any power and when you fiddle around with the switches you will eventually let go off that "BIND" button.

In my case I had to set one switch to TH Hold, which is a bit strange for me, since for the V922 if you start in TH Hold your model will not bind.

I definitely need to do the RF Mod for when using the OrangeRX TX module, it's much worse then the HiSky HT8 (FHSS) module or the internal FrSky.

This VIDEO helped me getting my Align T-Rex 150 with a Spectrum sat RX to bind with OrangeRX TX module on a Taranis.
Binding a Taranis/OrangRX with a Spektrum Receiver (5 min 8 sec)

Posted by piotrkundu | May 09, 2014 @ 04:18 PM | 6,737 Views
2014-05-12: Robbe just confirmed that NE480193 binds with Aling T-Rex 150.

NE480193 (S-FHSS)

Here are some other that I guess will NOT work:
NE480133 (DMSS without SLT) and I think NE480114 is an older model.

Code:NE480192 (DMSS with SLT)

Here is a guy using a General Link module with his T-rex 150:
Align T-Rex 150 Test 2 mit Futaba T8 und General link (4 min 11 sec)

(Unfortunately I don't know which one he is using and hopefully my long forgotten german skills will come handy)

These guys have it in stock and say it works with T-Rex 150

Originally Posted by cdauv
Got it confirmed from a user too.

EDIT 2014-06-09:
Now it's dead!
Robbe's new S-FHSS module is dead! (0 min 18 sec)
...Continue Reading
Posted by piotrkundu | May 08, 2014 @ 04:55 PM | 4,814 Views
I got a Rakonheli one way bearing (OWB) and CF main shaft. The OWB is slipping at high rpm. Actually I can throttle up and att highest throttle (HS=6000) the OWB slips and I can hold the main shaft in MY hands

As soon as I throttle down to around 4500-4000 rpm in HS it catches on and I cant hold the main shaft any long and it burns my fingers.

I greased my with silicon grease and you should NOT, they can jam! This one is slipping at high rpm only. You can buy it here:

PS. It's coming off and the stock shaft and stock main gear is going back on. Another $30 USD that could be used for something else.

("If it's not broken don't fix it", yadayada... Well if it sh*t and cheap don't upgrade it.)
Posted by piotrkundu | May 07, 2014 @ 02:29 PM | 5,044 Views
Well, I wish I remembered that part from "school".

P or gain is the factor between input (like a temp sensor) and output (heater). A gain 0.5 would need 50% change in temperatur to give 100% output on a heater. A gain of 2.0 would need 200% change of temperature for 100% output. So 0.5 gain is a faster response than 2.0 gain.

A slower responce would give less overshoot then, right? In case of BLHeli, I get less overshoot (tailwag) when the tail ESC gain is at 0.75, but the again I have to try 1.25 to see the difference. My HS is around 4500 (slow for being a mCPX clone). The tail ESC has no I or D setting.

Funny thing about the tail regulation is that the 3in1 has a throttle to tail mix, which is a blackbox we know nothing about. The tail ESC is guessing what its supposed to from the tail PWM signal, but knows nothing the main rpm or load and it knows nothing about the tailblad either.

The 3in1 has a gyro and some knowledge (lookup table) for the tail response using a stock tailblade and stock brushed motor. I still have my stock tailblad, but my brushless tailmotor I guess is running at least twice that speed.

So I can mess around with my P-value all day and throw it all out of the window as soon as I change headspeed or use a low pitch tailblade. (The ones I have are 1.2mm and the motor shaft is 1.0mm and I broke the ones that used to fit.)

I wish I had access to the main ESC current draw and rpm (which can be used to calculate the torque and...Continue Reading
Posted by piotrkundu | Apr 28, 2014 @ 06:53 AM | 6,566 Views
I've been tinkering with my V922 and upgraded most parts to CNC Alu and CF which in total cost more than the V922. I spent 1-2 manweeks reading up on settings, mods and tweaks.

Ended up buying HK Dual ESC 10A (7A+3A), 14000kv main, 12000kv tail.

1. The Dual ESC connectors were to bulky and I have no issues soldering stuff, so I removed all except the tail.

2. The instruction is for mCPX v1/v2 and connects to where your main/tail brushed motor is. For the V922 that will not work. Use the PWM signal on the FET's (the red dot is for the main, for tail use the leftmost FET (64BL) and connect to the left side pin:
(PS. I also tried the TAIL/MAIN test point on the other side of the board, with no luck.)

3. I tried the 8T 1,5mm 0.3M pinion, which should not be allowed to be manufactured. The bore hole is to big and the pinion is fragile, people reported the 8T being destroyed in mid-flight. I broke mine within 30s just holding it. Never AGAIN.

4. The 9T might be to much for the 14000kv main but you need to Dremel away some plastic to fit the main motor bell and some of the mounting forward part. You will need to enlarge the mounting holes in the frame to fit the 9T. Not much room for the hole closest to the main shaft.

5. NOTE: When you apply CA to the pinion, be careful of the capillary action which will "suck" more glue than you expect. If you have the main gear on the CA creeps there too, otherwise it trickles around the pinion and I stopped...Continue Reading