FirstPersonView's blog View Details
Posted by FirstPersonView | Aug 17, 2012 @ 08:02 AM | 3,132 Views
Its been only a few weeks since I started to try out FPV and after great flights with my AXN I decided to put the gear on my T380!

4000mah 3s for Gear and Quad
200mw 5.8ghz Transmitter
5.8ghz Reciever
$16 HK Sony CCTV Board Cam
Simple HK Osd
Posted by FirstPersonView | Aug 17, 2012 @ 07:39 AM | 3,136 Views
Great flying day today! Just came home after quick flight of my Floater. I am currently using Turnigy 9x with FrSky module (FrSky V8HT) and Rx (FrSky V8FR-II). I have to say it is best I have tried so far! The range and reliability you get for such a low price is unbeatable in my opinion. I used to own a DX5e with Ar600e rx and it was good to a point. I had to switch it as I have a crash with my heli in a pond and it was unretrievable. My tx was having problems which was partly the reason for crash so I decided to give away. I bought myself a 9X and the stock module and Rx was not the best so I switched to FrSky and it is best I have tried! Really, the speed, the everything! I haven't had a problem yet and its been 3 months! For a simple and affordable setup like this I couldn't be happier, I highly recommend to all beginners and intermediate fliers!

Thanks for reading!
Posted by FirstPersonView | Aug 14, 2012 @ 03:26 AM | 3,212 Views
Today I went for a casual FPV flight with my AXN Clouds. I am using 5.8ghz with the foxtech AIO goggles and 200mw tx. I have Super Simple OSD from HK and using 2200mah Battery for FPV gear and plane. I was flying nicely over the trees (lots of trees in my area) when suddenly my rudder seemed to flap uncontrollably, after about 20 seconds of trying to fight with the rudder the plane came to a sudden crash in a tree. The plane and gear were all fine but a few dints were made in the plane. Not sure exactly what happened but I suspect some kind of interference with my radio. I am using DX5e with Ar600e. All was going well in the months I had this setup until this. I tested it again after the crash and all is working fine. Maybe a once in life glitch but you never know.