Jru28b's blog View Details
Posted by Jru28b | Mar 22, 2020 @ 11:35 AM | 5,257 Views
Hi! Fairly new to this site, looking for some help.

Recently purchased a used Timber X from a friend. Had been crashed and was not flyable, so i took the elecs out and bought new wings, fuse, stabs. Put every single servo in the new plane the exact same way, centered them on a tester, all that good stuff. Didn't have any issues until i tried to bind yesterday. New file in my DX9, all the channel inputs are set up right, everything was set up exactly as it was supposed to be according to the manual. The tail servos were fine but all four wing servos are way off. Either maxed out up or down. Everything, trims, sub-trims, all that is zeroed and never been adjusted. Tried putting a 9030T receiver in it to eliminate Y-harnesses. Same exact thing. One flap and one aileron are completely backwards, and frying the servos trying to overextend. So i took the wings off, all servos at zero plugged into the RX, centered the arms and tried again. Same thing again. They return to way off, and twitch every couple seconds. A 9030 doesn't have SAFE or AS3X obviously, so there's no gyro that needs to be calibrated or reset or something. What am I doing wrong?