--Oz--'s blog View Details
Posted by --Oz-- | Apr 11, 2021 @ 05:06 PM | 3,080 Views
This thread is about different ways to control a brushless motor, the pros and cons of the different ways and open discussion about brushless motor drive. All idea's and suggestions welcome.

I have a lot of collected old hard disk drives. The neo magnets are very strong, the head spindle and motor bearings are amazing with zero slop. Controlling the three phase brushless motor is not simply hooking up power wires and it spins like a brush motor does. About 3 years ago I had the idea to drive a brushless motor with a single fet and square wave generator and it works, but with limitations.

I currently have played with these brushless motor drive methods:
A: Single fet and function generator driving the motor.
B: H-Bridge and function generator driving the motor.
C: Using 3 fets, 3 resistor and three caps in a cascade fashion
D: Using 3 fets, a decade counter (4017 setup for 3 count) and a function generator.
E: RC electronic speed control (ESC) driving all three phases, with a servo tester to control the esc.

A: Single fet and square wave generator driving the motors 2 phases
(phase-1 to +supply, phase-2 to fet and then ground). Current only goes one direction.
Pro: Very low cost.
Con: Slow accelerating, decelerating and torque.

B: H-Bridge and square wave generator driving the motor 2 phases.
(phase-1 to +supply, phase-2 to fet and then ground). Current goes both directions.
Pro: Very low cost. (few bucks)
Con: Slow accelerating and decelerating...Continue Reading
Posted by --Oz-- | Mar 10, 2021 @ 10:02 PM | 11,935 Views
I was given this ESC after a crash at the field, when it was given to me the heatsink was gone, a third of the fets was shorted or ripped in two and missing the input caps. After some troubleshooting, it turns out, there was just 6 good fets of the 18, the minimum requirement to get working, after moving the good fets around I now have it working on the bench (no heatsink and reduced power).

Still not knowing what model ESC it was, after searching a bit, it looks closest to a Castle Talon 90A, makes sense for several reasons, 3 fets @ 60A=180A then reduce for thermal reasons and 90A sounds about right, the 5.5mm connectors , the beeps from the motor sound like a castle (from watching YT videos), the led's are in the right place and the huge BEC inside (castle claims 9A cont and 20A peak, and it looks like it). It was recommended to plug in a USB castle link and I borrowed the CC linker and its a Talon 90A.

I ran the esc for two hours at ~10% thro on a little 2826-2200kv motor w/o prop, and it is still working. The stock fet TPH9003NL ($7 for qty=20) is 30V 60A 9mΩ , I found some better fets, the TPH4R50ANH ($12 for qty=20), 100V 60A 3.5mΩ, roughly one third the resistance. I might convert this esc to 12S (changing some caps/resistor values), if nothing else it should run cooler with the much lower RDSon (resistance) FETs.

After the third hour running on bench, it stopped, another FET died, more than likely that FET was wounded. So I removed all fets and now my temporary test setup with external fets (using irzf48n 60V 50A to-220 package). I have run this setup for about 12 hours w/o issues, so I bought the one third resistance fets (60A 100V), will update when they get here and install them.

Question, is there a lower cost option for CC USB link dongle (I use the $2 arduino nanov3 for all my BLHeli_S/_32 ESC, or the passthrough feature of the flight controller), I dont want to spend $20 on CC linker?

~

Posted by --Oz-- | Feb 11, 2021 @ 01:20 PM | 10,227 Views
~~~
Posted by --Oz-- | Jan 20, 2021 @ 02:15 PM | 9,783 Views
I wanted to be able to control the brightness of some LEDs from Ardupilot flight controller.
I wanted 0 to 100% pwm output from the FC pin to drive the gate of a FET, then you can control anything (LEDs/motors/solenoid/etc), but Ardupilot does not have that function.

Ardupilot has servo passthrough function, it passes a RC channel from the Rx through the FC to a output pin. This will require a brushed motor esc, most of them are larger than the size of the FC, and fitting them on a 5" quad is a bad choice. Then I found on AliExpress for $3 shipped, a servo motor esc (for continuous rotation servos).

I got one and have tested it on the bench, its got some issues that I was not expecting.
1. Most Tx/Rx will not output below 1000us and above 2000us, this means you will maximum get +/- 70% speed (see picture).
2. Lowest PWM output is 17.5%
3. Maximum 6V. Maybe possible to modify for more voltage by cutting the FET driver supply trace and feeding more voltage, but I have not found the datasheet to the FZMOS-5X (so-8 package).

Large zero thro dead band 1390 to 1591 (200us)
See the attached picture for the PWM info.

So with the limitations of 6v, 1A, 17% to 70% max output, it will work out of the bag and its low cost and tiny.

AliExpress INFO:
1pcs DIY Dual-way 1A Mini ESC 5V DC Brushed Speed Controller Module Winch Control Bidirectional Driven Circuit Board for DIY RC Part
https://www.aliexpress.com/item/1005...36e34c4duQeMF3
Specification:
- Size:...Continue Reading
Posted by --Oz-- | Apr 30, 2020 @ 12:46 AM | 14,494 Views
I been a PC gamer since the early 80's, yep, a clone of the IBM XT, never bought a prebuilt PC till 5 years ago (for my mom). In the last decade I built a couple i5, i7 and have enjoyed them.

Then I came across this video, 8core cpu for $53 and comparing it to the i9-9900K ($500 cpu) with a very nice 5700 video card, it opened my eyes at used server cpu's. You really need to see the results comparing a old used server xeon to a new cpu.
8 Core CPU for $53....!? Will it BOTTLENECK a RX 5700 XT...!? (16 min 9 sec)


I learned a few things,
1. Used Xeon server cpus are low cost, high preformance,
2. chinese mfg have developed motherboards for server cpu with pc atx form factor
3. video games are mostly limited by the video card (relativity)

That video led me to Aliexpress.com, been there with about 40 purchases for DIY electronics items, but being new to xeon server cpu's I was lost compared to desktop cpu's. I did some searching and found Passmark cpu benchmarking and this russian website (google translates it very well), the guy that runs it is good, he loves bang for buck and tells you how it is. Seems quite a few YT reviewer use his info.

Check out the russian website, across the top is the sockets, look at the better sockets, the 2011 and 2011-3,
https://xeon-e5450.ru/
the xeon build part is good comparing different builds/price
https://xeon-e5450.ru/faq-po-sborkam-na-xeon/

Here is the Passmark website, I started using them from last December,...Continue Reading
Posted by --Oz-- | May 21, 2019 @ 12:05 AM | 11,598 Views
Look at the picture, this picture is amazing once you figure out what happened. The "T" in the top left of the picture is the scope trigger point, ball at rest (0 rpm) 25ms later, the ball is at 3.2 million rpm!
Name: 0rpm to 3.2Mrpm in 25ms - 250W.jpg
Views: 108
Size: 345.2 KB
Description:

EDIT: Here is 0 to 3.4 million RPM in 15ms, thats an average of 227,000 RPM per 1ms (0.001 second)!
Name: 0 to 3.4 Mrpm in 15ms.png
Views: 35
Size: 2.72 MB
Description:


I always set the vertical cursors to my current record (in microseconds), so I can see when I beat my personal best.
I usually prepare 10~15 balls for testing that day, one day, I got to this one ball, I guess things were just right (ball/container/angle/settings). What happened was amazing and unbelievable, with about ~250W (18V ~13A). First hall sensor trigger, it gave a ~0.25 second burst, I could hear the power supply give a quick 60Hz hum, sucking some juice, then the scope displayed high 2 million rpms! The major keys it was legit was no vibrations and the ball was still spinning down from momentum. I have been running the scope at 10us/div (since going for 2+ mil), but I decided to get the big picture, zoomed out the scope to 100ms/div and set single trigger and tried again, moved the hall sensor into position and it happened again, a burst of around ~250ms then hall stops triggering the coil. I zoom the scope into the end of the coil drive signal, this time just over 3 million in a quarter second! I stopped to think about it, no Ford transmission vib's, just pure signing spinning ball. Blown away I called a friend to witness what happened, I...Continue Reading
Posted by --Oz-- | Apr 23, 2019 @ 12:50 AM | 12,072 Views
I bought a couple of these for $27 shipped on ebay, turns out they were different than the three I already have working (DPS-800GB). Different connector, so I needed to figure out how to turn them on.

As can be seen in the pictures, the 5th pad on top and bottom need to be shorted to ground and the supply turn on. The big pad closest to the edge is ground on top and bottom, of course next to it is 12V.

-------------------------
INFO on how to turn on the DPS-1200FB-1 PSU
To turn on, simply connect pins 36 and 33 with a resistor of 500Ω or less, even a short is fine.

Today I played with my pair of DPS-1200FB-1 PSU. So I tried a 1K resistor, it would not turn on, then a 750Ω (the two most common resistances I found people using in my search last night), same, nothing out the main output. Then I grabbed my resistor decade box and connected up with a ammeter.

Open 3.1v 0mA
1k 0.58v 0.5mA
800 0.54v 0.57mA
600 0.34v 0.57mA
500 0.29v 0.59mA
200 0.12v 0.62mA
100 0.06v 0.63mA
0 0.001v 0.65mA

My two power supplies turn on at 500Ω or lower, indicating it needs under 0.3v to trigger the turn on. As can be seen there is very low power and a wire works fine.

When the main output is off, the 12V standby (SB) and the 5V output(s) on the bottom of the connector are on.
----------------------------
Posted by --Oz-- | Feb 13, 2019 @ 10:40 PM | 15,461 Views
I bought the M9-R on sale for $34 a pair 6 months ago, I just couldn't pass them up. Even though I did self modded hall gimbals in Jul 2016 and still work perfect, around 20K flights on them.

I wanted to use the short throw on the thro and modify the other gimbal back to normal 60 degree throw, also they will match color. After collecting dust for 6 months, in a couple of minutes looking at it, bingo, simply add four 1.5mm washers under the red ALU plate (see picture), now it has the stock ~60 degree travel like the stock gimbal has.

I took some OTX raw data and photos to compare travel degrees of all four axis. Looks like the raw travel numbers are within reason of the other axis (AIL and YAW) movements (+/-~100). These numbers have a lot to do with how close the sensor is to the magnet (closer gives larger range).

I took some pictures to compare my 1.5mm washer mod to see how close it is to 60 degrees. Roughly its ~1.5 degrees less than the other two axis (AIL & YAW). Of course there is some error in my measurements. I am pretty happy with a first try with 1.5mm thick washer guess.

I did the heat shrink tubing over the thro drag bar and a dab of rc car diff grease, this thro gimbal now feel as smooth as anything I have felt. So far pretty happy with them.