FR4-Pilot's blog View Details
Posted by FR4-Pilot | Jun 03, 2020 @ 02:54 PM | 11,232 Views
After a few years of learning with Proto-X quads, Eachine FatBees and E-Flite Inductrixes (original, Plus and brushless), I decided to give this guy a try:

F54 (4 min 6 sec)

3 BLADE GREEN 3S 4 3 C x264 (4 min 11 sec)
...Continue Reading
Posted by FR4-Pilot | Feb 09, 2020 @ 12:27 AM | 11,102 Views

TH2FS finally showed up

Tried to bind it to my old Futaba 7UAFS 72Mhz transmitter with FrSky DFT 2.4G module, just to see what happens. It bound to it, but once in BetaFlight there was no receiver activity, no matter what combination of things were tried. I got nervous since I had accidentally pressed the BOOT button numerous times instead of the BIND button on the other side of the FC board. Was able to do a test-bind with Mike's FrSky transmitter to verify the quad does work and I haven't hosed anything, yet

I have a RedCon R720X DSMX receiver that I'll be using with this quad. It will require complete disassembly as the solder pads for RX1, GND and 3.3V are on the bottom side of the flight controller board. And, there is a capacitor soldered across the 3.3V and GND pads by Emax (not shown this way in the user manual) that needs to stay.

While I have the quad apart I will go directly to a XT30 power connector as well. Along with the quad I bought 2 450mAh, 2 525mAh, and 2 550mAh lipos to see which one's I like the best, all with XT30 connectors.

I need to come up with some way to keep the flight controller and the motors from moving during the surgical process since everything has to be removed from the bottom plate (frame). Thinking of borrowing Joshua Bardwell's technique of using a blue sticky-putty compound to hold everything in place ... we'll see how that goes. The motor wires are pretty fragile and I don't want to break any if a motor accidentally dangles or something.

Here we go .... !
Posted by FR4-Pilot | Jun 13, 2019 @ 05:26 PM | 6,694 Views
11-27-20 DSMX version on the way

Posted by FR4-Pilot | May 01, 2019 @ 05:50 PM | 6,171 Views
Since the Beta85 Pro 2 didn't work out (either of them) let's try this little guy next ... This one has a current sensor

Posted by FR4-Pilot | Jul 25, 2018 @ 11:47 AM | 3,580 Views
Pretty good deal from Costco - Get the drone package, plus extra battery, 32G microSD card, and carrying case for $10 less than the price of the basic drone package

Nearly the same size as the GepRC CineQueen 4K:

Posted by FR4-Pilot | Aug 28, 2017 @ 08:30 PM | 4,031 Views
This one just arrived from RDQ. It has a Speki+ DSMX receiver, buckle battery strap, TPU stack support, but no red Avan Rush props, only 2 sets of black HQ Props. Also includes 2 zip-ties and heat shrink to mount the Speki's antenna wires.

Well, here's hoping that this quad shares the awesome quality of my Mobula 6 (fingers crossed).

Posted by FR4-Pilot | Jul 19, 2017 @ 10:31 PM | 9,090 Views

After 7+ hours of trying to setup this pre-owned quad copter I'm done. It kinda works, but not like it's supposed to. According to JavaScript, it just needed a receiver (and batteries). I've setup, modified, and re-setup a bunch of quad copters now. Usually takes 2-3 hours max with all the soldering, mounting, wiring, Betaflight and maiden.

The FC is flakey. It will not recognize my new RadioMaster R81 SBus FrSky Rx. It will recognize my DSMX PWM, but only 4 and 1/2 channels most of the time. Sometimes it sees 5 or all 6, but then with next lipo change is back to 4 and 1/2. Extremely odd.

The user manual needs serious fixing too. If you don't have any kind of inverted signal receiver, then you cannot use the connector on the FC, period. The manual says something like PWM/S.BUS/RX2INV. I have PWM and S.BUS receivers, but they're not inverted. Then, if you don't have an inverted signal receiver, it tells you to use solder pad RX1 on the FC, which is horse sh-i-t because UART1 is already committed to Tramp/Smart Audio, so you really need to use the RX2 pad. So even with the wiring shown in the photo below I can only get my PWM Rx to work - the S.BUS Rx is never recognized by Betaflight, even with proper config settings. Grrr!

The VTx is damaged. Within 10 seconds of plugging in a lipo (3S used for testing) it gets severely hot, all three LEDs flash quickly, the picture goes completely to static then the Vtx completely shuts down. The antenna had been...Continue Reading