perttime's blog View Details
Posted by perttime | Sep 30, 2020 @ 11:33 PM | 2,462 Views
Conditions looked fine on Tuesday, so I took the Spitfire to the larger nearby clearing again. Getting there, I could feel some wind but went on and launched anyway. That didn't last long. I suspect I got some turbulence from the hilltop trees. The impact was hard enough to break the nose completely off in front of the wing. The good thing was that it was a clean break and easy to glue. Uhu POR to the rescue.

Wednesday had almost calm weather towards the evening, so I went again. Launched several times, flew around, and did a few loops too. No good landings, though. Getting close to the ground I always managed to get the Spitfire into a slight climb and it stalled into the grasses. Need to work on that. Forecasts say there's going to be too much wind for my liking, for at least 10 days, though.
Posted by perttime | Sep 25, 2020 @ 11:08 AM | 1,681 Views
The calm afternoon/evening arrived today.

So, with transmitter and plastic bag in a laptop bag, the ugly Spitfire in my hand, and a battery pack in my pocket, I walked to the larger nearby clearing. Some people were out with dogs, so I waited until they got a little further away.

Before I had time to get too tense, I switched on the transmitter, connected the battery and closed the hatch. Control surfaces still moving the right way? Check. Neckstrap on, model in the left hand (I throw better with my left), push the thottle stick a bit awkwardly, brace for the impact.

And it was flying! For the first few seconds I was over-controlling, even with a plenty of expo dialled. Then, it was flying surprisingly steady. I didn't feel compelled to climb to "high" altitudes, so flew circles and figure eights, and such, not too far from me. Power wasn't all that great. It might be the old battery sagging. Still, I managed a strange shaped loop and a half cuban.

I thought I'd need to land it some time, so slowed down. I slowed down too much and it wanted to drop a wing. The first landing was not pretty. No damage, though, so I launched again and flew some circles. The second landing was better but there was a hint of wing drop before I got it down. I need to keep up more speed next time.

The GWS Spitfire is still in one piece.

I told it is ugly (for a Spitfire).

Before:


After:

Posted by perttime | Sep 15, 2020 @ 12:56 PM | 2,645 Views
I had a model in the air, after many years of not flying at all.

I'd thrown together a green GWS Spitfire, with a home made mount for a brushless motor that I've had for a long time. It is uggly as .... with no spinner and some of the green paint gone with the masking tape that I used while gluing it together.

It was calm just before sundown, so I collected myself, the Spitfire, my old transmitter and an OLD LiPo pack that has miraculously survived the years - and went into the park just behind the apartment building.

I only did some glide tests down a slope, over long grass and even longer weeds. My launches were a bit shaky but a few of the better ones had the Spitfire in the air for a while and responding to ailerons and elevator about as expected.

And I didn't break it!

Next time we get some calm weather, I will go to a larger clearing and launch it under power. That might take a while, though.