SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Dec 10, 2010, 08:06 PM
Registered User
Joined Sep 2009
429 Posts
Yes rocket and guys thats what i did and it looks good i was using the gel and noticed a problem if you have bad vibs you will lose tail control, i believe that was my whole issue from the front when i was using the ds520 because at one point it held rock solid.


Loc if you called them there always dumb i learned that years ago so if you have a issue use the forums they have you will get a real fast response.

Back to tail/gyro tape im hopeing from research with the vibration gyro tape if something like that happens i will have some control. Im very intense on this because i fly around houses and people and want to be very safe as can be will be flying 8.30am.

They sent me 2 pinions i bought 1
anton831 is offline Find More Posts by anton831
Reply With Quote
Sign up now
to remove ads between posts
Old Dec 10, 2010, 09:09 PM
Not a six pack
rocketscience's Avatar
USA, IL, Chicago
Joined Jul 2008
5,307 Posts
Quote:
Originally Posted by lectroglide View Post
well EXI isnt gonna get our bizz for a lonnnnnng time....last week we called and told them they shorted us some parts on the plastic 500 "THEY WERE WELL AWARE IT WAS THE WHOLE TAIL BOOM PKG" so here we are 7 days later and nothing shows up, so we call and play the waiting game then when they answered ask them what hell happened to the parts you said you send right out???, thier reply was "oh we didnt know what you meant about the whole boom pkg" well you freakin idiots!! we sat right thier and told you what happened and you said youd send the parts right out, oh ok will send them right out
best thing to do is post it on rcdiscuss.

1) they seem to check that every day
2) it's in writing so there's no mistake. just be clear.
3) everyone else gets to see their mistake so it's important they rectify it.
rocketscience is offline Find More Posts by rocketscience
Reply With Quote
Old Dec 10, 2010, 09:46 PM
AMA# 548800
jombo's Avatar
United States, CT, Trumbull
Joined Dec 2007
5,205 Posts
It's fixed, it was the gears. I took them out took them apart and slowly put the screws back in. I put the whole thing back together and gave it another try. It spun up perfectly . The 6 cell 2200 are too light the thing it still tail heavy, I guess the next thing is to get some 6 cell 3000 lipo's.
jombo is offline Find More Posts by jombo
Reply With Quote
Old Dec 10, 2010, 10:11 PM
Registered User
lectroglide's Avatar
United States, WA, Puyallup
Joined Aug 2006
2,240 Posts
Quote:
Originally Posted by rocketscience View Post
best thing to do is post it on rcdiscuss.

1) they seem to check that every day
2) it's in writing so there's no mistake. just be clear.
3) everyone else gets to see their mistake so it's important they rectify it.
wheres RCdiscuss? disreguard
lectroglide is offline Find More Posts by lectroglide
Last edited by lectroglide; Dec 10, 2010 at 10:16 PM.
Reply With Quote
Old Dec 10, 2010, 11:20 PM
Not a six pack
rocketscience's Avatar
USA, IL, Chicago
Joined Jul 2008
5,307 Posts
Quote:
Originally Posted by lectroglide View Post
wheres RCdiscuss? disreguard
I just noticed people posting issues on their facebook page. Again, for the world to see. Seems to get resolved decently there too from the couple posts I read.
rocketscience is offline Find More Posts by rocketscience
Reply With Quote
Old Dec 11, 2010, 12:05 PM
Registered User
Joined Sep 2009
429 Posts
well another successful flight gyro tape work great i did foam,foam, plate foam my electronics stay cold, escand motor lipo barely warm "BUT" im going to have to run a receiver lipo at the end of my flight my tail started getting loose real loose i sat her down quick. The new motor is awesome and no bogging im trying to find a way to speed her up it was like flying in slow motion my max head speed was around 3000rpm or more. my poor nano's ant enough 4 min flight
anton831 is offline Find More Posts by anton831
Reply With Quote
Old Dec 11, 2010, 12:10 PM
Registered User
Joined Sep 2009
429 Posts
Almost forgot now its making that sweet weird noise like a amplifier that heli's make. i think im dead on sweet sweet sweet
anton831 is offline Find More Posts by anton831
Reply With Quote
Old Dec 11, 2010, 05:34 PM
Registered User
lectroglide's Avatar
United States, WA, Puyallup
Joined Aug 2006
2,240 Posts
ok, fianally fooling around with the 225s and trying to figure out how theyll mount up, dont see any problem mounting one end but would appreciate it if someone could illustrate or post ideas what to do about the other end where nothing lines up

the pix Ive seen only show a top view
lectroglide is offline Find More Posts by lectroglide
Last edited by lectroglide; Dec 11, 2010 at 06:23 PM.
Reply With Quote
Old Dec 11, 2010, 05:45 PM
M0unt@in M0del$ minion
turbojoe's Avatar
United States, AZ, Mesa
Joined Jul 2002
7,319 Posts
Quote:
Originally Posted by lectroglide View Post
ok, fianally fooling around with the 225s and trying to figure out how theyll mount up, I dont see any problem mounting one end but would appreciate it if someone could illustrate or post ideas what to do about the other end where nothing lines up

the pix Ive seen only show a top view
Gimme a few minutes. I'll see if I can get some good shots of how I did mine.

Joe
turbojoe is offline Find More Posts by turbojoe
Reply With Quote
Old Dec 11, 2010, 06:13 PM
M0unt@in M0del$ minion
turbojoe's Avatar
United States, AZ, Mesa
Joined Jul 2002
7,319 Posts
OK. Whether it's right or wrong here's how I did mine. I used the aluminum nut blocks that came with the kit. I used Align shims on the front cyclic servos only. The shims aren't needed on the elevator servo. It's impossible to see on the front servos but on the elevator servo you can see that one of the "nuts" is mounted with the raised area UP and the other is mounted DOWN. That takes up all the excess space in the servo bay and they fit nice and snug. Hope the pictures help. Sorry for the poor lighting.......

Joe
turbojoe is offline Find More Posts by turbojoe
Reply With Quote
Old Dec 11, 2010, 06:30 PM
Registered User
lectroglide's Avatar
United States, WA, Puyallup
Joined Aug 2006
2,240 Posts
thanx for the pix man and looks like Ill just have to tough this one out are those spacers Im seeing behind the balls? Im assuming those are thier otherwise the rods would stick out at an angle
lectroglide is offline Find More Posts by lectroglide
Last edited by lectroglide; Dec 11, 2010 at 06:49 PM.
Reply With Quote
Old Dec 11, 2010, 06:44 PM
M0unt@in M0del$ minion
turbojoe's Avatar
United States, AZ, Mesa
Joined Jul 2002
7,319 Posts
No spacers on the balls though they are Align balls. No different in size than stock other than they have longer screws that go all the way through the horn arm and the links fit better.

Joe
turbojoe is offline Find More Posts by turbojoe
Reply With Quote
Old Dec 11, 2010, 07:06 PM
Registered User
Joined Sep 2009
429 Posts
nicelly explained that was a good question
anton831 is offline Find More Posts by anton831
Reply With Quote
Old Dec 11, 2010, 08:08 PM
Not a six pack
rocketscience's Avatar
USA, IL, Chicago
Joined Jul 2008
5,307 Posts
Quote:
Originally Posted by turbojoe View Post
That takes up all the excess space in the servo bay and they fit nice and snug. Hope the pictures help. Sorry for the poor lighting.......

Joe
Where are you guys getting washers for the servo mounting screws? I had to use the self-tapping screws that come with the 225bb's and align plastic screw nuts. Those self tapping screws are really long, would have loved to use the machine screws that came with the EXI but I just didn't have enough washers.

I like what you did to take up the slack. Good thinking.

Oh on my friend's I just centered the 225s in the servo hole and then tightened it down. Seems pretty solid. Was able to hover it anyway. He's going to put a Sea King fuse on it.
rocketscience is offline Find More Posts by rocketscience
Reply With Quote
Old Dec 11, 2010, 08:18 PM
M0unt@in M0del$ minion
turbojoe's Avatar
United States, AZ, Mesa
Joined Jul 2002
7,319 Posts
Quote:
Originally Posted by rocketscience View Post
Where are you guys getting washers for the servo mounting screws?
They're just #2 flat washers. The holes are kinda large for 2mm socket heads but they work fine. You can get the washers from Dubro. I have a pretty large selection of RTL hardware in SAE and metric. It comes in really handy at times.

Joe
turbojoe is offline Find More Posts by turbojoe
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product EXI 500 Carbon Edition RC Helicopter & 450/500 Fiberglass Canopies starting $12.95 xheli XHeli 2 Oct 06, 2009 05:03 PM
Discussion Official Trex 500 Thread? learninginverted Electric Heli Talk 0 Mar 17, 2008 11:57 PM