HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Mar 06, 2010, 03:50 PM
Registered User
Joined Jan 2010
5 Posts
Ouch

I had my 11th flight on my 500 when I found out the hard way that I must have missed the thread about checking the head and reapplying lock tight. The long linkage ball screw fell out and the heli started doing nice uncontrolled loops. I must say it look cool, but thatís not how I wanted to start doing loops. I think it got 3 loops in before I cut the power and let it drop. The good news is the damage is not as bad as it could have been or worse if it was low and close to me.
mandrew is offline Find More Posts by mandrew
Reply With Quote
Sign up now
to remove ads between posts
Old Mar 06, 2010, 03:54 PM
Registered User
jcervantes11's Avatar
Joined Sep 2003
1,412 Posts
Quote:
Originally Posted by Tumbler View Post
I can't find the battery to my video camera, but my girlfriend was nice enough to shoot some video with her regular camera for me. The quality is not the best, but shows some of what this thing can do with cheapo stuff.

Turnigy 930 cyclic servos
hs-82mg TR servo
GY48 Gyro
Hobbymate Motor
Flyermate 80a ESC
6s 3000 20c Turnigy battery

http://www.youtube.com/watch?v=_50dUrd5Hl4
Wow nice flying.
jcervantes11 is offline Find More Posts by jcervantes11
Reply With Quote
Old Mar 06, 2010, 04:03 PM
Registered User
jcervantes11's Avatar
Joined Sep 2003
1,412 Posts
Quote:
Originally Posted by thunderfrog View Post
I can see by some photos that people are leaving the stickers on there motors.
I've read in a couple of difference threads of stickers coming undone and screwing up the motor.
Just a thought.

I like your flying tumbler especially the piro/flips. I can do a loop, roll, and some inverted flight.
But anything else I try on the simulator usually ends with a crash.
I'll keep practicing.
I heard about that but i'm to lazy to take the label off also it takes away the looks. LOL but i took it off already. Well that damn hk 401b gyro kick ass then my xmhobbies g401b i used last. I'm going to check if the gyro is loose inside with the xmhobbies. Their both the same gyro just different label also.
jcervantes11 is offline Find More Posts by jcervantes11
Reply With Quote
Old Mar 06, 2010, 04:33 PM
Registered User
thunderfrog's Avatar
Joined Nov 2009
196 Posts
Finally got some decent weather and was able to get a couple good flights in.
I noticed on some ones t-rex the paddles were alot bigger then my plastic ones.
So Im going to get $8.00 skids tail blades paddles.
Im using the dx6i with the ar6200 receiver on my second flight when I landed I noticed both light on the two receivers were flashing. They weren't flashing when I took off.
Any thoughts?
thunderfrog is offline Find More Posts by thunderfrog
Reply With Quote
Old Mar 06, 2010, 04:56 PM
Team Wack-a-Mole
Melnic's Avatar
Maryland
Joined Oct 2008
8,439 Posts
Quote:
Originally Posted by thunderfrog View Post
Finally got some decent weather and was able to get a couple good flights in.
I noticed on some ones t-rex the paddles were alot bigger then my plastic ones.
So Im going to get $8.00 skids tail blades paddles.
Im using the dx6i with the ar6200 receiver on my second flight when I landed I noticed both light on the two receivers were flashing. They weren't flashing when I took off.
Any thoughts?

Flashing AR6100 or 6200 lights means it rebooted in flight. It could have been static or a power drop. Do you have a switching BEC supplying power? Using digital servos?
Melnic is offline Find More Posts by Melnic
Reply With Quote
Old Mar 06, 2010, 05:03 PM
Team Mulikow 3D
Oxfordshire, UK
Joined Jan 2007
4,098 Posts
Quote:
Originally Posted by thunderfrog View Post
Finally got some decent weather and was able to get a couple good flights in.
I noticed on some ones t-rex the paddles were alot bigger then my plastic ones.
So Im going to get $8.00 skids tail blades paddles.
Im using the dx6i with the ar6200 receiver on my second flight when I landed I noticed both light on the two receivers were flashing. They weren't flashing when I took off.
Any thoughts?
The flashing lights mean that your Tx lost contact with your Rx, what probably happened was that you flew one flight, changed batteries and then flew another with out turning the DX6i off and on again.

To avoid this ....... turn Tx on, Connect battery to heli, fly, disconnect heli battery, Tx off then on again, fit and connect new heli battery, fly, disconnect heli battery etc etc. etc.
MikeHRC is offline Find More Posts by MikeHRC
Reply With Quote
Old Mar 06, 2010, 05:31 PM
Registered User
jcervantes11's Avatar
Joined Sep 2003
1,412 Posts
Quote:
Originally Posted by thunderfrog View Post
Finally got some decent weather and was able to get a couple good flights in.
I noticed on some ones t-rex the paddles were alot bigger then my plastic ones.
So Im going to get $8.00 skids tail blades paddles.
Im using the dx6i with the ar6200 receiver on my second flight when I landed I noticed both light on the two receivers were flashing. They weren't flashing when I took off.
Any thoughts?
Get the align upgrade kit that comes with paddles, landing gear and tail blade. Under 10 bucks.
jcervantes11 is offline Find More Posts by jcervantes11
Reply With Quote
Old Mar 06, 2010, 05:45 PM
What is a plank?
mainblades's Avatar
Kingfisher, OK
Joined Jul 2006
225 Posts
Quote:
Originally Posted by Melnic View Post
mainblades, that a fusonic 9257 on the tail?
Is it the digital or analog version?
Let me know how it performs.
Yes it is and digital. So far break in batts. Here is a video, gain is a bit high.
http://www.youtube.com/watch?v=zTI5AB-SZVo This was before i got my replacement parts from xheli. Got them in and installed. All was perfect. Boom holder and seesaw.
mainblades is offline Find More Posts by mainblades
Reply With Quote
Old Mar 06, 2010, 07:00 PM
Registered User
jcervantes11's Avatar
Joined Sep 2003
1,412 Posts
Quote:
Originally Posted by Melnic View Post
Flashing AR6100 or 6200 lights means it rebooted in flight. It could have been static or a power drop. Do you have a switching BEC supplying power? Using digital servos?
Melnic ever baught the linkage rod? If so does it come with both small plastic link and longer one? They all look one side, when i baught the linkage rod and plastic link, it was all smaller one, even smaller then what the kit have.

http://ep.yimg.com/ca/I/yhst-9458232..._2093_20117778
jcervantes11 is offline Find More Posts by jcervantes11
Reply With Quote
Old Mar 06, 2010, 08:08 PM
Registered User
thunderfrog's Avatar
Joined Nov 2009
196 Posts
Quote:
Originally Posted by Melnic View Post
Flashing AR6100 or 6200 lights means it rebooted in flight. It could have been static or a power drop. Do you have a switching BEC supplying power? Using digital servos?
Im using the turnigy plush 80a w/ubec and turnigy 930 servos.
Im not using an external bec.
Im sure I turned off the transmitter after the first flight.
I rebound it and going to have to keep an eye on it.
I think the motor rpms dropped a little during flight, thats why I landed, then I noticed the lights flashing.
thunderfrog is offline Find More Posts by thunderfrog
Reply With Quote
Old Mar 06, 2010, 10:20 PM
Registered User
Joined Sep 2009
428 Posts
[QUOTE=thunderfrog;14526345]Im using the turnigy plush 80a w/ubec and turnigy 930 servos

your having static problems thats what the 500 helis are known for. they came out with the tt for one of those reasons if you keep flying it that way its going to get a mind of its own, the simply fix is running a gound wire thats in early post if you herd the motor lose power it was going into failsafe for a split second,with helis everything happens so fast
anton831 is offline Find More Posts by anton831
Reply With Quote
Old Mar 06, 2010, 10:24 PM
Registered User
jcervantes11's Avatar
Joined Sep 2003
1,412 Posts
Quote:
Originally Posted by thunderfrog View Post
Im using the turnigy plush 80a w/ubec and turnigy 930 servos.
Im not using an external bec.
Im sure I turned off the transmitter after the first flight.
I rebound it and going to have to keep an eye on it.
I think the motor rpms dropped a little during flight, thats why I landed, then I noticed the lights flashing.
Thunderfrog I have no issue with my dx6i with ar7000.
jcervantes11 is offline Find More Posts by jcervantes11
Reply With Quote
Old Mar 06, 2010, 11:11 PM
Registered User
SAC - MAN's Avatar
Sacramento
Joined Feb 2008
136 Posts
what do most of you fly in fixed end points or governor mode ?? I have been flying my 500 in gov mode but have always flown my 400 in fixed end mode ?? I like the way both fly. does one work better for 3d flying ? Im not doing much 3d yet so dont know...
SAC - MAN is offline Find More Posts by SAC - MAN
Reply With Quote
Old Mar 06, 2010, 11:29 PM
Team Wack-a-Mole
Melnic's Avatar
Maryland
Joined Oct 2008
8,439 Posts
Quote:
Originally Posted by thunderfrog View Post
Im using the turnigy plush 80a w/ubec and turnigy 930 servos.
Im not using an external bec.
Im sure I turned off the transmitter after the first flight.
I rebound it and going to have to keep an eye on it.
I think the motor rpms dropped a little during flight, thats why I landed, then I noticed the lights flashing.
I had a static issue once. I think it was static, but never sure. I normally silicone spray my belt every 5 or so flights. That time, it was dry outside (fall) and I had not sprayed the belt in a while.
Melnic is offline Find More Posts by Melnic
Reply With Quote
Old Mar 07, 2010, 05:37 AM
What is a plank?
mainblades's Avatar
Kingfisher, OK
Joined Jul 2006
225 Posts
What do you all have your low voltage cutoff set to on your esc? 3.0v or 3.2v
mainblades is offline Find More Posts by mainblades
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product EXI 500 Carbon Edition RC Helicopter & 450/500 Fiberglass Canopies starting $12.95 xheli XHeli 2 Oct 06, 2009 04:03 PM
Discussion Official Trex 500 Thread? learninginverted Electric Heli Talk 0 Mar 17, 2008 10:57 PM