HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Dec 15, 2008, 11:26 PM
Registered User
Trion, Ga
Joined Sep 2008
20 Posts
Discussion
Servos on Falcon 40 going too far!!!!!

I had a small crash and and broke the blade holder. When the heli hit I was already all the way down on the throttle. Well I ordered the parts and some super skids and a super boom got it all togerther and it looks great. BUT, when I spin it up the tail motor doesn't run. My first thought was well Ive got a spare tail motor no problem. Then when I got to working the head and checking it out I noticed the servos are traveling too far and binding. They push the swashplate so high it hits the top of the swashplate stay. Also I dont think my 4n1 is initializing. Any help would be greatly appreciated. If it is the 4n1 where can I get one I see they are out of stock everywhere or what can I upgrade to. And also its both servos doing it not just one. I checked the tail motor by hooking it up to the main motor plug and nothing. Then I hooked the tail plug up to the main motor and it worked so my tail motor is bad but why are my servos going too far.
kbailey45us is offline Find More Posts by kbailey45us
Reply With Quote
Sign up now
to remove ads between posts
Old Dec 15, 2008, 11:56 PM
Registered User
Trion, Ga
Joined Sep 2008
20 Posts
My 4n1 is initializing. But it initializing very quickly is that ok.
kbailey45us is offline Find More Posts by kbailey45us
Reply With Quote
Old Dec 16, 2008, 12:16 AM
Cranky old fart
Balr14's Avatar
Germantown, WI.
Joined Oct 2007
21,486 Posts
First, just disconnect the motors and test the servos.
Balr14 is offline Find More Posts by Balr14
Reply With Quote
Old Dec 16, 2008, 12:46 AM
Registered User
Trion, Ga
Joined Sep 2008
20 Posts
I have done that and the middle linkage is hitting the blade holder here is a pic. Everything is working fine except the servos just seem to be going too far.
kbailey45us is offline Find More Posts by kbailey45us
Reply With Quote
Old Dec 16, 2008, 08:42 AM
Cranky old fart
Balr14's Avatar
Germantown, WI.
Joined Oct 2007
21,486 Posts
Does it do the same thing going up and down? Can you change to a different hole on the servo arm? Do you have a different servo you can test with?
I've had similar symptoms to what you describe and it turned out to be a bad servo.
Balr14 is offline Find More Posts by Balr14
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Servos for Falcon 40? thanosd Micro Helis 2 Jul 10, 2008 06:02 PM
HS 85MG servos on a .40 mustang conversion? roadhogtri Glow to Electric Conversions 9 Nov 11, 2005 05:01 AM
HS-60 Servos on the Duskstik? Too Heavy? mrebman Parkflyers 2 Sep 09, 2001 10:04 PM
mounting servos on a round boom fuselage papichulo Parkflyers 2 Aug 05, 2001 04:24 AM
Is the Current deal on the Eco 8 too good to pass up? Adam Neat Electric Heli Talk 4 Jun 23, 2001 01:12 AM