SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Feb 25, 2003, 11:54 PM
MEDIC!!!!!!!
roguewolf's Avatar
Near Fresno, California
Joined Sep 2002
1,741 Posts
Have I messed up my HE cells....?

I have a couple of 7 cell HE packs that I regularly use in 7-8 amp applications....probably about 30-40 cycles, initially broken in at 1/10C for three cycles.....

...I put one of the packs into a twin motored plane that drew approximately 14 amps (Motocalc)...it flew only briefly due to dumb thumbs and a reversed servo

...I put the pack into my Slowstick after the not so ugly (but stupid) crash and it stuttered badly at full throttle..thinking "oh great, now another dying motor", I put the SS down and put in a 600AE pack, no stutter....then put in the HE pack that hadn't been in the twin, no stutter...

....wondering what was up, I put the SS back down again and loaded up the HE pack that I had flown earlier, same stutter at full throttle, alright at part throttle, but can't seem to deliver the full amp draw...

I've asked others about the ability of the HE cells to deliver 15 amps and was told it was possible...but maybe not with cells that are slightly used?
roguewolf is offline Find More Posts by roguewolf
Last edited by sierra aardvark; Feb 25, 2003 at 11:59 PM.
Reply With Quote
Sign up now
to remove ads between posts
Old Feb 26, 2003, 02:04 AM
Dimension Engineering
Akron, Ohio
Joined Jan 2002
1,705 Posts
Check your pack's wiring for crash damage, a weakened solder joint or broken wire might do that. Batteries that are just going soft won't stutter as much as just not provide any juice,unless they're so low that your ESC is cutting in and out.

So first i'd check the pack for wiring damage, then fire up the olde multimeter and see what your voltage at full load is.
Comatose is offline Find More Posts by Comatose
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question Oops, I may have messed up my DL50? kilmerrc36 Hand Launch 6 Dec 29, 2006 07:51 PM
Messed up my Yak55...Stupid Foam. slopilot 3D Flying 20 Aug 08, 2005 01:10 PM
Help! Messed up my transmitter Vol GWS (Grand Wing Servo) 2 Jul 16, 2004 05:35 PM
HELP! I have messed up a model... soholingo The Builders Workshop 5 Jun 06, 2004 01:33 PM
TOG you sure have messed up my bench MatRat Foamies (Kits) 1 Dec 29, 2003 11:26 PM