HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Aug 17, 2008, 02:11 AM
I'm lost.. again..
Vaportech's Avatar
Pueblo West Colorado
Joined Jan 2008
71 Posts
Discussion
Getting "waiting for GPS data" on Dragon OSD

Hello all! Rainy weekend here in Colorado and took some time to install my dragon after receiving it four months ago. When I apply power, I see BOB4 flash on the screen and then it goes immediately to waiting for GPS data and stops there. When I received the RTF dragon, it had a 1inch or so antenna cable that I had to extend to make it work.... Before I started cutting and soldering i wrote down the config it arrived pinned and wired. Looking through the threads, it seems my issue is with the connection of the the GPS antenna. However, the little 1" wire/connection i received only has 1 red and the rest are black wires which makes it tough to figure out which one I screwed up on. Does anyone have a wiring diagram for the antenna or some advice of how to resolve my problem? I've ohm'd out and matched the original config it arrived in and it always is looking for GPS data.
Thanks,
Dave
Vaportech is offline Find More Posts by Vaportech
Reply With Quote
Sign up now
to remove ads between posts
Old Aug 17, 2008, 04:26 AM
Registered User
Joined Aug 2006
76 Posts
Well, you're having more luck than me!

I also finally wired up my Dragon this weekend. After correcting the video cable (the manual appears to describe the wiring incorrectly, at least with respect to the photo), I get BOB4 to flash on the screen, but...nothing else! No startup screen or anything, just the view from my camera.

Did I receive a dead Dragon?
NickDV is offline Find More Posts by NickDV
Reply With Quote
Old Aug 17, 2008, 10:20 AM
FPV Desert Beta Test Center
Mesa, Arizona
Joined Nov 2006
2,451 Posts
Have you looked in the IF forum for information?

http://forum.intelligentflight.com/
Gary Evans is offline Find More Posts by Gary Evans
Reply With Quote
Old Aug 17, 2008, 11:13 AM
JettPilot's Avatar
Miami
Joined Apr 2005
10,875 Posts
Quote:
Originally Posted by NickDV
Did I receive a dead Dragon?
From what I understand, Mark peronally tests all the Dragons before they are shipped. I think chances of you receiving a dead dragon are almost nil. They are a bit complicated to hook up, I would check everything time and again before thinking it was a hardware error.

I had an external voltage regulator on my plane fail, and it overvoltaged my Dragon by a large amount, but the Dragon lived The dragon can tolerate some abuse and still be fine.

JettPilot
JettPilot is online now Find More Posts by JettPilot
Site Sponsor
Reply With Quote
Old Aug 17, 2008, 11:46 AM
Registered User
Mark Harris's Avatar
Perth, Western Australia
Joined Apr 2007
1,207 Posts
NickDV, please send me an email with your order number mark@intelligentflight.com
Mark Harris is offline Find More Posts by Mark Harris
Reply With Quote
Old Aug 17, 2008, 05:29 PM
Registered User
Joined Aug 2006
76 Posts
Mark, email sent

JettPilot - I've got the video, GPS, current sensor, and control channel hooked up correctly, and the Dragon powered off a regulated 6V (I've also tried a 2S lipo directly). Looking at a few other posts with similar problems, I'm thinking the firmware got left behind, so I've ordered a pickit2 programmer to try installing it.

Vaportech - sorry for hijacking your thread! Any luck with your GPS?
NickDV is offline Find More Posts by NickDV
Reply With Quote
Old Aug 17, 2008, 06:07 PM
I'm lost.. again..
Vaportech's Avatar
Pueblo West Colorado
Joined Jan 2008
71 Posts
Vaportech - sorry for hijacking your thread! Any luck with your GPS?[/QUOTE]

No problem Funny you should ask. I just found a pic from Daemon on the Dragon thread and he posted a good shot of the wires up close and after I matched my pinout to his, it worked great. Wish i would have been one of the lucky ones to get a cable longer then 1" and color leads..Oh well, all part of the experience. Good luck with getting your setup working and don't hesitate to ask if I can help in anyway.
Vaportech is offline Find More Posts by Vaportech
Reply With Quote
Old Aug 18, 2008, 01:22 AM
Registered User
JMSTECH's Avatar
Canada, BC, Duncan
Joined Dec 2006
3,621 Posts
Quote:
Originally Posted by NickDV
Well, you're having more luck than me!

I also finally wired up my Dragon this weekend. After correcting the video cable (the manual appears to describe the wiring incorrectly, at least with respect to the photo), I get BOB4 to flash on the screen, but...nothing else! No startup screen or anything, just the view from my camera.

Did I receive a dead Dragon?
No I think you simply have to reverse the outside wires of the three connected off BOB4 (the side 90 degree connecting terminals) Leave the center for it is ground.
JMSTECH is offline Find More Posts by JMSTECH
Reply With Quote
Old Aug 18, 2008, 02:56 AM
Registered User
Mark Harris's Avatar
Perth, Western Australia
Joined Apr 2007
1,207 Posts
Vaportech - as i've said before in the other thread, just email me your order ID and i'll send you a longer one.
Mark Harris is offline Find More Posts by Mark Harris
Reply With Quote
Old Aug 18, 2008, 11:58 AM
Registered User
Joined Aug 2006
76 Posts
Quote:
Originally Posted by JMSTECH
No I think you simply have to reverse the outside wires of the three connected off BOB4 (the side 90 degree connecting terminals) Leave the center for it is ground.
Yep, that's what I did in the end (it's a lot easier than rewiring everything ) and got to the point of seeing my camera feed, but no actual OSD data other than the BOB4 flash. A look at the Dragon thread confirmed that the photo of the video wiring in the manual was indeed inconsistent with the description (at least in terms of left and right). The lack of any OSD data makes me think that the firmware is sadly missing - I believe someone on the DragonOSD thread came to the same conclusion after experiencing the same problem.

Anyway, when my pickit2 arives, I'm hoping to see some more action from the Dragon Need to work on getting rid of the video noise from the ESC in the meantime...
NickDV is offline Find More Posts by NickDV
Last edited by NickDV; Aug 18, 2008 at 12:07 PM.
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Looking for data on 35hp Green engine Chevelle Scale Kit/Scratch Built 1 Jul 15, 2008 03:27 PM
Discussion Getting tired of waiting for DX6 Receivers to re-stock...!!! Kilo60 Radios 11 Mar 15, 2007 04:30 PM
New data on "other" J250 for EDF-50's meteor Electric Ducted Fan Jet Talk 0 Jul 28, 2003 09:39 PM
Looking for data on JR FM Rx IC thomasb Power Systems 0 Dec 05, 2001 07:06 PM