HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Apr 24, 2008, 09:14 PM
Registered User
ricoalonso's Avatar
USA, KS, Derby
Joined Mar 2003
1,475 Posts
Discussion
How to identify if it's an ESC or a Motor Problem?

I have a Jeti Spin-33 ESC with the 3300kV brushless motor setup for a Heli. At one time, everything worked fine. After 3 or 4 times spooling up/down, the motor just stopped turning. It will shake but not spool up.

After that, I cannot anymore hear the beeping sound when I turn the Power ON. Now, here's the thing...

When I tried connecting another motor to the Jeti Spin-33 ESC things work fine. So I thought it was the motor which is having problem. But then, when I tried connecting the original brushless motor to another ESC it also works. When I put them back together (Jeti Spin-33 and original brushless motor) then it doesn't work. Weird ... now, I just could not know which one is faulty. Any help/input/comment will be appreciated.

Thanks.
Rico.

P.s. I cross-posted this situation in the Heli (Dragonus) forum in case anyone had the kit experienced the same problem.
++++
ricoalonso is offline Find More Posts by ricoalonso
Reply With Quote
Sign up now
to remove ads between posts
Old Apr 24, 2008, 09:48 PM
Balsa Flies Better!
Stamford, CT
Joined Oct 2000
6,738 Posts
Hi Rico

I'm guessing here- but if the motor still works, odds are its fine. I'll bet that some of the chips on the ESC have fried- if you push it to its limits, you may be able to induce the behavior again.

Sam
Megowcoupe is online now Find More Posts by Megowcoupe
Reply With Quote
Old Apr 24, 2008, 09:55 PM
Registered User
ricoalonso's Avatar
USA, KS, Derby
Joined Mar 2003
1,475 Posts
Sam,
Thanks for sharing your analysis. Yes, that may be the case... I also realized that the other motors I tested with the Jeti SPIN-33 (and which worked) are with lower ampereage. So yes, maybe some parts in the ESC had fried and can't handle the heavier motor. I hope Hobby-Lobby will replace this under warranty. I only had this last Oct-2008 and not really flown with it yet, and the motor came with their kit.

Anyway, thanks for sharing.
Rico.
ricoalonso is offline Find More Posts by ricoalonso
Reply With Quote
Old Apr 25, 2008, 11:25 AM
Balsa Flies Better!
Stamford, CT
Joined Oct 2000
6,738 Posts
Hey Rico

Glad to help. Having just checked HLs site- sounds like they should.

Sam
Megowcoupe is online now Find More Posts by Megowcoupe
Reply With Quote
Old Apr 25, 2008, 11:34 AM
Registered User
ricoalonso's Avatar
USA, KS, Derby
Joined Mar 2003
1,475 Posts
Sam,
Yes... I was just on the phone with one of their personnel. He is sending me the replacement part (with free shipping) and I'll be sending the defective unit I have then, they will credit my account once they receive it. They really have a good warranty (2 years) for the Jeti ESC... I just did not pay attention of it when I placed my order. I guess I need to, this time

Thanks.
Rico
ricoalonso is offline Find More Posts by ricoalonso
Reply With Quote
Old Apr 25, 2008, 11:59 AM
homo ludens modellisticus
Ron van Sommeren's Avatar
The Netherlands, GE, Nijmegen
Joined Feb 2001
10,800 Posts
Have you tried another battery?

Prettig weekend Ron
Ron van Sommeren is offline Find More Posts by Ron van Sommeren
Reply With Quote
Old Apr 25, 2008, 12:19 PM
Registered User
ricoalonso's Avatar
USA, KS, Derby
Joined Mar 2003
1,475 Posts
Quote:
Originally Posted by Ron van Sommeren
Have you tried another battery?

Prettig weekend Ron
Hi Ron,
Yes tried different battery and did not help either. And, I'm now very sure that the motor is alright since it runs good using another ESC. Anyway, I'm packing the unit and sending it back to Hobby-Lobby. I already got a notification from their order department that the replacement part is being processed .

You all have a great weekend.

Rico.
ricoalonso is offline Find More Posts by ricoalonso
Reply With Quote
Old Apr 26, 2008, 12:50 AM
Registered User
Oregon
Joined Mar 2008
40 Posts
servos go wild when i turn on system???

Need to trouble shoot. Transmitter will not control servos they just go wild when I turn on the power? I am positive it is something simple . Any idea's?
rab_bit@msn.co is offline Find More Posts by rab_bit@msn.co
Reply With Quote
Old Apr 27, 2008, 08:32 PM
Balsa Flies Better!
Stamford, CT
Joined Oct 2000
6,738 Posts
Check your rx crystal.
Megowcoupe is online now Find More Posts by Megowcoupe
Reply With Quote
Old Apr 27, 2008, 08:38 PM
Registered User
ricoalonso's Avatar
USA, KS, Derby
Joined Mar 2003
1,475 Posts
Do you have a PCM capable Tx and/or Rx ? If so, check that Tx is set to what the Rx is capable of receiving... ie: PPM to PPM; PCM to PCM.

^R^
ricoalonso is offline Find More Posts by ricoalonso
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
How to tell if you're an electroplaneoholic. Chuck Electric Plane Talk 143 May 18, 2004 05:38 PM
esc or cd rom problem fourstarforty Power Systems 5 Apr 22, 2004 03:21 PM
Does an ESC need a motor? Kosh Electric Plane Talk 7 Oct 17, 2002 03:18 PM
How good is governer mode on an ESC? HankF Electric Heli Talk 12 Jan 24, 2002 06:49 PM
6/7-99 S+E ESC by Stefan V. ... problem.. Fire Fox Power Systems 4 Oct 07, 2001 12:16 PM