SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Mar 20, 2008, 04:54 PM
Registered User
Joined Jul 2006
16 Posts
Help!
Roto Start (Shaft start )wont Prime, Help Please

Ofna Ultra Lx buggy
Force .26

I can't get the bugger to prime. There is no prime pump on the fuel tank. I swear i checked all the tubing.

Previously, I just pulled the pullstart 2-3 times and it primed fine. I am new to the shaft start systems.
sneth is offline Find More Posts by sneth
Last edited by sneth; Mar 20, 2008 at 05:35 PM.
Reply With Quote
Sign up now
to remove ads between posts
Old Mar 20, 2008, 05:59 PM
Mad Mad World
madmax93's Avatar
Halifax, ma.
Joined Jan 2007
123 Posts
Try blowing thru the pressure line untill you see fuel hit the carb.
madmax93 is offline Find More Posts by madmax93
Reply With Quote
Old Apr 09, 2008, 01:43 AM
Registered User
Joined Apr 2008
9 Posts
ok

ok. try holding your finger over the exaust and turnin the shaft starter. that should work
ronnie696 is offline Find More Posts by ronnie696
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion i cant start my engine - noob help please monkeys_out Engines 12 Oct 28, 2006 09:35 PM
Question muliflex easy start cg? quick help please lowflyer101 Hitec/Multiplex USA 2 Dec 17, 2005 11:26 AM
ntc3 wont start help please shannonmcb Nitro and Glow Power Cars 3 Feb 23, 2005 06:54 AM
my stupid rx wont work help please new flyer Radios 29 Nov 19, 2004 02:41 AM
Help please, Eflite 370 BL, CC25, Tp1500hd2c chatters, no start Michael Bogh Power Systems 5 Oct 07, 2004 12:38 AM