HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Aug 20, 2007, 03:32 AM
TMD
Registered User
Christchurch NZ
Joined Jan 2005
16 Posts
Help!
TT01D suspension problem please help!

Hey guys

Got myself a TT01D that I've been learning to drift with and has had about 7-8 hours use. Now when I use the car it sinks down on its suspension but doesn't come back up , so i have practically no suspension or ground clearance.
It was fine when it was new sprang back up no problem when depressed, I cleaned the shocks and springs and that helped but not much.

So what caused this and how do i fix it?

Thanks
Toby
TMD is offline Find More Posts by TMD
Reply With Quote
Sign up now
to remove ads between posts
Old Aug 20, 2007, 01:56 PM
Registered User
Sir-Ipswich's Avatar
Joined Feb 2007
86 Posts
wow the exact thing happened to me but only on the front suspension, mine will go up if i push it up but if i push it down it stays down.

I have oil filled shocks and springs by the way, mabey i have not enough oil?
Sir-Ipswich is offline Find More Posts by Sir-Ipswich
Reply With Quote
Old Aug 20, 2007, 08:00 PM
Registered User
Joined May 2006
394 Posts
You probably got air in the shock oil..
I have a feeling you will need to rebuild and re-oil your shocks..
OR the Springs have slipped off their Holdings.
magnat is offline Find More Posts by magnat
Reply With Quote
Old Aug 20, 2007, 08:07 PM
Registered User
Nexzzt's Avatar
Australia, QLD, Kippa-Ring
Joined Apr 2005
810 Posts
I don't have a lot of exp with cars (I race RC bikes), but I found with my cars/bikes that the shocks never seal perfectly, and eventually oil leaked out, and therefore air got into the shock and caused the problem you described. When ever I have problems with shocks (and I haven't touched them for a while) I always rebuild them with fresh oil and seals (if required) and they bounce back to life (pun intended). When your rebuilding them, give them a good look ever and make sure the shaft is straight, the shock body isn't dented or other signs of damage. Also make sure nothing else is binding (like suspension arms) when you move each wheel through full travel of the suspension.
Nexzzt is offline Find More Posts by Nexzzt
Reply With Quote
Old Aug 21, 2007, 05:06 AM
TMD
Registered User
Christchurch NZ
Joined Jan 2005
16 Posts
Stripped shocks down and checked all the seals and put new oil in them, had to give the shafts a little wiggle, just needed 1 really small preload spacer and they are all good

Thanks
TMD is offline Find More Posts by TMD
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
xing charger problem - please help! wigham1 Power Systems 5 Jan 02, 2002 12:35 AM
Servo problem, please help... Vincent Power Systems 5 Dec 10, 2001 12:00 PM
ESC Problem, please help?? Vincent Power Systems 4 Dec 06, 2001 06:58 PM
Hornet assemble problem... please help! crazybear Electric Heli Talk 3 Nov 01, 2001 10:13 PM
RANGE PROBLEM...please HELP!!! tnsfrk Electric Plane Talk 5 Jul 24, 2001 10:46 PM