Espritmodel.com Telemetry Radio
Reply
Thread Tools
Old Sep 11, 2002, 10:24 PM
Rehab is for quitters
LuckyArmpit's Avatar
West Middlesex, PA, US
Joined Jun 2001
4,853 Posts
Weird ESC or TX problem

Put in a new GP Goldfire motor in a Battle Floyd. Hooked up a Dymond D35. Ran motor. Okay. Tried another battery, no throttle. Tried same batt in another plane. Runs fine. Okay...
Hooked up a Jeti 50 amper to the Goldfire. Throttle was horrible!
Put back in Dymond ESC. It ran fine! So, I'm thinking maybe my Flash TX has a problem with throttle control. Hooked up the Jeti to my geared 05 Dogfighter and throttle was there. All of these were run on a 555 and a Feather reciever with same results.
Its funny that the Jeti would not turn the motor as well as the Dymond did. And this was on 5 seperate battery packs. But the Jeti worked fine on the geared MAS 05 geared motor. Or maybe I breathed in too much solder fumes today!

Dave...
LuckyArmpit is offline Find More Posts by LuckyArmpit
Reply With Quote
Sign up now
to remove ads between posts
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
esc or battery problem?? american junior Electric Plane Talk 5 Aug 10, 2005 08:49 AM
ESC or Battery problem? quietflyer Power Systems 5 Jul 21, 2005 12:31 AM
ESC or Receiver Problem? eman2 Beginner Training Area (Aircraft-Electric) 4 Oct 15, 2004 08:25 AM
ESC or Motor Problem? martimer Electric Plane Talk 7 Oct 12, 2004 01:47 PM
Question GWS 100C ESC or transmitter problem Grejen Power Systems 2 Jan 22, 2004 03:12 PM