HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jan 09, 2013, 06:30 PM
Registered User
SJMarty's Avatar
United States, FL, Jacksonville
Joined Aug 2012
57 Posts
Time to put the keyboard down...
Quote:
Originally Posted by erdnuckel2 View Post
its written on the side ... the difference is that one has been discontinued ...
SJMarty is offline Find More Posts by SJMarty
Reply With Quote
Sign up now
to remove ads between posts
Old Jan 09, 2013, 08:30 PM
Registered User
SJMarty's Avatar
United States, FL, Jacksonville
Joined Aug 2012
57 Posts
Now I remember where I saw this...

http://www.ebay.com/itm/290758355984

http://www.ebay.com/itm/290767145155

I guess the EFLH1240 is discontinued but this vendor has both this one and the EFLH1240A. The "A" is about a buck more. Still wondering...

I do have two CX3s and just noticed a difference. The "cap" on the head of one is blue and the other is silver. Is that the mystery difference?
SJMarty is offline Find More Posts by SJMarty
Reply With Quote
Old Jan 09, 2013, 08:35 PM
It flies!!! ... so who cares ?
erdnuckel2's Avatar
Joined Mar 2009
10,061 Posts
Quote:
Originally Posted by SJMarty View Post
Now I remember where I saw this...

http://www.ebay.com/itm/290758355984

http://www.ebay.com/itm/290767145155

I guess the EFLH1240 is discontinued but this vendor has both this one and the EFLH1240A. The "A" is about a buck more. Still wondering...

I do have two CX3s and just noticed a difference. The "cap" on the head of one is blue and the other is silver. Is that the mystery difference?
maybe they just ran out of parts ...
erdnuckel2 is online now Find More Posts by erdnuckel2
RCG Plus Member
Latest blog entry: I "JUST" made a blog post ...
Reply With Quote
Old Jan 27, 2013, 10:04 AM
"whirlydude"
flyeraroo's Avatar
United States
Joined Sep 2008
1,513 Posts
Bump
flyeraroo is offline Find More Posts by flyeraroo
Reply With Quote
Old Jan 27, 2013, 11:23 PM
Registered User
JDMJim's Avatar
United States, IL, Joliet
Joined Jul 2011
2,149 Posts
Hey guys, I had my coax out Saturday flying figure 8's and I had the lower blade pins(plastic and cant think of the name) break off again resting in loss of swash plate control therefore crashing....I know I saw a better part and can't find them...also cost me a awash plate as well since the ball joints come off on impact....this happened to me a few times now. I should hang up the helo as much better with fixed wing stuff
JDMJim is offline Find More Posts by JDMJim
Reply With Quote
Old Jan 28, 2013, 07:48 AM
Registered User
kodak_jack's Avatar
Hilton (Rochester), NY
Joined Mar 2008
10,014 Posts
If you lost a swash, you might as well get a metal one to replace it as the plastic ones also have a habit of separating into two parts. Do you mean you lost the links between the swash and blades? Did you lose or break the balls off of the blades? I guess we can't help you unless you have a better description or can post a picture. Can you refer to the diagram that comes in the heli manual?
kodak_jack is offline Find More Posts by kodak_jack
Reply With Quote
Old Jan 28, 2013, 11:21 AM
Registered User
JDMJim's Avatar
United States, IL, Joliet
Joined Jul 2011
2,149 Posts
the ball links broke off the swash plate. I otherwise remained intact. Its the rotor head that keps breaking in flight....I found an aluminum one...
JDMJim is offline Find More Posts by JDMJim
Reply With Quote
Old Jan 28, 2013, 11:48 AM
"whirlydude"
flyeraroo's Avatar
United States
Joined Sep 2008
1,513 Posts
Quote:
Originally Posted by JDMJim View Post
the ball links broke off the swash plate. I otherwise remained intact. Its the rotor head that keps breaking in flight....I found an aluminum one...
Yeah, those blade pegs on the rotor heads break very easily. The aluminum rotor heads, and the unbreakable landing skids were the first upgrades I made. If the helicopter starts flying weird going in different directions, check the swashplate for separation. The stock swashplates have been know to separate from crashes and hard landings. Just squeeze it together, and you should be good to go. If it separates frequently add a little ca on the sides before squeezing it together, but be careful not to use too much in case it would spread to moving parts. If the ball joints broke off on the swashplate, I would replace the plastic swashplate with aluminum also. If it is just the links popping off, they can be replaced easily.
flyeraroo is offline Find More Posts by flyeraroo
Reply With Quote
Old Jan 28, 2013, 01:18 PM
Registered User
JDMJim's Avatar
United States, IL, Joliet
Joined Jul 2011
2,149 Posts
Yea, this one I have toilet bowls when hovering. But flus fairly well. I can do banking turns and such. But it's just th rotor head keeps breaking
JDMJim is offline Find More Posts by JDMJim
Reply With Quote
Old Jan 31, 2013, 07:38 AM
Registered User
kodak_jack's Avatar
Hilton (Rochester), NY
Joined Mar 2008
10,014 Posts
Whirly already started a new thread about this, but this was found on the mcx2 thread:

http://www.rcgroups.com/forums/showt...20881&page=179

It's completely new and of a larger size (300 vs the 180 of the CX2), so, it's a unique animal that would require you to buy all your parts from EFlite. It'll take a while before mod parts are available. The rotor diameter is supposedly 18" = HBFP size = 300. It has pivoting blades and 360/380 motors running on 3 cells.
kodak_jack is offline Find More Posts by kodak_jack
Reply With Quote
Old Jan 31, 2013, 12:59 PM
Controls Engineer
lasakro's Avatar
United States, NY, Amsterdam
Joined Dec 2012
1,331 Posts
Hi guys. It's my first time here on this thread and sorry for interrupting. I need some serious Coax help. I've got this CX2 and it's kicking my as@ big time.

The top wants to spin on take off (see video). Both shafts completely straight by sight while running and there are no vibrations. New swash and plastic lower head. Both upper and lower blades balance check good. Flybar not bent and also has good balance. Upper blades track good even though the linkage is adjusted to the shortest. No bar binding. No bearing slop. Shaft collar is snug so there is no axial shaft movement. Blade direction is correct, bottom CW and top CCW. I'm at a loss.

Ignore the reference to toilet bowl on the video.
Blade CX2 Toilet Bowl Lift Off (0 min 26 sec)
lasakro is offline Find More Posts by lasakro
Last edited by lasakro; Jan 31, 2013 at 01:04 PM.
Reply With Quote
Old Jan 31, 2013, 01:44 PM
"whirlydude"
flyeraroo's Avatar
United States
Joined Sep 2008
1,513 Posts
Quote:
Originally Posted by lasakro View Post
Hi guys. It's my first time here on this thread and sorry for interrupting. I need some serious Coax help. I've got this CX2 and it's kicking my as@ big time.

The top wants to spin on take off (see video). Both shafts completely straight by sight while running and there are no vibrations. New swash and plastic lower head. Both upper and lower blades balance check good. Flybar not bent and also has good balance. Upper blades track good even though the linkage is adjusted to the shortest. No bar binding. No bearing slop. Shaft collar is snug so there is no axial shaft movement. Blade direction is correct, bottom CW and top CCW. I'm at a loss.

Ignore the reference to toilet bowl on the video.
http://www.youtube.com/watch?v=40NNf...layer_embedded
I don't know if there is anything wrong with the helicopter, and you will be able to tell once you get it hovering. It's reacting that way, because your throttling up too slow. Throttle up quicker so the helicopter lifts off faster, and don't move the right stick of the transmitter. Throttle up until the helicopter is a couple feet off the floor, and it should sit and hover without input from the aileron, or elevator. Once it's hovering you will see if it drifts, which can be corrected by adjusting the servo pushrods.
flyeraroo is offline Find More Posts by flyeraroo
Reply With Quote
Old Jan 31, 2013, 02:03 PM
Controls Engineer
lasakro's Avatar
United States, NY, Amsterdam
Joined Dec 2012
1,331 Posts
Quote:
Originally Posted by flyeraroo View Post
I don't know if there is anything wrong with the helicopter, and you will be able to tell once you get it hovering. It's reacting that way, because your throttling up too slow. Throttle up quicker so the helicopter lifts off faster, and don't move the right stick of the transmitter. Throttle up until the helicopter is a couple feet off the floor, and it should sit and hover without input from the aileron, or elevator. Once it's hovering you will see if it drifts, which can be corrected by adjusting the servo pushrods.
If you watch the end you see what happens when I apply some power. The top spins out. I didn't want to do this because something would break. Something always breaks on these. Well you asked and yes I broke another blade.

Don't fall out of your chair

MVI 2804 (0 min 17 sec)


MVI 2805 (0 min 11 sec)
lasakro is offline Find More Posts by lasakro
Reply With Quote
Old Jan 31, 2013, 02:51 PM
Epilepsy Awareness
Chap1012's Avatar
United States, MA, Malden
Joined Mar 2008
11,864 Posts
"That" is pretty weird. Now I know what you meant on the other thread. Lets check the TX. All the trims should be centered EXCEPT the throttle trim. The throttle trim should be all the way down.

Mike.
Chap1012 is offline Find More Posts by Chap1012
Reply With Quote
Old Jan 31, 2013, 03:07 PM
Controls Engineer
lasakro's Avatar
United States, NY, Amsterdam
Joined Dec 2012
1,331 Posts
Quote:
Originally Posted by Chap1012 View Post
"That" is pretty weird. Now I know what you meant on the other thread. Lets check the TX. All the trims should be centered EXCEPT the throttle trim. The throttle trim should be all the way down.

Mike.
Tell me about it. Dude, I own 4 CP's and my latest sweety is the ALZRC Devil 480 Fast with a uBeast FBL. I can set up a CCPM in my sleep. It HAS TO BE something simple I'm missing and apriciate a fresh perspective. The tech at my LHS works there on Fridays so it's now big deal other than the embarrassment of going in there. I have the swash setup so there is no drifting until it starts it's ornery act. Tx E, A, & P centered. Opps- one to many there
lasakro is offline Find More Posts by lasakro
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion to buy or not to buy the blade cx2 airhead225 Coaxial Helicopters 36 Jul 10, 2009 12:01 AM
Discussion Blade CX2 Tx's - Can they be adapted to fly indoor/park flyers Sirion Electric Plane Talk 11 Apr 19, 2009 08:52 PM
Question How to program my dx7 to fly blade cx2? topforce Coaxial Helicopters 4 Sep 23, 2007 10:13 AM
Discussion How do I use my ICE to charge my batterys for blade CX2??? webejpn01 Electric Heli Talk 2 Jan 26, 2007 02:02 PM
Discussion How to learn to fly inverted with the Blade CP? Crazyrcer Micro Helis 4 Apr 05, 2006 01:59 PM