SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Aug 13, 2002, 09:28 AM
Registered User
Kings Park, New York, USA
Joined Sep 2001
813 Posts
Promax 4011 quits, anyone else have this?

I have a twin Promax 4011 stick direct with 4.7x4.7 Graupner Cam props and 10 RC2400s used on WagMax 2.

Last night out flying it climb was not great. Put it in glidermode for a while, aimed it towards the field and added power, spin right into ground?

No damage to airframe, stick needs a little fixing on.

What happened is the left motor quit. The main lead going into the end bell had all the strands broken about 1/8 inch outside of the case? It dosen't look like heat or over amps, looks almost like they were cut, but it was still inside the insulation? I do have shottky diodes soldered on about 3/8 of an inch from endbell. It did not break just at the solder joint, but between the bell and the shotky?

Anyone else have this happen? How did you resolve?

I was planning on trying to solder in some new castle Creation wire.

Thx.
Ron Parigoris
rparigoris is offline Find More Posts by rparigoris
Reply With Quote
Sign up now
to remove ads between posts
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Club politics, dose anyone else have this problem!? Thomas Manson Electric Plane Talk 80 Oct 17, 2014 01:03 PM
Does anyone else have this problem? tdriedger Electric Heli Talk 13 May 03, 2014 08:14 AM
Dymond in San Diego - Anyone else have this happen? Flying Low Vendor Talk 17 Sep 18, 2004 06:22 PM
Anyone else have this problem with a Kontronik FUN400-23? Neil Morse Power Systems 64 Feb 23, 2004 07:45 PM
Kokam Lipo-202 getting hot, anyone else have this problem? slammin Batteries and Chargers 0 Sep 16, 2003 11:24 AM