HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jul 11, 2006, 03:50 PM
Registered User
Flint's Avatar
Australia, ACT, Canberra
Joined May 2001
1,794 Posts
Quote:
Originally Posted by BulletMaster
I had a control rod that was only threaded one end. Also the same problem as Ozace with the ball links cracking (after trying to take off for adjustment).
Ditto, on the ball links, I have broken 4 now, 2 during the build and 2 during adjustments. No spares available yet. I hope Wattsuprc get a lot in!
Flint is offline Find More Posts by Flint
Reply With Quote
Sign up now
to remove ads between posts
Old Jul 11, 2006, 11:02 PM
sky is the limit
AeroSports's Avatar
NJ, US
Joined May 2002
116 Posts
I built and flown mine without any problem. it flies smooth and powerful.
AeroSports is offline Find More Posts by AeroSports
Reply With Quote
Old Jul 12, 2006, 10:16 AM
Registered User
Beaumont, Ca.
Joined Dec 2005
73 Posts
One wrong main shaft brg. three # 6800ZZ, in the kit, need #689ZZ, lower brg.
helicrazi is offline Find More Posts by helicrazi
Reply With Quote
Old Jul 14, 2006, 02:19 AM
Conformity Kill's
Mission Viejo, CA
Joined Nov 2005
2,796 Posts
more broken links

I had one link break on me, and I was missing one washer for the mixing arm. other than that smooth sailing. much better build than the 450XL IMO.

GW
geneween is offline Find More Posts by geneween
Reply With Quote
Old Jul 14, 2006, 04:21 AM
Registered User
northwood's Avatar
Harstad, Norway
Joined Aug 2005
123 Posts
I had no problems what so ever with my kit. No missing parts, brittle links and so on... I'm happy!
northwood is offline Find More Posts by northwood
Reply With Quote
Old Jul 14, 2006, 05:07 AM
Registered User
Joined Jun 2006
130 Posts
- Control Shaft H60023 also has the thinned part of it to fit the grub screw for the Elevator lever in the wrong spot (therefore elevator lever hits the main shaft).
The shaft needs to be flipped around!!!!!

im having the same problem Nick and i installed the shaft precisely as the instructions and Bob White demonstrates in his TREX 600 Build video

mine doesnt hit the main shaft but there is very little movement up and down before it does, once the linkages are on there will be even less, i guess i will have to dremmel a flat spot in a more appropriate spot

i will try spinning it the other way just to see if u are right and apologise accordingly if you are
nice heli dont get me wrong well done, now i just need to find someone that knows how to set up a gy611 as i sure dont
zx12rRed is offline Find More Posts by zx12rRed
Reply With Quote
Old Jul 14, 2006, 10:30 PM
Registered User
Joined Jun 2006
130 Posts
yep sorry nick i just pulled it all apart and tried it in both directions

and neither way clears the main shaft

the little indented bit on the shaft is in the wrong spot on my kit

so i just didnt use the little indented bit and moved it so the ball was vertical with the ball on the anti rotation device

definately something wrong
zx12rRed is offline Find More Posts by zx12rRed
Reply With Quote
Old Jul 15, 2006, 12:24 AM
Registered User
Lewis Center, OH
Joined Oct 2005
412 Posts
Any one else's control shaft have alot of side to side play? Mine has what seems to be a good 1-2mm of play if I move it side to side.
GoBucks is offline Find More Posts by GoBucks
Reply With Quote
Old Jul 15, 2006, 12:35 AM
Renewed interest
ozace's Avatar
Melbourne , Australia
Joined Jun 2002
8,950 Posts
Not here, mine all fitted really well, only ball link issues
ozace is offline Find More Posts by ozace
Reply With Quote
Old Jul 15, 2006, 02:22 AM
Conformity Kill's
Mission Viejo, CA
Joined Nov 2005
2,796 Posts
yup my control shaft moves side to side. I'm going to try to put some washers where the bearing hit to see f it helps.

geneween
geneween is offline Find More Posts by geneween
Reply With Quote
Old Jul 15, 2006, 03:29 AM
Chillaxin dude!
BulletMaster's Avatar
Newcastle, NSW, Australia
Joined Apr 2003
4,786 Posts
my control shaft is ok too.
BulletMaster is online now Find More Posts by BulletMaster
Reply With Quote
Old Jul 15, 2006, 04:50 AM
Registered User
Joined Jun 2006
130 Posts
2 batch's of control shafts, 1 good and 1 bad

my shaft has about 1 to 2mm of play as well, i assumed this was ok, now i assume its not, so im gonna have to fix it.

whats the best way ?
dremmel a few mm off one end ?
or look for some little washers ?
or demand a new shaft off align ?
zx12rRed is offline Find More Posts by zx12rRed
Reply With Quote
Old Jul 15, 2006, 04:43 PM
Renewed interest
ozace's Avatar
Melbourne , Australia
Joined Jun 2002
8,950 Posts
There seem to be more and more ball link issues popping up. It seems to be the most common problem reported so far.
ozace is offline Find More Posts by ozace
Reply With Quote
Old Jul 15, 2006, 09:44 PM
Registered User
Joined Jun 2006
130 Posts
for those of you haveing issues with the small amount of play on the shaft that holds the linkages to the swash, in my spares bag that came with the heli there was one washer that was the same as the ones that go on there

i used it and no more end play

have a look and see if you have any in your spares bag
zx12rRed is offline Find More Posts by zx12rRed
Reply With Quote
Old Jul 16, 2006, 08:25 AM
sky is the limit
AeroSports's Avatar
NJ, US
Joined May 2002
116 Posts
can someone show a picture of problem ball links?
AeroSports is offline Find More Posts by AeroSports
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Sold Almost New Align Trex 600 XL motor--65$ shipped Jag72 Aircraft - Electric - Power Systems (FS/W) 0 Jun 15, 2007 09:10 AM
Discussion Align Trex 600 metal head parts driving me crazy! kenmalecki Electric Heli Talk 12 Jun 05, 2007 12:09 AM
Discussion Align Trex 600 power options RC Man Electric Heli Talk 44 Aug 12, 2006 06:50 AM
Yippee! Align Trex 600 at modefo's heli!!!!!! prodigy Mini Helis 19 Jul 13, 2006 12:55 AM
Discussion Align TREX 600 mysn95 Electric Heli Talk 7 Mar 10, 2006 12:29 PM