HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Apr 19, 2006, 07:34 PM
Registered User
Joined Nov 2003
190 Posts
Help!
I just burnt my rc-expert 30A ESC

duhh.. yeah i did it

I feel so stupid..there's what happened and yo let me know where i went wrong

I just received to my 450TH motor. I also have a 1800 Mah 10C lipo and rc-expert 30A ESC

soldered on all connectors today and attached everything as directed, got my receiver hooked up, etc..

the esc manual says as follows:
---------------------------------------------------------------
brake (throttle stick at lowest position):
single high pitched noise: brake is on
double high pitched noise: brake if off

5-6 seconds wait.. then 4 high pitched

for timing:
throttle stick at highest position
wait 5-6 secs..4 high pitched noise
the 6 secs later, another 5 single high pitched noise from motor, at this point if throttle is moved to lowest position, soft-timing is on.
if there is no action after 5 single high pitched noise, another 5 double high pitched noises can be heard. move the thro. stick to lowest position then hard timing is ok.
soft timing: 2-6 pole motors
hard: 6 or more.

notes: use soft timing for first flight as hard timing can only be used if temp. or motor, ESC and batts are below 50 C (122 F)
--------------------------------------------------------------

now is had the motor fixed to the frame of my x400 but with no pinion. i connected everything while thro. stick at lowest position. 1 double pitched noise came out.. so i assumed brake is off. then a few secs later, 5 double pitched noises came out.. now thats not written in the manual..
i disconnected and connected again.. same thing.
I realised these is a switch connected to the esc, i thought it was for safety. the switch was in the OFF position during all these steps..

i reconnected again and flicked the switch.. moved throttle to highest position.. nothing happend except the motor clicked just once click. moved the throttle down then up again.. by imstake to maximum.. motor spun up as fast as it could.. i quickly spooled down again till it stopped.
so far so good.. now i moved the thro stick back up slowly.. motor started spinning only at around half throttle stick.. then pfffffttt.. smke came out of my esc.. i quickly disconnected the lipo.

guys.. sorry for the long thread.. but i really wanted to know what happened did i do anything wrong ?
should i contact rc-expert to send me a new ESC ? or was it totally my mistake ?

thanks, all help appreciated..
PS: can i use that esc again ? or is it toast ??
hpcre is offline Find More Posts by hpcre
Reply With Quote
Sign up now
to remove ads between posts
Old Apr 20, 2006, 12:49 AM
Registered User
Joined Nov 2003
190 Posts
bump... no one to help ?
hpcre is offline Find More Posts by hpcre
Reply With Quote
Old Apr 20, 2006, 01:04 AM
Registered User
Joined Sep 2005
1,102 Posts
awww sorry, call them see if you can return the esc... battery also not enought juice
lowflyer101 is offline Find More Posts by lowflyer101
Reply With Quote
Old Apr 20, 2006, 01:21 AM
Permanently Banned
kogibankole's Avatar
Albuquerque
Joined Nov 2004
1,188 Posts
i have been saying that rc expert is whack
kogibankole is offline Find More Posts by kogibankole
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Alert Just brought my first RC plane! Wind Spirit RC glider. ed_diaz Beginner Training Area (Aircraft-Electric) 64 Dec 29, 2008 11:18 PM
Toasted my 30A ESC fasttrip Electric Ducted Fan Jet Talk 4 Jun 17, 2005 06:44 PM
Just had my first ever RC filght (GWS P-51) savvy Foamies (Kits) 31 May 02, 2005 05:56 AM
FS- Last lot of equipment (trimming my RC for start of school)- Epp wing, esc, poly's Etonic Aircraft - Electric - Airplanes (FS/W) 9 Jul 26, 2003 03:56 PM
I just fried my new ESC rcnutt Power Systems 3 Jul 22, 2003 05:06 AM