HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old May 26, 2002, 12:29 PM
Borders, language & culture
AintQytRite's Avatar
United States, TN, Maryville
Joined Jun 2001
213 Posts
Speed control problem for wattage crazy max

I just put together a crazy max with a wattage 30 amp sc and the motor wont run. The servos work fine but the sc apparently isnt putting out any power to the motor. I have tried reversing the tx output for the throttle control. The sc just sets there light blinking rapidly and the directions dont say anything about that. HELP!
AintQytRite is online now Find More Posts by AintQytRite
Reply With Quote
Sign up now
to remove ads between posts
Old May 26, 2002, 12:51 PM
Making Cuisinarts Fly!!!!
Richardson, Texas
Joined Dec 2001
298 Posts
Try adjusting the trim and reversing the servo.

On my futaba TX I have to reverse the servo for My Hitec RX and sometimes pull the trim tab down to get it to arm.

Good luck!
RCAddict is offline Find More Posts by RCAddict
Reply With Quote
Old May 26, 2002, 01:08 PM
Registered User
Fountain Valley, CA USA
Joined Oct 2000
500 Posts
If your radio has throttle ATV, make sure they are turned up to maximum "travel".

It is an arming issue. Moving the trims/ATV/reversing to the correct position to match the ESC should solve the problem.

If it doesn't, call me Tuesday at work and I'll help you with it.

-Mike
Mike Greenshields is offline Find More Posts by Mike Greenshields
Reply With Quote
Old May 26, 2002, 01:09 PM
Registered User
Fountain Valley, CA USA
Joined Oct 2000
500 Posts
Ooops,

Work phone:
714 964 0827 ext 308

-Mike
Mike Greenshields is offline Find More Posts by Mike Greenshields
Reply With Quote
Old May 26, 2002, 01:11 PM
Crash Site Instigator
sheerLuck's Avatar
Novato, CA USA
Joined Jan 2002
917 Posts
Had the same problem initially using a Pixie 20 ESC. Fussed around with it & it started working - not sure what fixed it. However, I have to have the throttle trim all the way down for it to run, and the travel between off and full throttle is only about half the stick travel. This doesn't seem optimum, but as long as it flies....
sheerLuck is offline Find More Posts by sheerLuck
Reply With Quote
Old May 27, 2002, 11:53 AM
Borders, language & culture
AintQytRite's Avatar
United States, TN, Maryville
Joined Jun 2001
213 Posts
Found out what the problem was......................I had the esc plugged into the battery channel so the servos worked but reversing the throttle channel did nothing! Plugged the esc into the throttle channel on my JR 8103 and now it flies great! a blast but the kit was minus one pushrod so my rudder got taped strait for now cant wait to get a pushrod and had rudder also!
AintQytRite is online now Find More Posts by AintQytRite
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
WTT: GWS Beaver for Wattage Crazy Max mkirsch1 Aircraft - Electric - Airplanes (FS/W) 7 Aug 01, 2002 11:20 AM
Cool Wattage Crazy Max fly4fun Parkflyers 1 Jan 31, 2002 06:03 PM
Wattage Crazy Max 3D PunkerTFC Electric Plane Talk 20 Jan 29, 2002 05:44 PM
WattAge Crazy Max 3D Gene Bond Parkflyers 31 Dec 18, 2001 11:57 AM
Is this a speed control problem??? jshelton Power Systems 3 Dec 10, 2001 06:31 AM