HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Nov 13, 2005, 01:14 PM
Registered User
rgoble's Avatar
Dayton Montgomery, Ohio, United States
Joined Sep 2004
258 Posts
Need help with electrions for a buggie

I was give this Team Associated Buggie about 10-15 years ago so all of the electrions in it is very old and may not work. I have not touched the car since it was given to me but I would like to try and get it up and running. So if you have any suggestions on what battiers/esc/motor i should get please let me know.

http://www.rcgroups.com/gallery/show...cat=500&page=1

I fly RC planes but do not have much experience with cars. Also I could use some of my plane gear if it would work.

Thanks for the help,
Robert
rgoble is offline Find More Posts by rgoble
Reply With Quote
Sign up now
to remove ads between posts
Old Nov 14, 2005, 02:25 PM
Registered User
United States
Joined Dec 2004
1,892 Posts
wow. that is some pretty old stuff. does the original electronics still work? i'd get a 7.2 volt battery pack, a cheap esc and a 19-turn motor for it. u should be looking for an esc that can handle the motor limit (like 19 turn, for example). do u have a radio system? if not, then get a pistol radio.
TueLe is online now Find More Posts by TueLe
Reply With Quote
Old Nov 14, 2005, 03:11 PM
Registered User
rgoble's Avatar
Dayton Montgomery, Ohio, United States
Joined Sep 2004
258 Posts
Well I did some testing with some of the radio gear from my plane. The servos/motor still works but the mechanical speed controler is shot. I do have a 2 channel radio for it but either that or the rx is shot. I do not have any other 27mhz Rx or Tx so I have no way of testing to see which it is.

The tires spin right off the rems so I might have to glue them down.
rgoble is offline Find More Posts by rgoble
Reply With Quote
Old Nov 14, 2005, 05:49 PM
Registered User
United States
Joined Dec 2004
1,892 Posts
Quote:
Originally Posted by rgoble
Well I did some testing with some of the radio gear from my plane. The servos/motor still works but the mechanical speed controler is shot. I do have a 2 channel radio for it but either that or the rx is shot. I do not have any other 27mhz Rx or Tx so I have no way of testing to see which it is.

The tires spin right off the rems so I might have to glue them down.

ok, what u need is an esc and maybe a new motor if yours isnt in good shape. u can take the radio system to a hobby shop and see what's wrong. if its unfixable then u may have to get a new one.
TueLe is online now Find More Posts by TueLe
Reply With Quote
Old Nov 19, 2005, 01:15 AM
Registered User
rgoble's Avatar
Dayton Montgomery, Ohio, United States
Joined Sep 2004
258 Posts
Ok I got a mechanicle ESC and it seems to be working fine so far. I got my radio checked out, it runs out the throttle works fine but the steering is broken. When you move the wheel the servo will jitter but not move like it should. I took the radio apart because they guy at the LHS thought the pot might just be loose and could be fixed easily. Well once I had it apart it didnít look like he explained it. So if you know anything about fixing radios please check my other post here and let me know.


http://www.rcgroups.com/forums/showthread.php?t=442883
rgoble is offline Find More Posts by rgoble
Reply With Quote
Old Nov 19, 2005, 12:20 PM
Registered User
United States
Joined Dec 2004
1,892 Posts
did u notice any loose part or obvious damage on your radio when u took it apart? im no expert, but my guess is that the problem is not the radio, but the servo. a servo doesn't last forever, and when the motor in there is worn out, u will experience some glitches and jittering like u described. get a new servo, and test it out. if the problem persists then u can eliminate the servo as one of the causes.
btw, if u're still using a mechanical speed control, get a new electronic speed control, also known as an ESC. it's maintanence-free and gives u longer runtime.
TueLe is online now Find More Posts by TueLe
Reply With Quote
Old Nov 19, 2005, 08:41 PM
Registered User
rgoble's Avatar
Dayton Montgomery, Ohio, United States
Joined Sep 2004
258 Posts
Its not the servo, i used 2 of the 4 that came brand new with my JR6102 radio I got for my planes. The throttle servo works fine but the steering does not, if i swap the servos the same thing happens again on the steering channel. That elimates it from being a servo problem. When I took it to the LHS they tested my radio with a brand new receiver and it did exactly the same thing on the new reciver. I did not see anything that was loose and once I reassembled it the steering channel stop working completly. I am going to take it back apart and check the signals to make sure all the wires are connected.

I puraches a new mechanical speed controler because it was 12$ instead of 40$ for a new ESC. I am mainly into flying but started trying to fix this to see if racing is something I would enjoy as well. So I am trying to get it running for as cheap as possible for now. Besides if i do enjoy it and I find people in my area that still race them I will most likely try and get a brushless for it, which means a different ESC anyways.

Thanks,
Robert
rgoble is offline Find More Posts by rgoble
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Need help with prop for WindDancer yaha-tinda Electric Sailplanes 7 May 29, 2006 12:56 PM
Question Need help with servos for DragonFly malor Micro Helis 2 May 17, 2004 11:58 PM
need help with a towhook for zagi AzJason Foamies (Kits) 6 May 17, 2004 09:21 PM
Need help with parts for TM tenover Parkflyers 27 Feb 17, 2003 07:17 PM
Need help with 400 for park flyer Cpietro Electric Plane Talk 2 May 21, 2001 01:35 AM