SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Jul 20, 2005, 09:41 AM
Heli Headcase
Orion_V's Avatar
Cliffside Park, NJ
Joined May 2003
2,551 Posts
Slipping Hyper drive

I've been flying with Matt's hyper drive for quite some time. Probably my favorite mod for the Corona. After installing it at first (last year) it was running great at my adjusted tension which I've always had pretty tight. However, it seems now that no matter how tight I make it it slips at full power. I have the tension VERY tight...and it slips when I apply quick full bursts of throttle. This has caused me to crash a few times b/c the belt just slipped after trying to get out of trouble(no worries though b/c my BT Corona almost never breaks).

Perhaps my belt is a little worn from constant high tension operation? I inspected it and it seems to be fine. I'm afraid if I try to make it tighter it's going to bend the motor shaft on my Hacker.

The other thing it may be is perhaps the Hyper drive gear is slipping around my Titanium shaft, but I have it screwed on pretty tight...and I can't seem to do it by hand.

The sound it makes when it slips is hard to explain. Sounds like a stripped pinion gear trying to turn a main gear..if that makes any sense.

How tight do all of you have Hyper Drive owners have your tension? Any ideas on what I can do to get rid of this slippage? Thanks for reading!!
Orion_V is offline Find More Posts by Orion_V
Reply With Quote
Sign up now
to remove ads between posts
Old Jul 20, 2005, 10:58 AM
luc
I plant balsa sticks too
luc's Avatar
France
Joined Feb 2000
3,585 Posts
I did a flat spot on my mega axle as well as on the titanium shaft and I used a bigger screw (bigger alien head screw) which avoids the slipping of the pinion.
Yes it has to be pretty tight, but there is no slippage for me.
luc is offline Find More Posts by luc
Reply With Quote
Old Jul 20, 2005, 11:42 AM
Heli Headcase
Orion_V's Avatar
Cliffside Park, NJ
Joined May 2003
2,551 Posts
well I got the flat on my Hacker motor shaft, and I'm pretty sure I have one on the main shaft...guess I'll try and tighten up the set screws and see if I can get the belt a little tighter.
Orion_V is offline Find More Posts by Orion_V
Reply With Quote
Old Jul 20, 2005, 12:50 PM
luc
I plant balsa sticks too
luc's Avatar
France
Joined Feb 2000
3,585 Posts
I don't think there is any flat "from factory" on the titanium shaft, unless you did one.
luc is offline Find More Posts by luc
Reply With Quote
Old Jul 20, 2005, 12:50 PM
Registered User
USA, NY, Jamestown
Joined Jun 2000
2,910 Posts
Are you sure it is the hyper drive? I have gotten that sound with worn input gears on the stock tail drive. Or do you have a belt drive tail also?
JoeR is online now Find More Posts by JoeR
Reply With Quote
Old Jul 20, 2005, 12:56 PM
Heli Headcase
Orion_V's Avatar
Cliffside Park, NJ
Joined May 2003
2,551 Posts
yeah have the belt drive as well...

i'll double check on the flat on my 5mm titanium shaft..it's been a while since I removed the main drive gear. From what i remember there was..but I could be wrong.

If there isn't is there an easy way to apply a flat on it using a dremel?
Orion_V is offline Find More Posts by Orion_V
Reply With Quote
Old Jul 20, 2005, 01:07 PM
luc
I plant balsa sticks too
luc's Avatar
France
Joined Feb 2000
3,585 Posts
ahhh..I have the 7mm shaft, not sure about the 5mm..

titanium is rather soft and ez to work with, in any case
luc is offline Find More Posts by luc
Reply With Quote
Old Jul 20, 2005, 03:56 PM
Registered User
Cape Town, South Africa
Joined Jan 2005
5,157 Posts
My 7mm Ti shaft came with a flat.
aragon is offline Find More Posts by aragon
Reply With Quote
Old Jul 20, 2005, 06:13 PM
Professional Tinkerer
rickyblaze's Avatar
Bloomington Monroe Cty, Indiana, United States
Joined Jul 2003
1,285 Posts
I've heard the stripping sound before on mine but could'nt tell if it was the elevated tail or the hyperdrive. seems it would mostly do it with lipo batteries. I suspected the tail was skipping because I have it a little loose to keep it from pulling the fin over from over tightening the belt. I have the flat spots everywhere there's a pulley tightened to a shaft,common practice after having troubles with a tail shaft

Rick
rickyblaze is offline Find More Posts by rickyblaze
Reply With Quote
Old Jul 20, 2005, 06:15 PM
Professional Tinkerer
rickyblaze's Avatar
Bloomington Monroe Cty, Indiana, United States
Joined Jul 2003
1,285 Posts
I think a spring loaded idler would come in real handy for these type of problems
rickyblaze is offline Find More Posts by rickyblaze
Reply With Quote
Old Jul 20, 2005, 06:52 PM
---------Speed!!---------
Illinois
Joined Jul 2003
6,134 Posts
Hmm, I guess the belt could be worn. All my shafts have flat spots (now). They 5mm shaft used to not have one for those who wanted to use a oneway. But, all shafts for the last 8 months or so come with a flat for the set screw.

Hmm, could your head be slipping around the shaft?

Oh, also, I do not run my Hyper Drive belt very tight. It is snug, but not tight. I have found that if you make it too tight, the motor mount and the main shaft will flex a tad. That will screw up the pulley alignment and only allow a portion of the belt to be snug and the rest of the belt to be slack. Kind of hard to explain.

Matt.........
Heli Mod Man is offline Find More Posts by Heli Mod Man
Reply With Quote
Old Jul 21, 2005, 04:02 PM
Heli Headcase
Orion_V's Avatar
Cliffside Park, NJ
Joined May 2003
2,551 Posts
Don't think my head is slipping around the shaft....the sound seems like its coming directly from the hyper drive...i'm gonna take another look at it on Saturday and will report back...I'll go ahead and add a belt to my landing skid order i'm going to place soon...see if that will help...
Orion_V is offline Find More Posts by Orion_V
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
GWS Hyper Drive Prop Testing Dave Hederich Power Systems 157 Feb 21, 2005 12:36 PM
Adapters for GWS Hyper Drive Props Dave Hederich Power Systems 14 Jul 23, 2003 05:00 PM
Which hyper drive prop for stock GWS 300C and P-51? Mikey-flies Power Systems 1 Jul 10, 2003 10:13 AM
Hyper drive props, where? ryanl2006 Parkflyers 7 Jun 17, 2003 11:54 PM
WTB: GWS 10x6 Hyper Drive props (2) ElectriFan Aircraft - Electric - Airplanes (FS/W) 0 Jun 02, 2003 10:07 PM