HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jul 07, 2005, 07:22 AM
Registered User
mhackney's Avatar
MA - close to Boston
Joined Apr 2003
111 Posts
Slow Stick: not enough power with Futaba 9H radio

Hello all, I've been flying micro electric helis for about a year with a Futaba 9H radio. I recently assembled a SS to teach my son to fly planes. We tried to maiden the other night but the plane literally did not have enough power to get off the ground! We have the eps-300 and I was running 2cell LiPo (1200 mAh batteries (tried 2 packs). Running GWS receiver (6 ch pico), servos and a GWS 100 speed controller.

I suspect this is a radio programming issue since I have not really had to touch the radio program for a year. I did notice that I have the program set for a heli rather than acro. I have a tach but have not had the time to check the prop rpm yet. I hope to do that tonight along with reprogram the xmitter.

Does this make sense or is there something else I should look in to?

thanks in advance!
Michael
mhackney is offline Find More Posts by mhackney
Reply With Quote
Sign up now
to remove ads between posts
Old Jul 07, 2005, 09:50 AM
Registered Disabuser
Wertygrog's Avatar
Norfolk, Massachussetts
Joined Jul 2003
738 Posts
The only thing i can think of the usually grounds slow sticks is maybe the prop is on backwards? The lettering should be facing out.....those lipolys should make it fly no prob. ???


hey where's groton? I live south of boston near RI
Wertygrog is offline Find More Posts by Wertygrog
Reply With Quote
Old Jul 07, 2005, 09:58 AM
Registered User
Joined Oct 2004
211 Posts
Ya with lipos you should be able to lose the SS in 20 seconds. An unscientific way to check the motor: when its full throttle is sounds like a house fan on high . I have the SS with a 300 and a 750 nimh and she rotates in less than 10 feet.
abev107 is offline Find More Posts by abev107
Reply With Quote
Old Jul 07, 2005, 10:38 AM
Registered User
Jason Paul's Avatar
Joined Mar 2005
565 Posts
Actually, I would think that a 2-cell lipo pack would leave the SS a little underpowered, but it should still probably lift off.

Check to make sure the prop is on correctly. The numbers should be facing forward. I think almost everyone has put one on backwards at least once.

Also, the speed controller is a bit small too.

As far as the radio being the problem, I have no idea there.

Jason
Jason Paul is offline Find More Posts by Jason Paul
Reply With Quote
Old Jul 07, 2005, 04:35 PM
Oldie but goodie
Popsflyer's Avatar
United States, CA, Orange
Joined Jun 2003
3,890 Posts
1) Prop on backwards?

2) Radio set-up for Heli and governor mode? Governor mode use is common with electric heli's and will limit the maximum power (rpm) in an airplane.

3) The 300/350 version of the S.S. should fly fine on a 2S LiPo pack as fully charged voltage is about the same as a 7 cell NiCd pack. The 400 version would definately be underpowered on 2S and is great on 3S.
Popsflyer is offline Find More Posts by Popsflyer
Reply With Quote
Old Jul 07, 2005, 04:36 PM
Registered User
crashingagain's Avatar
Sacramento
Joined Nov 2003
964 Posts
If your radio is in heli mode your settings might keep full throttle from being reached
crashingagain is offline Find More Posts by crashingagain
Reply With Quote
Old Jul 07, 2005, 04:52 PM
....PieMaster....
kave_man's Avatar
United States, GA, Warner Robins
Joined Aug 2004
695 Posts
the 2 cell lipo is fine for the ss. i have had one for 9 months.

300d with 12x6 prop
2 cell kokam 1500 ma
kave_man is offline Find More Posts by kave_man
Reply With Quote
Old Jul 07, 2005, 07:11 PM
Registered User
mhackney's Avatar
MA - close to Boston
Joined Apr 2003
111 Posts
Thanks all. Came home and took a look at the prop - it was on correctly. When I programmed the model on the 9H it defaulted to a heli. I tached the prop at 2620rpm at full throttle. I then reprogrammed the model as a plane (acro on the Futaba). Now I am getting 3460rpm and I did not hold at full throttle very long to get a stable reading since I was alone and the SS was trying to pull out of my hand. Wouldn't you know it, I started for the field next door and it started to pour!

Good news is, I came in and replaced all of that GWS tape with some good fiber reinforced tape on the control surfaces. The old stuff was pealing off. This new stuff looks like it will stay on.

Cheers and thanks,
Michael
mhackney is offline Find More Posts by mhackney
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Sold slow stick GWS EM400 power system with extra props 300Spartans Aircraft - Electric - Power Systems (FS/W) 2 Jul 16, 2007 11:46 AM
Slow Stick: Not everyone is happy with it markusj Beginner Training Area (Aircraft-Electric) 57 Oct 09, 2005 09:28 AM
Not enough power with 2cell Lipo and like90's skateboardjunky Micro Helis 13 May 13, 2005 04:39 PM
Twin Dimwatt--8 cells not enough power? Please help!! totalboss Electric Plane Talk 5 Oct 22, 2001 09:35 AM
Not enough Power form Battery Snow Bird PA-FL Power Systems 2 Sep 21, 2001 03:14 PM