HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jul 01, 2005, 08:05 AM
clh
Registered User
Joined Jul 2005
2 Posts
Help!
Help needed with a smoked Hyperion emeter

I accidentally reversed polarity on the shunt with the result of a burned component inside the emeter. Is there anyone who recognize what kind of component it is (se attached picture). Please help, I just bought it a few days ago.
clh is offline Find More Posts by clh
Reply With Quote
Sign up now
to remove ads between posts
Old Jul 01, 2005, 08:38 AM
Registered User
meteor's Avatar
Ontario, Canada
Joined Nov 2002
1,568 Posts
Bummer!

It may be some sort of diode to protect the batteries in case of reverse-voltage, but if it was it didn't work!

You'd think that they'd try to protect against reverse-voltage a bit better, it doesn't make sense...


edit: It looks like this component goes directly to the shunt connection. Does the eMeter still power-up?

Once you remove the device, check to see if there's voltage across the pads, that way you'll know it was part of the on-board power circuitry.
meteor is offline Find More Posts by meteor
Last edited by meteor; Jul 01, 2005 at 08:52 AM. Reason: addition...
Reply With Quote
Old Jul 01, 2005, 10:40 AM
clh
Registered User
Joined Jul 2005
2 Posts
It's alive?

The emeter is surprisingly working and identifying the shunt correctly but Iím not so sure about the readings on the MOTOR page when I test it. After taking a closer look where the component goes, it seams like it does go directly to the shunt (positive connector) and to RS+ on a MAX4081 which have something to do with the battery charger accordingly to this web page http://www.maxim-ic.com/view_press_release.cfm/release_id/706.

data sheet MAX4081
http://pdfserv.maxim-ic.com/en/ds/MAX4080-MAX4081.pdf
clh is offline Find More Posts by clh
Reply With Quote
Old Jun 12, 2007, 09:48 AM
Pesky Landings!
bigandy's Avatar
Abergele, North Wales, UK
Joined Apr 2004
1,112 Posts
draggng this thread up from the depths, I've done exactly the same thing. I plugged the battery into the load side (i was using adpaters for Deans Micro conenctors at the time) and on opening the case, the exact same component has a burn mark on it.

Did you manage to get it mended? Did you just replace the diode? If so, what type/value etc, and did the Emeter work properly again afterwards?

Cheers
Andy
bigandy is offline Find More Posts by bigandy
Reply With Quote
Old Jan 28, 2008, 05:43 PM
Registered User
bsoder's Avatar
Mesa, AZ
Joined Aug 2004
1,848 Posts
My turn... did the same damn stupid thing today. Looks like it reads voltage correctly but not current?
bsoder is offline Find More Posts by bsoder
Reply With Quote
Old Jan 28, 2008, 07:59 PM
Registered User
California
Joined Apr 2006
1,247 Posts
bigandy was correct. It look like the device burned is a diode. Possiblly a schottky diode. Either way, you could replace that with schottky diode with the largest rating you can find. If you can still make out the printing on the diode, try to figure out which side has the white line.

Brian
asm_ is offline Find More Posts by asm_
Reply With Quote
Old Jan 28, 2008, 08:36 PM
Registered User
bsoder's Avatar
Mesa, AZ
Joined Aug 2004
1,848 Posts
I remembered this evening that when I was helping my father get set up I made sure he bought an emeter as well. he's sending it to me, should have it in a day or two, I hopefully can figure out the details on the burned component. i'll post what I find.
bsoder is offline Find More Posts by bsoder
Reply With Quote
Old Jan 28, 2008, 11:24 PM
Registered User
California
Joined Apr 2006
1,247 Posts
Where are you gettin a emeter? I have been looking for one too.
asm_ is offline Find More Posts by asm_
Reply With Quote
Old Jan 28, 2008, 11:40 PM
Registered User
bsoder's Avatar
Mesa, AZ
Joined Aug 2004
1,848 Posts
he bought it about a year ago. far as I know there are none out there to buy new.

I want an Emeter2, damnit!
bsoder is offline Find More Posts by bsoder
Reply With Quote
Old Feb 04, 2008, 04:38 PM
Registered User
bsoder's Avatar
Mesa, AZ
Joined Aug 2004
1,848 Posts
update - I got my dad's Emeter today (delay on the shipping end )

The component is all black, with VERY faint lettering on it - "P2U"

using my multimeter, it shows a voltage of .615V with the negative lead on the battery side (bottom side, closer to batteries), so it's not a schottky, if I remember my electronics classes from long ago isn't that about right for a regular diode?
bsoder is offline Find More Posts by bsoder
Reply With Quote
Old Feb 04, 2008, 10:24 PM
Registered User
California
Joined Apr 2006
1,247 Posts
You are right, it's a regular diode. Have you check diode with the test lead in reverse? It should not conduct at all.
asm_ is offline Find More Posts by asm_
Reply With Quote
Old Feb 05, 2008, 08:25 AM
Registered User
bsoder's Avatar
Mesa, AZ
Joined Aug 2004
1,848 Posts
yep. 0.0 backwards.
bsoder is offline Find More Posts by bsoder
Reply With Quote
Old Feb 05, 2008, 09:40 AM
Frankenstein recycled packs
rampman's Avatar
USA, AZ, Gilbert
Joined Jan 2006
8,757 Posts
bsoder - do you need a surface mount diode? I can part with a couple if needed, just pay $0.50 for stamp/envelope. Otherwise you can use a through-hole type diode and bend the leads to fit.

Rick
rampman is offline Find More Posts by rampman
Reply With Quote
Old Feb 05, 2008, 10:13 AM
Registered User
bsoder's Avatar
Mesa, AZ
Joined Aug 2004
1,848 Posts
a regular through-hole type will fit fine, there's plenty of room. Any idea if what particular diode I use matters, as long as it's a regular silicon diode? ie. 4003/4004, whatever?
bsoder is offline Find More Posts by bsoder
Reply With Quote
Old Feb 05, 2008, 03:52 PM
Registered User
California
Joined Apr 2006
1,247 Posts
Based on the voltage mesured, you should be fine with a regular silicon diode. Just be sure to get one with high enough amp rating. Of course, you gonna have to guess for that one.
asm_ is offline Find More Posts by asm_
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help needed with a plan... Please ! NetForce2K Parkflyers 1 Jun 04, 2002 11:59 AM
Help needed with biplane dimensions Rekit Power Systems 2 Apr 11, 2002 10:22 PM
Hornet Help Needed With Ccpm Mixing JUSTGLUEIT Electric Heli Talk 3 Apr 09, 2002 07:55 PM
Quick help needed with HF9, GWS gyro on the Housefly ruf Electric Heli Talk 1 Feb 01, 2002 09:47 PM
Picalo help needed with triming...I think mrtim Electric Heli Talk 1 Sep 08, 2001 01:49 AM