HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jun 26, 2005, 09:01 AM
Joe G
Joined Jun 2005
3 Posts
Electric Motor Throttle Problem

Hello,

I'm teaching my nephew to fly RC; my Dad got him a Megatech Freedom Flyer RC for Christmas. Since I'm the pilot in the family, I'm elected to train the new flyer

BTW, that is one crash-resistant plane.

Here's the problem. We put the plane away for a couple of months until we could find a better flying field. I followed all the instructions as far as the battery/electric motor before storing it.

Yesterday we did the recharge and I briefly tested the controls and throttle and all seemed well. We then left for the field to fly.

Problem is when I go to full throttle, the engine just dies out. We tried everything, cycling the system, reconnecting the wires, etc but nothing worked. If I pulled the throttle trim switch on the transmitter down to the lowest setting, I can get about 50% power.

But moving the trim control back to dead center and the engine stops when the throttle is advanced to full.

I thought maybe someone had played with the servo switches (we had a problem with the transmitter when we first got it where all the controls were reversed, even though the manual said the controls were correct - I reversed the control switch and all the controls worked normally afterwards - including the throttle.)

I'm stumped. I took the plane home and charged it again - this time for a longer period of time. Just checked it this morning and the motor still dies.

I know the batteries are good - all the lights indicate good on the transmitter and the engine can run 15 minutes at half speed. I think it's related to the setup or wiring or even the engine. It's crashed a lot of times.

The radio is a PF4000 4 channel model on 27MHz. 3 channels are used (the right stick is for rudder and elevator, the left only for throttle.

Any thoughts would be greatly appreciated.

Joe G
joeg123 is offline Find More Posts by joeg123
Reply With Quote
Sign up now
to remove ads between posts
Old Jun 26, 2005, 09:22 AM
Registered User
LesUyeda's Avatar
San Diego, California
Joined Dec 2004
3,454 Posts
For whatever reason, the battery pack is no longer able to deliver the current required at full throttle, and is dropping the voltage to below the BEC threshold.

Les
LesUyeda is offline Find More Posts by LesUyeda
Reply With Quote
Old Jun 26, 2005, 09:26 AM
Joe G
Joined Jun 2005
3 Posts
battery pack issue

the package was purchased 6 months ago so I can call the factory. it just seems strange that it worked great before and now it doesn't. nothing else on the radio or servos that I should check? thanks.
joeg123 is offline Find More Posts by joeg123
Reply With Quote
Old Jun 26, 2005, 09:50 AM
Southern Pride
everydayflyer's Avatar
Haralson County GA. USA
Joined Oct 2004
34,758 Posts
Sure sounds like LVC (low voltage cutoff) is being hit just like other responce mentioned. Well LVC not BEC (Battery Elimination Circuite) which supplies power to receiver and servos from motor battery.

If the battery is NiMH cells they do not like to be stored discharged. They have a high self discharge rate anyway. If the were stored discharged for two months they they really should have been slow charged at C/10 when put back in service which may have helped them.
If you have a DVM you could check the battery voltage under load and see what voltage the motor is cutting out at.

According to imformation here cells are NiMH however another site listed as NiCads.
http://www.zearth.com/ProductDetails...oductCode=3371

Charles
everydayflyer is online now Find More Posts by everydayflyer
Last edited by everydayflyer; Jun 26, 2005 at 09:57 AM.
Reply With Quote
Old Jun 26, 2005, 10:05 AM
Joe G
Joined Jun 2005
3 Posts
battery charge

I want to add some more information.

If I hold down the start switch, with the radio trim for the throttle set to midway the engine runs well but as soon as I let go of the switch it runs for a second or two and then cuts off.

I was wondering if during one of the crashes, maybe there is a adjustment on the motor or servo for the cutoff point?

Joe G
joeg123 is offline Find More Posts by joeg123
Reply With Quote
Old Jun 26, 2005, 11:26 AM
Space Coast USA
hoppy's Avatar
Space Coast
Joined Oct 2000
20,944 Posts
My bet is a sick battery....
Call the factory - hopefully they will replace it.....
hoppy is offline Find More Posts by hoppy
Reply With Quote
Old Jul 03, 2005, 07:55 PM
Registered User
Joined Mar 2005
15 Posts
I have a Freedom Flyer as well and after a number of crashes early on the battery was shot. I didn't realize it until I happened to try the battery from the F-27 Stryker that I purchased more recently and found it to provide much more power. My vote is a new battery. You can get 2 decent ones for $20 at www.batteryspace.com. Find the aircraft batteries and then look for the 8.4 volt "Firebird" batteries.
Bowbender is offline Find More Posts by Bowbender
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Setting a Throttle curve on a electric motor? vortechz230 Micro Helis 6 Aug 22, 2007 05:48 AM
AXI electric motor problem slowstick4ap Power Systems 3 Oct 15, 2005 05:45 PM
Desperately need help with motor interference problem Ken Lapointe Electric Plane Talk 8 Jun 22, 2001 06:40 AM