SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Apr 02, 2005, 09:26 PM
Brunswick, Ohio
BrunswickOH's Avatar
Joined Aug 2003
5,736 Posts
anybody else have problems with Etec 450 3's?

Has anybody else had problems with the etec 450 3's? I bought a pack at Toledo yesterday, went to put it in a new delta wing I'm putting together and voltage was so low it wouldn't power my watt meter, put it on a DVM and got crazy readings like it was an open circuit or something. I had already cut out the wing to fit this exact battery so I needed the same one. I thought no big deal, this happens so I went back to Toledo today (2 hours) and picked up another from the same vendor, I had run out without the bad one but he said just send it back and they would refund my money for it. I get home and same problem. Out of frustration I take the pack apart and am getting 3.76v out of each cell but nothing reading off of the little board used to solder the pack. I end up taking apart the 3 cells and soldering them together myself, now they work. What a pain this was, and I'm not an expert at soldering lipos so who knows if they will continue to work or not.

Jim
BrunswickOH is offline Find More Posts by BrunswickOH
Reply With Quote
Sign up now
to remove ads between posts
Old Apr 03, 2005, 09:47 AM
Brunswick, Ohio
BrunswickOH's Avatar
Joined Aug 2003
5,736 Posts
I'll take that as a NO, maybe I just got two bad ones! Oh well
BrunswickOH is offline Find More Posts by BrunswickOH
Reply With Quote
Old Apr 03, 2005, 06:46 PM
Registered User
los angeles
Joined Mar 2004
662 Posts
i have only one pack of the etec 3s 450's and they started going south after about 20 or 30 cycles and i don't fly to lvc, i time my flights and when i charge them they always start at 11.2 to 11.4 volts. i have 5 packs of tp 480's and their still going strong with over 100 cycles
skyhiflyhigh is offline Find More Posts by skyhiflyhigh
Reply With Quote
Old Apr 03, 2005, 06:53 PM
Brunswick, Ohio
BrunswickOH's Avatar
Joined Aug 2003
5,736 Posts
is the physical size of the two packs similar?? I've already got this pack cut into my wing so changing it will be a pain. I've got it in a setup drawing 3.8Awot and LVC setup for soft cutoff at 9v so it should never get abused in this plane.

Jim
BrunswickOH is offline Find More Posts by BrunswickOH
Reply With Quote
Old Apr 03, 2005, 07:19 PM
Registered User
los angeles
Joined Mar 2004
662 Posts
no the etecs are much narrower shaped like a pack of chewing gum, the tp pack is much wider and thinner 1.3in wide and .4 in thick and 2.1 in long. the polyquest 600 are shaped similar to the etec 450
skyhiflyhigh is offline Find More Posts by skyhiflyhigh
Reply With Quote
Old Apr 03, 2005, 07:40 PM
Southern Pride
everydayflyer's Avatar
Haralson County GA. USA
Joined Oct 2004
34,659 Posts
No experience with E Tec 450 s but I have had good experience s with 1200 Classic,and 730 HPs. I have posted graphs of most on mine in the battery vault.
I have always found to be a good value and the new 1000 HP a true 10C is very promising from what little data I have seen on it.
I have heard of rare cases of poor solder joints between the tabs and PCB . I resoldered a few of mine and it did seem to help a little. To me the lands are to light so I added solder to the traces(lands). I have only assembled a few packs from loose cells but tend to trust my work over others but hate paying more for lose cells than assembled packs.
Charles
everydayflyer is online now Find More Posts by everydayflyer
Reply With Quote
Old Apr 03, 2005, 08:01 PM
Brunswick, Ohio
BrunswickOH's Avatar
Joined Aug 2003
5,736 Posts
Looking at the board I could see no reason why it wouldn't work but after checking and rechecking at least 100 times I just took it apart as I could get a voltage reading from the individual cells. After I soldered them together voltage was fine, I've now done two easy discharges and charges. The pack seems to be working fine but there is no doubt that the tabs are more exposed then they were in the stock form. I did my best to protect them, time will tell.

Jim
BrunswickOH is offline Find More Posts by BrunswickOH
Reply With Quote
Old Apr 03, 2005, 08:16 PM
Registered User
Walled Lake, MI, USA
Joined Feb 2000
11,182 Posts
Jim, it's always a royal pain when you get a defective product and have to exchange it. Just the mileage you put on your vehicle making an extra round trip to Toledo probably cost more than the pack. It's really a bummer when you go to all that trouble and get a second defective one. On occasion, I've done the same with a non-functioning product as you did with the second pack and just fixed something myself instead of trying to return it. Hope you have good luck and the pack lives for you. Also hope you let the vendor know that it might be a common problem with that batch.
Dave Hederich is offline Find More Posts by Dave Hederich
Reply With Quote
Old Apr 03, 2005, 08:27 PM
Brunswick, Ohio
BrunswickOH's Avatar
Joined Aug 2003
5,736 Posts
I'll give them a call Monday and let them know! Yes it was an extra 230 miles to make matters worse I bought the new 450 pack was walking around picked up a few other items that I "needed" looked down and the new battery had fallen out of my shopping bad!!! Looked around and it was gone, I hope that it was also bad so whoever picked it up gets a surprise when they try to plug it in! So I then went back and purchased a THIRD pack (they said they will refund the first one so I'm really only on the hook for two)

The second trip was fun though, one of my neighbors went with me and we got to walk around a lot and I saw some things I had missed the first time. Even got home before the snow really got bad.

Jim
BrunswickOH is offline Find More Posts by BrunswickOH
Reply With Quote
Old Apr 03, 2005, 09:10 PM
Registered User
los angeles
Joined Mar 2004
662 Posts
jeez, u really r having some bad luck, i'm sure someone is feeling lucky but your rite, probably a bad batch and won't do them any good
skyhiflyhigh is offline Find More Posts by skyhiflyhigh
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Anyone else have problems with bug blades? hb888 Micro Helis 13 Sep 28, 2005 05:53 PM
Anyone else have problems with GWS recievers? STaNgXs GWS (Grand Wing Servo) 46 Mar 13, 2005 10:56 AM
Anyone else have problems with GWS radio batteries leaking? C172 Beginner Training Area (Aircraft-Electric) 9 Jun 25, 2004 05:01 PM
Anybody else have problems with ArtHobby Aileron horns? rlt55 Sailplane Talk 2 Apr 23, 2002 08:22 PM