New Products Flash Sale
Thread Tools
Old Dec 16, 2004, 03:29 PM
STaNgXs is offline
Find More Posts by STaNgXs
Registered User
Huntington Beach, CA
Joined Sep 2004
531 Posts
Elevator Trim On My Optic 6 Not Working?

when I try to tril the elevator, it doesn't move the servo.. the reeading tells me it's moving, but the servo stays still... anyone know what my problem is?
STaNgXs is offline Find More Posts by STaNgXs
Reply With Quote
Sign up now
to remove ads between posts
Old Dec 16, 2004, 04:09 PM
rcguy01 is offline
Find More Posts by rcguy01
Permanently Banned
Joined Apr 2003
3,171 Posts
change the servo, maybe just a bad servo.
rcguy01 is offline Find More Posts by rcguy01
Reply With Quote
Old Dec 16, 2004, 04:15 PM
ivanc is offline
Find More Posts by ivanc
S.A.D. member
ivanc's Avatar
United States, TX, Round Rock
Joined Dec 2004
10,247 Posts
Your Tx might be in Stick Mode 1 - change it to Mode 2 as described on page 7 in the manual.
ivanc is offline Find More Posts by ivanc
Reply With Quote
Old Dec 16, 2004, 04:31 PM
STaNgXs is offline
Find More Posts by STaNgXs
Registered User
Huntington Beach, CA
Joined Sep 2004
531 Posts
Quote:
Originally Posted by ivanc
Your Tx might be in Stick Mode 1 - change it to Mode 2 as described on page 7 in the manual.
heh, thanks.. i'll try that when I get home
STaNgXs is offline Find More Posts by STaNgXs
Reply With Quote
Old Dec 16, 2004, 07:21 PM
rutat is offline
Find More Posts by rutat
Registered User
Joined Mar 2004
5,237 Posts
Check your EPA etc. My Optic was obviously (re)set with strange numbers and NO servo movements were happening when I first got it. A quick call to Poway fixed it though!
rutat is offline Find More Posts by rutat
Reply With Quote


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! Need expert advice on hooking up my Optic 6 with RealFlight G3 funfly123 Mini Helis 7 Nov 21, 2006 09:13 AM
Discussion want to disable the trim levers on an optic 6 geneween Hitec/Multiplex USA 6 Aug 24, 2006 03:12 PM
Optic 6 not working swa2153 Hitec/Multiplex USA 2 Aug 19, 2005 10:12 PM
Esc on my Sportster EP... not working!!!!! Awall Sport Planes 7 May 27, 2005 10:34 AM
Want to use fast charger on my Optic 6 RonJ Hitec/Multiplex USA 6 Mar 20, 2005 06:28 AM